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Preface

Welcome to the TB8100 Service Kit User’s Manual. This manual provides you 
with information about the Tait TB8100 Service Kit in PDF format. You can 
view it online or print it if you want a paper copy. It describes how to use 
Version 03.00 of the Service Kit. 

■ New Service Kit users should begin at Part B: Getting Started.

■ For explanations of essential concepts, look in Part A: Introduction. 

■ The rest of the manual assumes that you are familiar with Part C: Basic 
Tasks.

Typographical Conventions
‘File > Open’ means ‘click File on the menu bar, then click Open on the list of 
commands that pops up’. ‘Monitor > Module Details > Reciter’ means ‘click 
the Monitor icon on the toolbar, then in the navigation pane find the Module 
Details group, and select Reciter from it’. 

Associated Documentation
All available TB8100 product documentation is provided on the CD supplied 
with the base station. Updates may be published on the Tait support web.

Online Help. The Service Kit also has online Help. It contains more or less the 
same information as this manual. To view it, start the Service Kit, then press F1 
or click the Help icon on the toolbar. If you are in a dialog box, click the Help 
button. The Alarm Center and the Calibration Kit also have online Help.

TB8100 Installation Guide.

TB8100 Operation Manual.  

CTU Operation Manual (MBA-00013-xx). Instructions on using the calibration 
and test unit.

TB8100 Service Manual. (service centers only) 

TB8100 Product Catalog provides information about base station parts and 
modules.

Technical notes are published from time to time to describe applications for 
Tait products, to provide technical details not included in manuals, and to offer 
solutions for any problems that arise. Look for them on Tait’s technical support 
website. The following have been published or are in development:

TN-742 Remotely Monitoring and Configuring the Tait TB8100.

TN-743 Using the TB8100 Base Station as a Talk-Through, Community, or Linked 
Repeater .

TN-744 Using the Tait TB8100 as a Line-Connected Base Station.

TN-745 Using the Tait TB8100 in TaitNet Trunked Networks.

TN-906 Connecting to TB8100 Base Stations Via an Asynchronous Port Switch.

TN-947-AN TB8100 Base Station Computer Controlled Interface Protocol.

TN-1047 Using a TB8100 in Paging Applications.

TN-1114-AN Using a TB8100 with an External Modem.

TN-1142-AN  Connecting to a TB8100 via Ethernet.

TN-1154-AN Task Manager Programming Guide.
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Publication Record

Issue Date Description

1 June 2003 First release of the manual. Describes version 
1.00 of the Tait TB8100 Service Kit software.

2 March 2004 Second release of the manual. Describes 
version 02.00 of the Service Kit. 

3
MBA-00010-03

September 
2004

Describes version 02.01 of the Service Kit. 
This includes support for connection via an 
Asynchronous Port Switch.

MBA-00010-04 March 2005 Describes version 02.05 of the Service Kit. 
This includes Tone on Idle. 

MBA-00010-05 April 2006 Describes version 03.00 of the Service Kit. 
This includes remote connection via Ethernet.
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Part A Introduction

The Service Kit is a Windows-based software program that 
makes it easy to monitor and configure a Tait TB8100 base 
station. You can also use it to carry out diagnostic tests and to 
update the base station’s firmware. 

The introduction explains concepts that are fundamental to the 
base station. You need to understand them before you can use 
the Service Kit effectively.

Topics

From T800 to TB8100

Operation Modes

Channels

Profiles

Subaudible Signalling

Power Saving

Task Manager

Remote Connections

Alarms

System Interface

Software Feature Enabler
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From T800 to TB8100

The TB8100 is a software-based radio. This means that its programming 
software has far more scope. For those who are familiar with the Tait 
PGM800Win programming software, here are some key differences. 

The Service Kit does more than configure channels. It can monitor 
operational details, receive alarms, and carry out diagnostic tests. It can 
switch the base station’s operating mode from Run to Standby and back 
again and even reset the base station or upgrade its firmware. It also lets you 
edit Task Manager tasks, which enables you to customize the TB8100 for 
individual applications. See “Task Manager” on page 9.

The Service Kit can connect remotely to the base station via dial-up 
modems. You can make routine monitoring checks and carry out diagnostic 
tests without needing to travel to the site.

The channel table does more than define the transmit and receive 
frequencies and the frequency of the tone used for CTCSS. It specifies a 
whole range of operational parameters. Because there are so many 
configurable parameters, most are grouped into profiles. There are two 
kinds of profiles: channel profiles and signalling profiles. See “Profiles” on 
page 6.

The Service Kit provides both a simple and a complex method for 
configuring the channel table. The simple way uses default profiles and lets 
you edit items directly in the table. The complex way is available if the base 
station has an Advanced Profiles and Task Manager license. You define a set 
of custom profiles then select the right ones for each channel. 

Custom profiles make it possible for you to assign up to 16 subtones to any 
channel, meaning that a tone panel is not needed for most applications.

The Service Kit can configure signal paths. In effect this means that you can 
customize ‘virtual backplanes’. These are profile-based so that the base 
station can change its virtual backplane in the middle of operations. For 
example, a Task Manager action can change the base station from a line-
connected base station to a talk through repeater, simply by changing to a 
channel with a different custom profile. 
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Operation Modes

A base station can operate in three different modes. Some functions are disabled 
until you shift the base station into the required mode. 

Run mode is used for normal operation. 

Standby mode is required if you want to program the base station or carry 
out diagnostic tests on it. Standby mode puts the base station out of service. 
However it will still transmit if you push the Carrier button on the control 
panel, use a microphone, or carry out a transmission test. 

Download mode is required if you want to update the base station’s 
firmware. (The base station automatically enters Download mode if it has a 
fundamental problem.)

Appropriate messages alert you to the need to change mode so that you do not 
inadvertently leave the base station out of service when you end a Service Kit 
session. Alternatively, you can configure the base station to automatically revert 
from Standby to Run mode after the Service Kit logs off.

The Mode icon on the toolbar displays the current mode of the base station you 
are logged in to. 

It is in the form of a traffic light:

Green indicates Run mode

Orange indicates Standby mode

Red indicates Download mode

Click on it to change mode.

The status bar also displays the current mode. 



TB8100 Service Kit User’s Manual   Channels 5

Channels

A TB8100 base station consists of the equipment needed to operate on just one 
channel. However, using the Service Kit you can program up to 255 channels 
into a single base station. This is confusing, until you realize that ‘channel’ has 
different meanings. The one channel is the transmit and receive frequency pair 
and the 255 channels are different channel configurations, each with its own 
number and name. You select one of these channel configurations and the base 
station operates according to all the settings defined by it. These include a 
transmit and receive frequency pair, a transmitter power output, a channel 
spacing, and many other configurable items.

Channel Table Each base station has a channel table. This is the database that stores the channel 
configurations. It is a good idea to maintain a single channel table for your 
system. This means that you can use almost the same configuration file for all 
base stations. To configure a new or replacement base station, all you need to 
do is copy the standard configuration file and select a different default channel. 
This simplifies maintenance. Alternatively, you can use the Export and Import 
functions to copy channels from one base station to another.

Default Channel You need to tell the base station which channel to use. The usual way to do 
this is to use the Service Kit to select one channel in the channel table as the 
default channel. When the base station starts up for the first time, it selects the 
default channel unless it is connected to external equipment that selects the 
channel. 

Current Channel The current channel is the channel that the base station is actually using. 
Usually, this is the default channel. However, external equipment can use 
digital input lines to choose another channel. Moreover, Task Manager can 
instruct the base station to change channel. It can even select another channel 
to be the default. Monitor > Monitoring > Channel displays the current 
channel.

Note: If the base station is reset, it starts up on the default channel, 
unless external equipment defines another channel.
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Profiles

Profiles are groups of configuration settings. They simplify the task of 
configuring channels. The base station has a large number of configuration 
settings, but most of these will be the same for all channels. Instead of 
configuring all options many times over for each channel, you configure them 
once in a profile. You then assign the profile to the appropriate channels (if you 
are working with the default profile, this is already done for you). 

Two profiles group almost all configuration settings: the channel profile (which 
defines the signal path for example) and the signalling profile (which defines the 
subaudible signalling and tail timers). 

The way you work with profiles varies, depending on whether the base station 
has an  Advanced Profiles and Task Manager license.

Using Default 
Profiles

The standard base station can only use the default profiles. You define most 
configuration settings globally in the two default profiles, and then you define 
the rest individually for each channel in the channel table. 

Using Custom 
Profiles

If the base station has the Advanced Profiles and Task Manager license, 
additional options are available and you can create a set of custom profiles. To 
configure an individual channel, you assign custom profiles to it. The only items 
you configure in the channel table are the transmit and receive frequencies. 
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Subaudible Signalling

The TB8100 base station can transmit and receive using subaudible signalling. 
Both CTCSS tones and DCS codes are supported. CTCSS attaches a 
subaudible tone to the carrier signal. DCS attaches a digital code. A receiver 
programmed with a particular tone or code will not unmute unless that tone or 
code is presented with the RF signal.

CTCSS tones and DCS codes are referred to collectively as subtones. Subtones 
make it possible for different groups of users to operate on the same channel 
without hearing or disturbing each other. The base station and the radios that 
use it need to be programmed with the same subtone(s). In some parts of the 
world, the use of subtones is regulated.

Assigning 
subtones

You assign a receive and a transmit subtone to a channel by editing the channel 
table. When the base station is operating on that channel, it opens the receiver 
gate to signals with the receive subtone and transmits using the transmit 
subtone.

If the base station has a license for the Advanced Profiles and Task Manager 
feature set, you can use a custom signalling profile to assign up to 16 subtones 
to a single channel. The receiver recognizes any of the assigned tones and 
responds according to its configuration for the particular tone. It can transmit 
the signal (encoding it with the same subtone), transmit the signal (with a 
different subtone), or carry out a Task Manager action. You can also add an 
audible reminder tone to the transmissions (for example, for customers who are 
behind with their payments). The 16 subtones can contain CTCSS tones and 
DCS codes. 

Reverse tone 
burst/end tone

The base station always transmits a DCS end tone for muting the receive audio, 
but transmitting a CTCSS reverse tone burst is optional and configurable. 
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Power Saving

The TB8100 base station can save power by switching off parts of its circuitry. 
The standard base station has a limited ability to reduce the current that the base 
station uses, but the Power Saving Modes license lets you configure three 
different power saving modes. This gives greatly increased flexibility and makes 
it possible to get the power savings needed with a minimum sacrifice in quality 
of service. 

Note: Power saving only occurs when the base station is battery-
powered. It is not available if the PMU supplies more than one base 
station.

Power saving 
modes

A base station with a Power Saving Modes license can operate in Normal, 
Sleep, and Deep Sleep modes. These modes are enabled and configured in the 
Service Kit. 

The base station begins in Normal mode. If the base station is idle (receives no  
valid signal) for a defined length of time, it switches to Sleep mode, which saves 
more power. If the base station is idle for a further defined length of time, it 
switches to Deep Sleep mode, saving even more power. When it receives a 
valid signal, it reverts to Normal mode.

Both receiver and transmitter contribute to the power saving.

The receiver is switched off, and then periodically switched back on. If it 
detects a valid signal, it stays on, otherwise it is switched off again. The power 
amplifier is always off when the base station is not transmitting. In power saving, 
other parts of the transmitter circuitry are switched off as well. The longer the 
Tx keyup time you select, the more circuitry is switched off. 

Response times The more power saved, the longer the response time. Initially, the radio user 
needs to press PTT and wait before speaking, to give enough time for the 
receiver to come back on and for the transmitter to key up. 

Configuring 
power saving 

You configure power saving when you define the channel profile that the base 
station will use. For each mode, you specify Rx cycling (how long the receiver 
stays switched off before it wakes up to check if there is a valid signal) and Tx 
keyup (how long it takes for the transmitter to key up). In addition, you specify 
how long the base station must be idle before it enters Sleep and Deep Sleep 
modes. The exact amount of power saved varies, depending on the model of 
base station and the pattern of traffic.
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Task Manager

Task Manager is the ‘brains’ of the base station. When something changes, Task 
Manager carries out actions based on the intelligence contained in its list of 
tasks. Each task defines what you want the base station to do in response to a 
particular event. 

For example, when the battery voltage low alarm is triggered, Task Manager 
can tell the transmitter to reduce its power output. If an alarm you want to 
know about is triggered, Task Manager can tell the base station to start the over-
the-air alarm or email you a status message via the Alarm Center. If a line-
controlled base station’s line fails, Task Manager can tell the base station to 
function as a talk through repeater. 

Task Manager is essential for sending alarms to the Alarm Center, for emailing 
alarms and status messages, and for turning over-the-air and over-the-line 
alarms on and off. It can also carry out override actions that enable or disable 
many configured base station functions. 

If the base station has an Advanced Profiles and Task Manager license, you can 
initiate any action simply by sending the base station a CTCSS tone or DCS 
code. Task Manager can also change the whole operating configuration simply 
by changing to another channel that uses different profiles.

Task Manager only operates when the base station is in Run mode. 

Modifying Task Manager
To change the way Task Manager works, you add and modify tasks using the 
Service Kit, and then you program the changes into the base station. In effect, 
you are creating scripts that make the base station perform simple actions. This  
customizes the way the base station operates without modifying its firmware. 
Task Manager can perform many functions that previously required expensive 
external equipment. 
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In a standard base station, Task Manager can process up to 20 tasks. In a base 
station with an Advanced Profiles and Task Manager license, Task Manager can 
process up to 200 tasks.

Tasks and Comments
Task Manager acts only on the basis of the tasks in its task list. A task is rather 
like computer code and takes the form: 

 IF < input> THEN <action> 

When the IF part of the task becomes true, the THEN part is executed. There 
are also IF NOT tasks: when the input of such a task becomes false, the THEN 
part is executed. You can add comments describing the purpose of a task or 
group of tasks. Comments have no effect on Task Manager processing. 

Inputs
Task Manager inputs are of two main types, ‘basic’ and ‘override.’ Tasks are 
processed differently, depending on the kind of input they have. You need to 
understand these differences if you are creating complex sets of tasks.

Basic inputs Basic inputs come from various parts of the base station. They include all alarms. 
While basic inputs can become true at any time, Task Manager will only process 
them in the course of the regular 10 ms processing cycle. For example, if an 
input becomes true in the middle of a processing cycle, Task Manager won’t 
process tasks with that input until the next processing cycle. This is because it 
only learns of the change after the completion of the first cycle. 

Override inputs Override inputs can only become true through a Task Manager override action. 
They are internal to Task Manager. Most become true automatically each time 
the base station enters Run mode. 

There are some other inputs that don’t quite behave like basic or override 
inputs. Look under the input for more information.

Actions
Task Manager actions are of two main types, ‘override’ and ‘do now’. These 
actions have different effects. 

Override actions Override actions enable, disable, or toggle a configured base station function. 
As most of these functions are enabled by default, the main use of override 
actions is to let you turn off a function such as talk through repeater, power 
saving, or even the receiver as a whole. The action changes the state of a flag, 
which can only be changed by another override action. The status of each flag 
that is controlled by an override action is displayed in Monitor > Base Station 
> System Flags. 

This flag can also be an override input. When an override action is carried out 
(for example Enable power saving), the equivalent override input (for 
example Power saving enabled) becomes true and any tasks with that input 
will be processed. 
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Important: Override actions only enable a function if the base 
station is already configured for that function using the Service Kit. 
For example, enabling the talk-through repeater function will only 

have an effect if the current profile defines a talk-through repeater signal path. 
If the function is not configured, enabling, disabling, or toggling it will have no 
effect.

’Do now’ actions ‘Do now’ actions issue a command to the base station to do something 
immediately, for example to change channel or send the alarm log. This is a 
one-off action which has no continuing effect on the base station’s status. A ‘do 
now’ action cannot be re-triggered until the original action is completed. For 
example, Task Manager cannot carry out the action Transmit CWID now 
when the base station is still transmitting the CWID from a previous Transmit 
CWID now action. 

There are some other actions that don’t quite behave like override or ‘do now’ 
actions. Look under the action for more information.

Custom Inputs and Actions
A task can only have one input and one output. However, you can combine 
existing inputs or actions to form your own custom inputs or actions. 

A custom input combines up to eight different inputs. It becomes true when 
the combination becomes true, according to the rules of the Boolean logic that 
you specify for the combination.

Similarly, a custom action can combine up to eight actions. When a task with 
a custom action is processed, all its constituent actions are carried out. 

You can also use counters, timers, and your own flags when defining tasks.
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Remote Connections

The TB8100 base station is designed for remote monitoring, diagnostics, 
configuration, firmware upgrade, and control. The Service Kit can carry out all 
these functions remotely. Provided a remote link is in place, you can connect 
and log on to the base station just as if you were directly connected.

For each remotely linked base station, you need to create a ‘connection,’ which 
is a named configuration that tells the Service Kit how to communicate with 
the base station.

It is possible to limit remotely connected Service Kit users to read-only access 
to diagnostics and configuration or even to deny access completely. Local and 
remote connections have separate access profiles.

Remote connections can be modem dial-up (using RS-232) or Network (using 
TCP/IP over Ethernet).

Dial-up 
connections

Dial-up connections require a telephone line with modems at each end. If there 
are a number of base stations at a single site, a third party asynchronous port 
switch makes it possible to connect to any base station over the one telephone 
line.

With an Alarm Reporting license, the base station can be remotely connected 
to an Alarm Center. On Task Manager instruction, the base station uses its 
modem to dial up an Alarm Center and pass on its alarm log or send a status 
message for emailing. The modems must support the Hayes ‘AT’ protocol. 

Network 
connections

Network connections require hubs or switches, routers, and a data link with 
sufficient bandwidth. The base station must be fitted with a system interface 
board containing an Ethernet interface. The base station can be configured to 
send alarm messages to a central third party syslog collector. A heartbeat message 
can also be enabled, so that the syslog collector can report any failure of the base 
station.  
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Alarms

The base station monitors a large number of conditions. When a condition rises 
above or falls below a defined threshold, the base station generates an alarm and 
stores it in its alarm log. The alarm log contains the 50 most recent alarms.

Some alarms are inappropriate for particular systems; you can disable any that 
you do not want. 

Most alarms indicate a fault condition, but some are generated by conditions 
external to the base station, such as mains power failure or loss of RF input. 

Alarm Notification Options
The base station is able to notify you in the following ways when an alarm is 
activated: 

Transmitting pip tones

Sending pip tones over the line

Activating a digital output line

These methods are configured in the Service Kit but enabled by Task Manager 
action. As Task Manager has an input for each alarm, its response can vary 
depending on the alarm. You can create Task Manager tasks that optimize the 
response for your particular system. 

In addition, alarms can be sent to an Alarm Center or to a syslog collector, 
depending on whether the base station is remotely connected via RS-232 or 
Ethernet. 

Enabling Alarm Notification
Alarm notification methods need to be set up and configured. Choose carefully 
which ones to implement, based on the available resources and your policy for 
remote monitoring. See TN-742, Remotely Monitoring and Configuring the Tait 
TB8100, for details.

To set up an alarm notification method, you may need a physical link (for 
example, modems and a telephone line). Then you use the Service Kit to 
configure the method. Finally, you define suitable Task Manager tasks. When 
something happens, a task is processed that tells the base station to use the 
method to notify the alarm. Tasks can initiate notification:

When the base station is started or reset 

When any alarm occurs

When particularly important alarms are triggered
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System Interface

The base station reciter can be fitted with a system interface board. Several 
different boards make a variety of inputs and outputs available for different 
applications.

Select Monitor > Module Details > Reciter to see which system interface is 
fitted. Select Configure > Base Station > System Interface and choose the 
system interface that is fitted. The System Interface form now displays the 
current pin assignments and lets you configure some of them for external 
channel assignment. In addition, Task Manager actions make it possible to 
configure digital input lines to have any of a wide range of functions.
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Software Feature Enabler

The TB8100 base station has many capabilities, but some of them require a 
license before you can use them. The Service Kit lets you enable the feature sets 
you require. The following feature sets are available:

Default Radio 
System

Generally, base stations are already licensed with the Default Radio System 
feature set. Without it, the base station cannot operate in Run mode, but could 
be used for training.

Alarm Reporting The Alarm Reporting feature set enables the base station to remotely dial up 
using a modem. This means that the base station can report alarms to an Alarm 
Center or email status messages to a technician (this is done via the Alarm 
Center). 

Advanced Profiles 
and Task 
Manager

The Advanced Profiles and Task Manager feature set enables the base station to 
operate according to custom channel and signalling profiles that you define 
using the Service Kit. It also lets Task Manager process up to 200 tasks.

Power Saving 
Modes

The Power Saving Modes feature set makes it possible for the base station to 
operate in Sleep and Deep Sleep modes. This takes full advantage of the power 
management unit’s power saving capabilities. 
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Part B Getting Started

Establishing a Service Kit session with a base station is a three-
stage process. First you connect a cable (or set up a remote link), 
and then you establish communications with the control panel. 
Finally, you log on.

In a Service Kit session, you can monitor the base station and 
carry out diagnostic tests. You can also view the base station’s 
configuration.

To learn how to program the base station, go straight to the 
configuration tutorial.

Topics

Connecting and Logging On

Monitoring Alarms

Monitoring the Base Station

Viewing Configuration Settings

Diagnosing Problems

Configuration Tutorial



18 Getting Started     © Tait Electronics Limited April 2006



TB8100 Service Kit User’s Manual   Connecting and Logging On 19

Connecting and Logging On

The following instructions describe how to connect a Service Kit to a base 
station via a direct RS-232 link to the control panel. For more detail, see 
“Connecting to a Base Station” on page 44 and “Logging On” on page 46. 

To connect and log on to a base station

1. If the Service Kit is not already running, select Start > Programs > Tait 
Programming Applications > TB8100 Service Kit.

2. Connect the supplied cable or a standard mouse extension cable from a serial 
port on your PC to the serial port on the control panel. 

3. If the subrack has more than one base station, make sure that the control 
panel selects the base station you want to connect to. 

4. On the toolbar, click Connect. The Connecting dialog box appears.

5. In the Connect to box, select a connection for the serial port you used. The 
Type field now shows ‘Direct connection.’ 

6. Click Connect. 

7. If the reciter is fitted with an Ethernet interface, turn its power off and then 
on again; the control panel serial port is only available straight after base 
station start-up.

Once the connection is established, the Log On dialog box appears.

8. Log on to the base station as follows.

a. Select an access level. 

b. Enter the password for that level of access to the base station. (For more 
information, see “Logon Details” on page 47.)

c. Click OK to log on and close the dialog box. The status bar shows the 
name of the connection and the base station you are logged on to.

You can now monitor the base station, conduct diagnostic tests, and read and 
modify the base station’s configuration.
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Monitoring Alarms

When you are logged on to a base station, the Service Kit regularly polls the 
base station for alarms. If an alarm is detected, a flashing Alarms icon appears in 
the status bar. If the Alarms icon disappears, the Service Kit has detected that 
the alarm was cleared.

To monitor alarms

1. Check the status bar. If it has a flashing Alarms icon, click the Alarms button 
on the toolbar. This opens the Current Status form.

2. Look to see which LED is flashing red. A flashing LED means that the alarm 
is on. One problem can set off more than one alarm. 

Tip: To view a list of recent alarms, select Monitor > Alarms > 
Reported Alarms. 

Note: Most monitoring forms have an Alarm Status LED, which 
indicates whether the module has any active alarms.
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Monitoring the Base Station

Once you are logged on to a base station, you can monitor various aspects of it. 

To view a monitoring form

1. On the toolbar, click Monitor. The navigation pane displays a menu of 
options. 

2. In the navigation pane, click a subheading (for example ‘Reciter’).

The main part of the Service Kit window displays information relevant to 
the subheading.

Options To view the current status of all base station alarms, select Alarms > Current 
Status.

To view information about the modules belonging to the base station, select 
an item under Module Details.

To view information about the way the base station is currently operating, 
select an item under Monitoring.
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Viewing Configuration Settings

From the Service Kit, you can view a base station’s configuration settings. This 
information must be read after you have logged in to the base station. 

To view configuration settings

1. On the toolbar, click Read. 

The Reading dialog box displays progress.

2. On the toolbar, click Configure. The navigation pane displays a menu of 
options. 

3. In the navigation pane, click a subheading (for example ‘General’); the main 
part of the Service Kit window changes to display the corresponding form. 

In this way, you can view any aspect of the base station’s current 
configuration. 
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Diagnosing Problems

From the Service Kit, you can carry out a variety of tests on aspects of the base 
station you are logged on to. These can help you diagnose any problems you 
may be experiencing. The base station must be in Standby mode, which takes 
it out of active service.

To carry out a diagnostic test

1. On the toolbar, click Diagnose. The navigation pane displays a menu of 
options. 

2. Click the Mode icon and select Standby mode. This takes the base station 
out of service.

3. In the navigation pane, click a subheading (for example ‘Self Tests’); the 
main part of the Service Kit window changes to reflect your selection. 

4. Click Start Test. View the results of the test on-screen.

5. If necessary, click Stop Test.

6. Return the base station to Run mode. 
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Configuration Tutorial

The following tutorial shows you how to make some basic changes to the 
standard configuration that turn the TB8100 into a basic repeater. You modify 
the signal path, change from carrier gating to noise gating, optionally configure 
subaudible signalling, and set the receive and transmit frequencies. The aim is 
to get you started and to introduce you to some of the many configuration 
settings that are covered in the online Help and the manual. 

Step 1: Install the Service Kit and Calibration Kit on your PC
1. Insert the CD-ROM in your CD-ROM drive. 

2. If the CD does not autoplay, select Run from the Start menu and use the 
Browse button to select Setup.exe from the d: drive, where d is the 
CD-ROM drive, 

3. Follow the on-screen instructions.

You are given the opportunity to install the Alarm Center as well. If your 
system is designed for an Alarm Center, do this separately on a dedicated PC.

Note: If the base station does not have the required switching range, 
use the Calibration Kit to adjust it. This should be done before you 
configure the base station. See the Operation Manual and the 

Calibration Kit online Help for instructions.

Step 2: Connect and Log On
1. Using the cable supplied, connect a serial port on your PC to the serial port 

on the subrack front panel. 

2. Select Start > Programs > Tait Programming Applications > TB8100 
Service Kit.

3. On the toolbar, click Connect. 

The Connecting dialog box appears.

4. In the Connect to box, select COM1 Connection or COM2 Connection, 
depending on the serial port you connected the cable to.
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5. Click OK. The Log On dialog box appears.

6. Select the User access level and enter the equivalent password (the default is 
user).

7. Click OK to log on.

Tip: You can get the base station receiving and transmitting on the 
frequencies you want without changing its configuration. Use the 
set receiver frequency and transmission diagnostic tests. 

Step 3: Read the Base Station’s Configuration
1. Click Read. The Reading dialog box displays progress.

2. Click Configure. The navigation pane displays a menu of options for 
configuring the base station. 

Step 4: Configure the Base Station as a Talk-Through Repeater
1. In the navigation pane, under Base Station, click General.

2. Click Channel Profile. The Edit Channel Profile dialog box appears.
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3. In the Receiver gating area, clear the RSSI gating check box and select the 
SINAD gating check box. Specify a level of 12 dB and a hysteresis of 6 dB. 

4. Click the Signal Path tab.

5. In the Talk through repeater list, click RxA- TxA. A thick line now 
connects the receive Path A to the transmit Path A.  
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6. Make any other changes to the default channel profile, and click OK.

Step 5: Configure a Channel
1. In the navigation pane, under Base Station, click Channel Table.

2. Decide which channel the base station will operate on.

3. In that channel’s row, enter receive and transmit frequencies.

4. Click in the Receive Signalling cell and select a CTCSS tone or DCS 
code. Do the same for Transmit Signalling.

5. Use the scroll bar to display the hidden columns in the table. 

6. In the Filter column, select Pre-De-Emph Speech Band. 

7. In the Channel Spacing column, select an option.

8. Click OK.

Step 6: Set the Default Channel.
1. Return to the General form. 

2. In the Default channel area, select the channel you configured.

3. Click OK.

Step 7: Program the Changes into the Base Station
1. Click Save to save your changes to a file, giving it a suitable name.

2. Press F5 to put the base station in Standby mode.

3. Click Program. The Programming dialog box appears and indicates 
progress.

When all the configuration information has been downloaded, it is 
programmed into the base station. When the Service Kit receives 
confirmation of this, it closes the dialog box. 

4. Press F6 to return the base station to Run mode. It is now operational.
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Part C Basic Tasks

Before you can get down to the real work on a base station, you 
need to know how to carry out basic tasks such as setting up a 
connection, changing the base station’s mode, or reading 
configuration information. 

The Basic Tasks section explains in detail how to do these and 
other preliminary tasks. 

Topics

Using the Service Kit

Setting Service Kit Options

Setting Up and Configuring Connections

Connecting to a Base Station

Logging On

Changing Base Station Mode

Working With Base Station Configurations

Logging Off and Disconnecting

Changing Base Station Passwords

Access Profiles

Working with Different Versions

Upgrading Base Station Firmware

Working with the Software Feature Enabler
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Using the Service Kit

When you start the Service Kit, a splash screen appears, followed by the 
application window.

By default, the Monitor icon on the toolbar is selected and the navigation pane 
gives you options for monitoring. When you click an item in the navigation 
pane, the main pane displays the corresponding form.

Toolbar
The toolbar gives you quick access to commonly used menu commands. For 
example, instead of selecting Base Station > Configure, click the Configure 
icon on the toolbar.

Open Lets you open a configuration file that is stored on the Service Kit computer.

Save Saves the open configuration. When saving a configuration file for the first 
time, you are asked to give it a name. 

Connect Lets you select a base station and then connect to it. When you are connected, 
the button changes to Disconnect. See also “Connecting to a Base Station” on 
page 44.

Log on Lets you log on to a base station, once you are connected. When you are logged 
on, the button changes to Log off. See also “Logging On” on page 46

Read Reads in the configuration information of the base station you are logged on 
to. See also “Working With Base Station Configurations” on page 49.

Navigation pane

Status bar

Menu bar

Main pane

Toolbar
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Program Sends the whole set of configuration information in the Service Kit to the base 
station. The base station must be in Standby mode. Once programmed, the base 
station operates using the new configuration. See also “Working With Base 
Station Configurations” on page 49.

Mode Lets you change the base station’s operation mode. The traffic light indicates 
the current mode. Green means Run mode, Orange means Standby mode, and 
Red means Download mode. See also “Operation Modes” on page 4.

Monitor Lets you monitor the base station. See also “Monitoring the Base Station” on 
page 21.

Configure Lets you view and edit a configuration. If a configuration is not already selected, 
you are given the option of creating a new configuration, opening an existing 
one, or reading the base station’s current configuration. See also “Viewing 
Configuration Settings” on page 22.

Diagnose Lets you carry out diagnostic tests on the base station. See also “Diagnosing 
Problems” on page 23.

Alarms Turns red when any base station alarm is triggered. Click Alarms to display the 
current status of all base station alarms. See also “Monitoring Alarms” on 
page 143.

Help Displays a Help topic for the form or dialog box you are currently in.

Status Bar
The status bar provides you with useful information that supplements the 
display in the main pane.

 

Miscellaneous essages appear on the left. ‘Ready’ means that the Service Kit has 
completed the last user request and is ready to respond to another request. 

Panels in the status bar display the following:

Flashing alarm icon. When a base station alarm is triggered, a flashing alarm 
icon appears.

Service Kit requests. 

Connection. The name of the connection currently being used.

Base station. The name of the base station that the Service Kit is logged on 
to.

Connection speed. The speed of the RS-232 connection to the base station. 
The speed is as reported by the base station. For remote connections, this 
will in fact be the configured speed of the base station modem, not the 
overall speed of the remote link

IP address. If the base station is connected via Ethernet it displays its IP 
address instead of the connection speed.

Miscellaneous 
messages

Service Kit requests Connection 
speed/IP address

Flashing alarm 
icon

Base station

Connection 
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Setting Service Kit Options

The Options dialog box (Tools > Options) lets you indicate some preferences.

Temperature 
units

The Temperature units area specifies whether the Service Kit displays 
temperatures in Celsius or in Fahrenheit.

Default file locations
The Default file locations area specifies folders for configuration files, log files, 
license files, and firmware files. To modify a default location, click the button 
to the right of the box and select a folder.

Configuration 
files

When you save a configuration file for the first time, the folder specified in the 
Configuration files box is shown in the dialog box. You can select another 
folder if you want. (You already chose a folder for configuration files during 
installation.) 

Log files Specifies where the Service Kit stores the alarm log and error log.

License files Specifies where the Service Kit will look for license files when you ask it to 
enable additional feature sets in a base station. If you receive a license file, copy 
it to this folder.

Firmware files Specifies where the Service Kit will look for firmware files when you ask it to 
download new firmware into a base station. If you receive new firmware for a 
base station upgrade, copy it to this folder.
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Setting Up and Configuring Connections

The Connections dialog box (Tools > Configure Connections) displays user-
defined connections. It lets you add new connections, edit existing ones, and 
arrange the connections in a tree structure that reflects the location of the base 
stations in the network. You can also import connections from or export them 
to other Service Kits. When you connect to a base station, you select one of the 
connections that you have created or edited.

There are different connection types, reflecting the different ways that the 
Service Kit can be physically connected to a base station. You only need one 
connection for connecting directly to any base station, but you need a different 
connection for each remotely connected base station. 

 

If your PC has no serial port, obtain a USB to Serial (DB9) converter. When 
the driver for this is installed, the operating system makes a virtual serial port 
available.

Physical Connection Options
There are various ways of physically connecting the Service Kit to a base 
station. The set of user-defined connections available to the Service Kit must 
reflect the ways that the Service Kit PC will be physically connected to the 
different base stations.
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Local Connection 
to the Control 
Panel

The simplest connection uses an ordinary RS-232 modem cable to connect the 
PC’s serial port to the serial port on the control panel. If the subrack has more 
than one base station, you need to select the base station using the control panel 
before connecting to it.

The SK communicates over this physical configuration using a Direct 
connection type. 

Local Connection 
to the System 
Interface

If the base station’s reciter is fitted with a TaitNet RS232 system interface, 
connect the PC to the serial port on the system interface at the rear of the base 
station. The control panel serial port is not available. If the subrack has more 
than one base station, one serial port is available for each base station, provided 
they have TaitNet RS232 system interfaces.  

The Service Kit communicates over this physical configuration using a Direct 
connection type. 

Remote RS-232 
Connection

The Service Kit can connect remotely via modems to the base station’s front or 
rear serial port. For details on setting this up, see TN-742 Remotely Monitoring 
and Configuring the Tait TB8100.

The Service Kit communicates over this physical configuration using a Modem 
Dialup connection type. 

TB8100

Service Kit
PC

front RS-232
cable

TB8100 Service Kit
PC

front

rear

R
S

-232

Modem

Service Kit
PC

TB8100

RS-232
Null modem Modem PSTN
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Remote  
Connection Using 
an Asynchronous 
Port Switch

The Service Kit can connect remotely to any of a number of base stations via a 
single link if an asynchronous port switch is used. For details on setting this up, 
see TN-906 Connecting to TB8100 Base Stations via an Asynchronous Port Switch.

The Service Kit communicates over this physical configuration using a Modem 
Dialup connection type, with the use of the port switch enabled and 
configured. In subracks with more than one base station, the Service Kit can 
connect to each base station.

Remote  Ethernet 
Connection

The Service Kit can connect remotely using TCP/IP over Ethernet to a base 
station with an Ethernet interface. For details on this, see TN-1142.

Each base station has its own IP address. In subracks with more than one base 
station, the Service Kit can connect to each base station.
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Adding a Connection
The New Connection dialog box lets you define new connections and add 
them to the list of available connections. There should already be direct 
connections for COM1 and COM2. You need to set up one connection for 
each base station with a remote link.  

Adding a Direct Connection
1. Select Tools > Configure Connections. The Connections dialog box 

appears.

2. Click New. The New Connection dialog box appears.

3. In the Name box, enter a suitable name, for example ‘All’.

4. In the Connection type box, select Direct Connection. 

5. In the Serial Port Number box, select the port on your PC that will be 
used by the cable from the base station. 

6. In the Baud rate box, select a suitable communications speed: for a direct 
connection, this can be 57,600 or even 115,200 Baud.

Note: You may experience slow or intermittent communications at 
baud rates of 56k and above. This is not a Service Kit or base station 
problem; it has been found that serial ports on some older PCs do 

not operate correctly. Moving the mouse makes the problem worse (use of one 
serial port affects the other). If you have this problem, select a slower Baud rate.

7. Set suitable polling intervals. These specify the interval from one poll of the 
base station to another. A direct connection can have very short intervals, 
for example 1 second for monitoring and 5 seconds for alarms.

8. Click OK. The new connection now appears in the Connections dialog 
box.
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Adding a Modem Dialup Connection
For each base station that is fitted with a dial-up modem, you need to define a 
connection. 

1. Select Tools > Configure Connections. The Connections dialog box 
appears.

2. Click New. The New Connection dialog box appears.

3. In the Name box, enter a name that uniquely identifies the base station.

4. In the Connection type box, select Modem Dialup. 

The New Connection dialog box now looks like this:

5. If your PC has more than one modem, select the one you want to use in the 
Connect using box. Normally, you do not need to click Configure and 
configure the PC’s port to the modem. The default settings can be left as 
they are. 

6. In the Phone number box, enter the telephone number of the line to the 
base station’s dial-up modem. You can enter up to 40 digits: enough for a 
local pin and an international number. 

7. If the Service Kit needs to use the country code and the area code to access 
the base station, provide this information as follows.

a. In the Area code box, enter the base station’s area code.

b. In the Country code box, select the base station’s country code.

c. Select the Use country code and area code check box.

8. Set polling intervals that are appropriate to the speed of your connection. 
The Alarms and Monitoring boxes specify the interval from one Service 
Kit poll of the base station to another.  

9. Click OK. The new connection now appears in the Connections dialog 
box.
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Adding a Connection That Uses a Port Switch
For each base station that is connected to an asynchronous port switch, you 
need to define a connection. This involves entering the commands that the 
Service Kit sends to the APS to instruct it to connect to the base station and to 
disconnect from it. You must also enter the responses to these commands that 
the Service Kit expects from the APS. 

1. Select Tools > Configure Connections. The Connections dialog box 
appears.

2. Click New. The New Connection dialog box appears.

3. In the Name box, enter a suitable name. The name should specify the base 
station and the connection type.

4. In the Connection type box, select Modem Dialup. 

5. Set up the parameters in the Connection tab as for adding a Modem Dialup 
connection (see “Adding a Modem Dialup Connection” on page 38).

6. Click the Port Switch tab. 

The dialog box now looks like this:

7. Select the Port switch check box. This enables the connection to use the 
port switch.

8. In the Connect command box, enter a command in the format
 ^M/Cx^M, where:

x is the APS port that the base station is connected to.

^ (the carat symbol) instructs the Service Kit that this is a control character. 
Do NOT use the control key.

^M instructs the APS to enter command mode.

/C requests a connection

^M terminates the sequence.

9. In the Connect response box, enter ‘1’.
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10. In the Disconnect command box, enter a command in the format
^Mxxx^M/X^M, where:

xxx is a sequence of three characters, for example, LLL. The APS must be 
configured to use the same character for its disconnect sequence and to 
require three identical characters. 

/X^M is the command mode exit instruction.

11. In the Disconnect response box, enter ‘3’.

12.Click OK. The new connection now appears in the Connections dialog 
box.

Adding a Network Connection
For each base station that is fitted with an Ethernet interface, you need to define 
a network connection. This enables the Service Kit to connect remotely to the 
base station via TCP/IP over Ethernet. 

1. Select Tools > Configure Connections. The Connections dialog box 
appears.

2. Click New. The New Connection dialog box appears.

3. In the Name box, enter a suitable name for the base station. 

4. In the Connection type box, select Network. 

The dialog box now looks like this:

5. Enter the IP address of the base station. (If the network uses network address 
translation (NAT), enter instead the IP address that will ultimately be 
translated into the base station’s IP address.)

6. Leave the Port box displaying 10001, except when NAT requires the use 
of a different TCP port.

7. Set polling intervals that are appropriate to the speed of your connection. 
The Alarms and Monitoring boxes specify the interval from one Service 
Kit poll of the base station to another.
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8. Click OK. The new connection now appears in the Connections dialog 
box.

Copying a connection
Once you have a connection of a particular type, you can use the Copy button 
as a quicker way of adding a new connection. This is particularly useful for 
connections that use an asynchronous port switch.

To copy a connection

1. Select Tools > Configure Connections. The Connections dialog box 
appears.

2. Click a connection to select it.

3. Click Copy. The Copy connection dialog box appears, containing settings 
copied from the selected connection.

4. Edit the connection as needed. For details, see “Editing a Connection” on 
page 41.

Editing a Connection
You may need to modify the settings of an existing connection, for example, if 
a telephone number changes or if the link is too slow for the polling intervals 
you selected. 

To edit a connection

1. Select Tools > Configure Connections. The Connections dialog box 
appears.

2. Click a connection to select it.

3. Click Edit. The Edit Connection dialog box appears.

4. Modify the settings as desired. For information about individual settings, see 
“Adding a Connection” on page 37.

5. Click OK. 
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Export and Import of Service Kit Connections
You can export connection definitions from one Service Kit and import them 
into another. This is particularly valuable if your system has a significant number 
of base stations, each of which needs its own remote connection definition. 

Importing Connections
You can import a file containing connections that have been exported from 
another Service Kit. You have the option of merging the imported connections 
with existing connections.

Merging adds the imported connections to the existing connection list. If there 
is a name clash, the imported connection is renamed. For example, Modem 
would be renamed to Copy (1) of Modem.

If you don’t merge the imported connections, they replace all the existing 
connections.

To import connections

1. Copy a TB8100 connections file (*.t8n) from another Service Kit into the 
main folder of your Service Kit program.

2. Run the Service Kit and select Tools > Configure Connections.

3. If you don’t want to replace the existing connection list, select the Merge 
with existing file check box. 

4. Click Import.

5. If necessary, select the desired connections file.

6. Click Open. 

Exporting Connections
You can export Service Kit connections. This results in a TB8100 connections 
file that you can import into other Service Kits. It also generates a text file that 
lets you view the details of each connection. 
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To export connections

1. In the Connections dialog box (Tools > Configure Connections),  specify 
whether you want to export all connections or just a selection. 

2. If you chose the Selected connections option, select the connections you 
want to export. You can use the Shift key to select a block of connections 
or the Control key to select additional individual connections. 

3. Click Export.

4. If necessary, specify the path and file name for the connections file. 

5. Click Save.

6. The Service Kit saves the file, giving it the extension .t8n. It also saves an 
equivalent text file with the same name and with the extension .txt. The text 
file gives you a readable view of the exported connections. Editing this file 
has no effect on the exported connections.
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Connecting to a Base Station

Before you can use the Service Kit to work with a base station, you must 
connect to it and log on. You can connect via RS-232 or via Ethernet, 
depending on the system interface board fitted to the reciter.

Most commonly, you connect via RS-232 using the programming port on 
the control panel.

If the reciter is fitted with a TaitNet RS-232 system interface, connect via 
RS-232 to the serial port on the rear of the reciter.  The control panel 
programming port is not available. 

If the reciter is fitted with a TaitNet Ethernet system interface, connect via 
Ethernet. If desired, you can connect via RS-232 using the control panel 
programming panel, but this is only accessible at start-up.

Connecting via RS-232
1. Connect the Service Kit physically to the base station. For a remote RS-232 

connection, refer to TN-742 Remotely Monitoring and Configuring the Tait 
TB8100. For a direct RS-232 connection, follow these steps:

a. Connect one end of the supplied cable to the control panel serial port. 
This cable is an ordinary (straight through) RS-232 cable and is available 
separately (order code TBA0P10). 

Note: The control panel serial port is disabled if the reciter is fitted 
with a TaitNet RS232 system interface. You must connect to the 
serial port at the rear of the reciter instead. 

b. Connect the other end to a serial port on your computer. The serial port 
to use is the one specified when the direct connection was set up and 
configured.

c. If the subrack has more than one base station, press the button on the  
control panel that selects the base station you want.

2. Click Connect. The Connecting dialog box appears.

3. In the Connect to box, select a named connection from the drop-down 
list. If your PC is directly connected to the base station, the connection type 
must be ‘Direct.’ If your PC is remote from the base station, the connection 
type must be ‘Modem dial-up.’ If no suitable connection exists, click Edit 
Connection or New Connection to edit an existing connection or create 
a new one. For more information, see “Setting Up and Configuring 
Connections” on page 34.

4. Click Connect. 

5. If the base station is fitted with a TaitNet Ethernet system interface, turn the 
base station on now. 

When the connection succeeds, the Log On dialog box appears.
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Connecting via Ethernet
1. Connect the Service Kit physically to the base station, using one of the 

following methods. 

Connect one end of an ordinary Ethernet cable to the Service Kit PC 
and the other to a port on the site hub.

Connect the Service Kit PC directly to the RJ45 connector at the rear 
of the reciter using an Ethernet cross-over cable.

Connect the Service Kit remotely, following the instructions in TN-
1142.  

The PC and the base station must be on the same subnet. You may need 
assistance from the network administrator.

2. Click Connect. The Connecting dialog box appears.

3. In the Connect to box, select the named connection for the base station 
from the drop-down list. The connection type must be ‘Network.’ If no 
suitable connection exists, click Edit Connection or New Connection 
to edit an existing connection or create a new one. For more information, 
see “Setting Up and Configuring Connections” on page 34.

4. Click Connect. 

If the connection succeeds, the Log On dialog box appears.

If the status display shows “Connection failure. Remote host is not 
responding,” the Service Kit is unable to reach the base station.  

If the status display shows “Connection refused by target machine,” the 
Service Kit has received a reply to its TCP message asking to connect, but 
the connection request has been refused. This refusal could be sent by the 
base station or by network equipment such as a router.  

The base station will not accept connection requests in these situations:

After base station start-up (for 40-60 seconds)

After a Service Kit programs a configuration into the base station and 
disconnects (the base station takes 30-40 seconds to re-check its Ethernet 
interface configuration)

After the base station sends a Syslog or heartbeat message 
(10–40 seconds)

When the Ethernet interface is being used by another Service Kit or CCI 
connection

The Service Kit will keep trying to connect until you click Cancel. If 
connecting remotely does not succeed after two minutes, you may be able 
to use ping to see if the base station is accessible.
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Logging On

Once the Service Kit is connected to a base station, you can log on. This  
establishes a communication session. Data can go back and forth, for example, 
to display monitoring information or to carry out a diagnostic test. However, a 
further step is necessary before you can work with configuration information: 
you must read the base station or open a configuration file, even to view the 
configuration forms.

The Log On dialog box contains a table with details of the base station and a 
Logon details frame that lets you log on.

Base Station Table
The base station table displays information about the base station. LEDs indicate 
in advance whether an alarm is active. 

The PMU serial number is displayed in its own box, because it serves all the 
modules in the subrack. 

Each module has an LED. If an LED is red, the module has an active alarm. If 
it is green, there are no active alarms. 

Base Station Displays the name of the base station. The LED to the left indicates whether 
the whole base station has any alarms.  The base station name is defined in  
Configure > Base Station > General: Identification area. 

Number The number of the base station’s reciter. This defines the reciter’s address on 
the control bus and is set by the rotary switch on the reciter front. Reciter 
number 1 is the control bus master.

Reciter S/N The serial number of the reciter. The LED to the left indicates whether the 
reciter has any alarms.

PA S/N The serial number of the power amplifier. The LED to the left indicates 
whether the PA has any alarms.



TB8100 Service Kit User’s Manual   Logging On 47

Logon Details
The Logon details area lets you enter information for the log on.

Access level Defines the access level for the log on. An access level determines your access 
to the base station and your ability to carry out different functions. If your access 
level is ‘User’, what you can do depends also on the base station’s access profile. 
The access profile is configured by the Administrator.

  

Note: Authorized Tait service centers have a higher level of access 
when directly connected and do not need to select a level or enter 
a password. 

Password Enter the password into this box. This is the password for the base station and 
for the access level you selected. Each base station has its own set of passwords. 
Passwords can be changed by users with the Administrator access level (see 
“Changing Base Station Passwords” on page 53). 

Access Level Description

User Lets you carry out the Service Kit functions that the 
administrator has selected for the base station in Base 
Station > Access Profiles. The administrator can specify 
one set of functions for a direct connection and another 
for the different kinds of remote connection.

Administrator Lets you carry out all Service Kit functions on the base 
station, including changing passwords for access to it.

Read only Lets you use the Service Kit to monitor the base station 
but not to change it or carry out any actions. You can read 
and view the base station’s configuration but not change 
it. You cannot carry out diagnostic tests. 

Access Level Default Password

User user

Administrator admin

Read only readonly
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Changing Base Station Mode

Some Service Kit operations can only be carried out when the base station is 
not in its normal operating mode. 

To change the base station’s operation mode

1. Press F5 to go directly to Standby mode, or F6 for Run mode.

2. Alternatively, click Mode. (Or, select Base Station > Change Mode.) If you 
have rights to change mode, the Change Operating Mode dialog box 
appears.

3. Select the mode you want.

Modes that you don’t have access rights to are disabled.

To leave Download mode, reset the base station. The Service Kit 
displays the Connecting dialog box. Wait about 10 seconds for the base 
station to start up, then re-connect and log on. The base station is now 
in Standby mode.

4. Click OK. 

Resetting the Base Station
You can reset the base station using the Service Kit. 

1. Click Mode.

2. Click Reset Base Station.

3. Wait for the base station to restart, and then connect and log on again.
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Working With Base Station Configurations

Base stations are programmed with many configuration settings. Using the 
Service Kit, you can view these settings, change them, and then program them 
into the base station. You can also create a new configuration from a template 
and save a configuration to a file.

Configuration works differently from other Service Kit functions. Once you 
are logged on, you can monitor the base station but you can’t yet view its 
configuration. First you must click the Read icon, which instructs the base 
station to supply its configuration information.

Programming the base station with a new configuration can only be done 
when the base station is in Standby mode.

You can obtain configuration information from a base station, from a 
configuration file, or from a configuration template. 

Figure 1: Obtaining Configuration Information
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station configurations.

Read the base station’s configuration, modify it, and program the changed 
configuration back into the base station.
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Creating a New Configuration
You can create a new base station configuration from scratch, modify it, and 
save it as a new configuration. This means that you can define a configuration 
without being connected to a base station. This is a good way to learn how to 
use the configuration part of the Service Kit program. It also means that you 
can do all the work of configuring before a base station is delivered. When it 
arrives, you just open the configuration file and program it into the base station. 
(This method completely overwrites the base station’s current settings.)

To create a new configuration

1. Select File > New. The Select Template File dialog box appears. 

2. Select an appropriate template (*.t8t file) from the templates in the 
Template folder. This template will provide a set of default settings. 
Templates can be provided by Tait or created for your system or 
organization.

3. Click Open.

The title bar displays ‘Untitled.t8c’, indicating that you have not given the 
configuration a name and saved it. 

You can now click Configure to view the current configuration settings, make 
any configuration changes, and save the configuration settings to a file. You can 
also program a base station with these settings. 

Reading a Configuration
Before you can view a base station’s configuration settings, you must read them. 
If they were saved to a file, they also exist in the Service Kit’s Configurations 
folder. 

Note: Reading configuration settings overwrites any settings that the 
Service Kit has in memory. If you have opened a configuration file, 
save and close it first.

1. Connect to the base station and log on.

2. Click Read.

The Service Kit reads the base station’s configuration information. If this 
information was saved to a file, the Service Kit loads the information from 
that file. This is much quicker, especially for remote connections. It checks 
to make sure that the information on file is the same as the information in 
the base station. If some parts of the configuration in the base station have 
been updated after the file was saved, these parts are read from the base 
station.
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Note: If reading the configuration file over a remote RS-232 link 
fails, the base station modem’s configured speed may be too high.  
The base station does not have flow control, which means that data 

from it can flood the modem if it arrives more quickly than the modem can send 
it. This is more likely to occur if the configuration file is large and the link is 
slow. Reducing the configured modem speed can solve the problem. See TN-
742 for details.

Important: When you read a configuration and the base station 
cannot detect its PA or PMU, it is unable to provide the 
configuration settings that are stored in the module. The Service Kit 

fills in the gaps by providing default settings. If this occurs, you might 
subsequently overwrite the module’s settings with defaults that are unsuitable 
for your system.  Before re-programming the base station, check and edit these 
default settings. They include alarm thresholds and the auxiliary power output 
configuration.

The Reading dialog box displays progress and gives you the option of 
canceling the process. The title bar displays the name of the configuration 
file. Any changes you make and save will be saved to this file. (If the title bar 
displays ‘Untitled.t8c,’ you need to specify a file name when you save your 
changes.)

You can now click Configure to view the current configuration settings, make 
any configuration changes, and save the configuration settings to a file. You can 
also put the base station into Standby mode and program it with the new 
settings. 

Saving a Configuration
It is a good idea to regularly save your current configuration settings as you 
work on them. You should also save them when you program them into a base 
station. In this way, you have a backup. The Service Kit can automatically use 
this to quickly load the settings if you need to read them again. It is also available 
in case the base station fails or its memory becomes corrupt.

To save configuration settings

1. After making any changes to configuration settings, click OK to confirm 
them.

2. Select File > Save or click Save.

If the configuration settings are already named, they are saved. If not, the 
Save Configuration File dialog box appears and you must continue as 
follows:

3. Enter a name for the configuration file into the File name box.

4. If you want to save the configuration file somewhere other than in the 
Configurations folder, alter the default path.

5. Click Save. The name you provided appears on the title bar. 

Programming a Base Station
To change a base station’s configuration settings, you must make the changes 
using the Service Kit, and program them into the base station. Programming 
only affects the settings that you can view after clicking Configure.
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To program a base station

1. Log on to the base station (if you aren’t already). 

2. Click Mode and put the base station into Standby mode. 

3. Check that the current configuration settings displayed in the Service Kit are 
what you want. Click OK to confirm this.

4. Select File > Save to create a copy of the configuration settings as a file in 
the Configurations folder.

5. Click Program. 

The Programming dialog box appears and indicates the download progress.  
When the base station has successfully received all the configuration settings 
and programmed them in, the Programming dialog box closes. 

If the download is not completely successful, programming is aborted and a 
message appears. Later, you can open the file you saved and try again. 

Important: When you program a base station, any changes to the 
PMU configuration will affect the operation of the PMU, which 
supplies the other base station in the subrack. That base station’s 
operation may be interrupted or otherwise affected. 

6. Return the base station to Run mode.

Creating a Configuration Template
The base station comes with templates that define configuration settings for 
different applications. When you create a new configuration, the template you 
select provides the configuration with sensible default settings. This enables you 
to concentrate on the main things that need to be changed.

You may want to add your own template. You can then quickly create a 
configurations with the settings you want. These could be settings common to 
all base stations in a system or settings that a system integrator generally uses. 

To create a configuration template

1. Edit the settings in a configuration file until they are as you want them. 
Click OK.

2. Save the file.

3. Select File > Save as Template. The Save Configuration Template dialog 
box appears.

4. Enter a name for the template.

5. Click Save. The Service Kit saves the configuration settings to a template 
file. This file has the name you entered and the template extension (.t8t). 
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Changing Base Station Passwords

Each base station stores its own password for each of the three access levels. If 
you log on to the base station as Administrator, you can change any of these 
passwords. While the base station is password-protected, the Service Kit is not. 

To change a password

1. Select Base Station > Change Passwords, and then select the appropriate 
sub-option for the password that you want to change. The Change User 
Password dialog box appears.

2. Enter the Administrator password.

3. Enter the new password.

4. Re-enter the password in the next box.

5. Click OK to change the password and close the dialog box.

Important: Take care not to lose the Administrator password.
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Access Profiles

The Access Profile dialog box (Base Station > Access Profiles) lets you view or 
edit information about the access that Service Kit users have to the current base 
station. This access varies, depending on the access level.

The ‘Administrator’ access level gives unrestricted access. 

The ‘Read Only’ access level lets you view everything but change nothing. 

The ‘User’ access level has a configurable access profile. This means that 
your access to the base station varies, depending on the type of connection 
and the Service Kit function. 

Tait-authorized service centers always have unrestricted access when locally 
connected.

Viewing an Access Profile
You may need to check and see what functions you are permitted to carry out 
on a particular base station.

To view your access profile

1. Log on to the base station.

2. Select Base Station > Access Profiles. The Service Kit reads access profile 
information from the base station and displays it in the Access Profiles dialog 
box.

The dialog box has two tabs, one for local (direct) connections and the other 
for remote (dial-up) connections  There is a row for each major area of the 
Service Kit program and a column for each access level. Access can be any of 
the following: 

Option Description

Deny The Service Kit opens the form you request, but it is disabled 
and displays no data.

Read The Service Kit opens the form and displays the data, but you 
cannot edit it. You can display the information in diagnostic 
screens, but not initiate any diagnostic tests.

Full The Service Kit lets you do anything it is capable of.
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Modifying Access Profiles
Those with Administrator access can configure the access profiles of those with 
a ‘User’ access level. One access profile is for local (direct) connections, the 
other for remote (dial-up) connections. You could for example allow these 
users to carry out diagnostic tests but only to view the base station’s 
configuration.

To modify an access profile

1. Log on to the base station as ‘Administrator.’

2. Select Base Station > Access Profiles. The Service Kit reads access profile 
information from the base station and displays it in the Access Profiles dialog 
box.

3. Make changes to any settings in either tab.

4. Click OK to program your changes into the base station and close the dialog 
box.
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Logging Off and Disconnecting

When you have finished working with a base station, click Disconnect to log 
off and disconnect from the base station.

If the base station is in Standby or Download mode, you are reminded of this 
and asked to confirm that you want to proceed. This is to make sure that you 
do not inadvertently leave the base station out of service when you end a 
Service Kit session. Select No to cancel disconnecting, and then change the base 
station’s mode back to Run before disconnecting. 
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Working with Different Versions

As time goes by, it is natural to end up with a system that has a mixture of 
versions. For example:

A module fails and its replacement has a newer hardware version. 

New firmware offers a highly desirable feature so a module is upgraded. 

A new Service Kit version is released and is loaded on the PC. 

When modules with different versions try to work together, compatibility 
problems can arise. The following offers some guidance.

Quick Tips A PC can only have one Service Kit version installed at a time. Ensure that 
upgrading the Service Kit does not make it incompatible with your base 
station equipment.

A new Service Kit can only save a configuration in its own format, but it 
can program the information into an older base station.

Version numbers are incremented when an update is made. Versions that are 
designed to work with each other don't necessarily have the same version 
number.

For information about compatibility for particular versions, see the Release 
Notes (on the Product CD).

Replacing 
Modules 

When replacing a PA, PMU, or reciter module, check the Release Notes to 
ensure that the module is compatible with the other modules in the subrack. 
(Hardware versions are on the module label. The Service Kit can display 
firmware versions). 

Upgrading 
Firmware

You can use the Service Kit to upgrade the firmware of a base station module. 
The Service Kit will only let you select firmware versions that are compatible 
with each other and with the respective module's hardware version. 

Upgrading the 
Service Kit

Before installing a version of the Service Kit from the product CD, check the 
compatibility table in the Release Notes to make sure that the Service Kit will 
be compatible with the base station modules' firmware and hardware versions. 
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Service Kit Handling of Older Versions
The Service Kit can handle older base stations and configuration files. Any 
differences are handled by conversion rules. The Service Kit applies these rules 
when reading from the base station, programming the base station, or opening 
a configuration file.

For example, the Service Kit Version 02.00 has a parameter "Revert to Run 
mode" and a timer value after which the reversion happens. When the Service 
Kit opens an older configuration file or reads an older base station, the 
conversion rules tell it to supply the default settings for the parameter and its 
value and displays them, even though they don't actually exist in the base 
station. When the Service Kit programs the configuration into an older base 
station, these settings are discarded, because the base station doesn't know about 
them. You are given no indication that this has happened. The base station 
continues to behave as before (it doesn't revert to Run mode).

Generally speaking, the application of conversion rules will not be noticed but 
could in some situations significantly alter base station behaviour. If you have 
any concerns, check the Release Notes for new features, enhancements, or 
fixed issues. These apply to the new Service Kit but not to older base station 
versions.
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Upgrading Base Station Firmware

When you install the Service Kit, firmware for the different base station 
modules is copied into the firmware files folder (by default C:\Program 
Files\Tait Programming Applications\TB8100 Service Kit\FirmwareFiles). 
Older firmware versions and a compatibility file are also copied over.  Firmware 
versions are also available from the Tait support website.  Copy them into the 
firmware files folder.

You can use the Service Kit to upgrade the firmware of base station modules. 
The Service Kit uses the compatibility file to ensure that the new firmware will 
not lead to incompatibility. It is also possible to downgrade a module to an older 
firmware version to ensure compatibility with other base station modules. 

Upgrading the firmware can be done remotely via the Internet or via RS-232 
modems. If via modems, the base station modem must be configured to 
communicate at a suitable speed (see TN-742 for more information) and the 
link speed must be 9,600 Baud or greater. 

To upgrade a base station’s firmware

1. Copy the firmware files and the compatibility file into the Service Kit’s 
firmware files folder (to find out where this folder is located, select Tools > 
Options). 

2. Connect to the base station and log on as Administrator. 

3. Make sure that the physical connection is secure (an interruption to serial 
communications can cause the upgrade to fail). Put the base station in 
Download mode. 

4. Select Tools> Firmware Download. The Firmware Download dialog box 
appears.

The Service Kit obtains information about the base station’s modules and 
displays it in the Current Versions area. It then determines whether the new 
firmware is compatible with the base station’s hardware. If it is, the version 
number of the new firmware appears in the Target Versions area. (To view 
the compatibility file and see what firmware versions are available, click 
Show Details.) 

5. In the Target Versions area, select the check boxes of the modules you 
want to upgrade.

6. Make sure that the Progress area displays Ready for the modules you want 
to upgrade, and then click Download. 
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The Service Kit reads the base station’s configuration information, stores it 
on disk, and then downloads firmware for the modules you selected. The 
Progress area indicates what is happening. 

Note: When the PMU is being upgraded it can still provide power 
to the entire subrack, but it cannot control its fan or provide 
information about alarms, monitoring, or diagnostics. 

If a step in the process is unsuccessful, you are given some options. You may 
be able to skip to the next module leaving the failure as is, restart the 
firmware download (this means going back to the Firmware Download 
form and trying again), or retry the step that failed. 

If necessary, contact Tait for assistance. It helps if you can provide the error 
log (this is stored in the LogFiles folder (see Tools > Options for its 
location).

When all LEDs are green and the text box displays ‘Done’, the firmware 
upgrade has been successfully completed. The firmware has been 
downloaded and written to flash memory. 

7. Wait while the Service Kit resets the base station and automatically logs on 
again. It checks that the base station is operating with the downloaded 
firmware versions, and then programs the stored configuration information 
back into the base station. It resets the base station again and automatically 
logs back on.

Important: When remotely upgrading firmware via the Internet, the 
Service Kit may fail to re-connect. (The Status box displays 
Connecting to...) If, after several re-tries, it still cannot re-connect, 

the Close button is enabled, so that you can abort the process. However, this is 
not recommended, as it may leave the base station in an unknown state. It is 
preferable to resolve the underlying network problem. If this is fixed, the 
upgrade process will automatically continue.

If this process leaves the base station in Download mode, and resetting it 
again manually does not bring it back into Standby mode, the Service Kit 
may have failed to copy the configuration back to the base station. You can 
manually do this as follows. Locate the temporary file (tmpConfig.tmp in 
the Service Kit main directory), change its extension to .t8c, copy it to the 
Configurations subdirectory, and program it back into the base station. 

8. When the message Firmware Download Complete appears, return the base 
station to Run mode. 

The base station is now operating with the new firmware.
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Working with the Software Feature Enabler

The software feature enabler (Tools > Software Feature Enabler) lets you 
enable additional feature sets in the TB8100 base station. The base station 
already has these feature sets but it needs license keys to enable them. The 
software feature enabler also displays the status of all feature sets and lets you 
disable any that are enabled.

The form displays the name and reciter serial number of the base station you are 
connected to. Each row in the table displays information about a feature set: the 
Feature code used to order a feature set, its name, and whether it is enabled or 
disabled. The Seq column indicates how many times it has been enabled or 
disabled. 

Enabling Additional Features
If you want a feature set, obtain a license key from Tait for that feature set, and 
then use the Service Kit to enable it.

To enable a feature set

1. Connect and log on to the base station with the Administrator access level.

2. If you received the license key in a license file, copy that file (and any others 
that you received for other feature sets or other base stations) to the Service 
Kit’s license file folder (select Tools > Options to see which folder the 
Service Kit uses).

3. Go into Standby mode, and then select Tools > Software Feature Enabler. 

4. Click the feature set to select it.

5. If you received a license file, click Find License File. This searches the 
license file folder for a license file for the current base station and the selected 
feature set. If the Service Kit finds one, it displays the license key (in the 
feature set’s row and in the Feature License Key boxes), and increments the 
Seq column by 1. 

6. If you don’t have a license file, enter the license key into the Feature License 
Key boxes.
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7. Click Enable. This enables the feature set. The license key appears in the 
feature set’s row and the Seq column is incremented by 1.

Disabling a Feature Set
Feature sets are not normally disabled. However, disabling may be desirable in 
special circumstances, for example, if you are trying out the feature set and 
decide not to purchase it.

Disabling the Alarm Reporting Feature Set
You can only disable this feature set if the base station does not use it. 

Important: A disabled feature set can only be re-enabled by 
purchasing a new license key. The original feature license key 
cannot be re-used. 

1. Check the Reciter Serial Number box to make sure that you are logged 
on to the correct base station.

2. Make sure that communications with the Alarm Center (Configure > 
Communications > Alarm Center) and communications  using email 
(Configure > Communications > Email) are disabled.

3. Go into Standby mode. 

4. Select Tools > Software Feature Enabler.

5. Select the feature set’s row. 

6. Click Disable.

The progress bar indicates how far the disabling has progressed. On 
completion, a new number appears in the Feature License Key column. 
Communicate this new number to Tait if you are entitled to a refund or if 
you want to re-enable the feature set. 

Disabling the Advance Profiles and Task Manager Feature 
Set
You can only disable this feature set if the base station does not use it. 

Important: A disabled feature set can only be re-enabled by 
purchasing a new license key. The original feature license key 
cannot be re-used. 

1. Check the Reciter Serial Number box to make sure that you are logged 
on to the correct base station.

2. Make sure that no channels use customized channel or signalling profiles. (In 
other words, they all use default profiles.)

3. Make sure that there are no more than 20 enabled task manager tasks.The 
number of enabled Task Manager tasks is displayed in all Task Manager 
forms. If necessary, disable unneeded tasks until the total number is 20 or 
less. 

4. Go into Standby mode. 

5. Select Tools > Software Feature Enabler.

6. Click the feature set’s row. 

7. Click Disable.
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The progress bar indicates how far the disabling has progressed. On 
completion, a new number appears in the Feature License Key column. 
Communicate this new number to Tait if you are entitled to a refund or if 
you want to re-enable the feature set. 

Disabling the Power Saving Modes Feature Set
You can only disable this feature set if the base station does not use it. 

Important: A disabled feature set can only be re-enabled by 
purchasing a new license key. The original feature license key 
cannot be re-used. 

1. Check the Reciter Serial Number box to make sure that you are logged 
on to the correct base station.

2. Make sure that all channel profiles have Sleep and Deep Sleep modes 
disabled. 

3. Go into Standby mode. 

4. Select Tools > Software Feature Enabler.

5. Select the feature set’s row. 

6. Click Disable.

The progress bar indicates how far the disabling has progressed. On 
completion, a new number appears in the Feature License Key column. 
Communicate this new number to Tait if you are entitled to a refund or if 
you want to re-enable the feature set. 

Disabling the Default Radio System Feature Set
If the Default Radio System feature set is disabled, the base station cannot 
operate in Run mode. You can configure it, monitor it, and carry out 
diagnostic tests on it, but not use it as a base station. It is suitable for training 
purposes only. 

Important: A disabled feature set can only be re-enabled by 
purchasing a new license key. The original feature license key 
cannot be re-used.

1. Check the Reciter Serial Number box to make sure that you are logged 
on to the correct base station.

2. Go into Standby mode. 

3. Select Tools > Software Feature Enabler.

4. Select the feature set’s row. 

5. Click Disable.

The progress bar indicates how far the disabling has progressed. On 
completion, a new number appears in the Feature License Key column. 
Communicate this new number to Tait if you are entitled to a refund or if 
you want to re-enable the feature set. 
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Part D Monitoring

The Service Kit lets you monitor the TB8100 base station. It can 
provide details about each module and monitor the level of 
incoming and outgoing signals. The Service Kit can also display 
the base station’s log. Monitoring can take place while the base 
station is in Run mode; it has no effect on base station operation.

The Service Kit also shows you whether any alarms are active. 
You can view the status of all alarms or a list of recent alarms. 
See “Alarms” on page 141.

To monitor a base station, log on to it, click Monitor, and select 
an item from the navigation pane. 

Topics

Module Details

Operational Information
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Module Details

The Service Kit can display details about the reciter,  PA, and  PMU of the base 
station you are logged on to. Items under the heading Module Details give you 
information about the module such as its frequency range and firmware version. 
To monitor the way the base station is operating, see “Operational 
Information” on page 71.

Viewing Reciter Information
The Reciter form (Monitor > Module Details > Reciter) lets you view 
information about the reciter module of the base station you are logged on to. 
Use it to confirm exactly what it is that you are dealing with.

 

The form has several read-only fields, an LED indicating whether there are any 
reciter alarms, and an area that gives version information.

Module The name of the module (reciter) followed by a number. This number is set by 
the rotary switch on the front of the reciter and plays a role in control bus 
communications within the subrack. 

Product code The product code and name for the type of reciter. 

Band The RF frequency band of the reciter. This is the frequency range that the 
reciter is type-approved to operate in.

Receiver setting The current switching range of the receiver. This can be changed using the 
Calibration Kit.

Exciter setting The current switching range of the exciter. This can be changed using the 
Calibration Kit.

System interface The type of system interface card that the reciter is fitted with.



68 Part D: Monitoring    © Tait Electronics Limited April 2006

Alarm status Indicates whether the reciter currently has any alarm conditions. If the LED is 
green, there are no active reciter alarms. If the LED is red, the text box displays 
‘Alarms active,’ and there is at least one active alarm. To see which alarm is 
active, select Monitor > Alarms > Current Status. 

Serial number A unique identifier assigned to the reciter in the factory.

Watchdog resets The total number of times that the watchdog circuit reset the reciter because 
the reciter firmware locked up.

Versions
The Versions area (Monitor > Module Details > Reciter) displays version 
numbers for aspects of the reciter. 

Hardware The version number of the reciter’s hardware.

Firmware The version number of the reciter firmware and its creation date.

Calibrated The date when the reciter was last modified using the Calibration Kit. (This 
includes adjusting the switching range and tuning the frequency response.)

System interface The version number of the system interface board installed in the reciter.

Viewing Power Amplifier Information
The Power Amplifier form (Monitor > Module Details > Power Amplifier) lets 
you view information about the PA module of the base station you are logged 
on to. Use it if you need to confirm exactly what it is that you are dealing with.

Module The name of the PA. This non-editable name is used internally to identify the 
PA.

Product code The product code and name for the type of PA. 
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Band The RF frequency range that the PA is type-approved to operate in.

Power Specifies the RF power output rating of the PA. There are 5 W, 50 W, and 
100 W variants.

Isolator Indicates whether the PA is fitted with an optional isolator. 

Alarm status Indicates whether the PA currently has any alarm conditions. If the LED is 
green, there are no active alarms. If the LED is red, the text box displays ‘Alarms 
active,’ and there is at least one active alarm. To see which alarm is active, select 
Monitor > Alarms > Current Status. 

Serial number A unique identifier assigned to the PA in the factory.

Versions
The Versions area (Monitor > Module Details > Power Amplifier) displays 
version numbers for aspects of the PA. 

Hardware The version number of the PA hardware.

Firmware The version number of the PA firmware and the date when the PA was updated 
to its current firmware.

Calibrated The date when the PA was last calibrated using the Calibration Kit.

Viewing Power Management Unit Information
The Power Management Unit form (Monitor > Module Details > Power 
Management Unit) lets you view information about the PMU of the base 
station you are logged onto. Use it if you need to confirm exactly what it is that 
you are dealing with.

Module The name of the PMU. This non-editable name is used internally to identify 
the module on the rack frame bus.
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Product code The product code and name of the PMU module. 

Alarm Status Indicates whether the PMU currently has any alarm conditions. If the LED is 
green, there are no active alarms. If the LED is red, the text box displays ‘Alarms 
active,’ and there is at least one active alarm. To see which alarm is active, select 
Monitor > Alarms > Current Status. 

Serial number A unique identifier assigned to the PMU in the factory.

Inputs
The Inputs area (Monitor > Module Details > Power Management Unit) 
indicates which inputs the PMU is able to use.

Mains ‘Available’ indicates that the PMU is fitted with an AC-DC converter 
submodule. It can use mains input.

Battery ‘Available’ indicates that the PMU is fitted with a DC-DC converter 
submodule. It can use DC power as an input.

Outputs
The Outputs area (Monitor > Module Details > Power Management Unit) 
indicates whether the PMU is able to supply an optional output.

Auxiliary power ‘Available’ indicates that the PMU is fitted with an auxiliary power supply 
submodule. It can provide an output for auxiliary equipment or for charging 
the batteries. 

Versions
The Versions area (Monitor > Module Details > Power Management Unit) 
displays version numbers for aspects of the PMU. 

Hardware The version number of the PMU hardware.

Firmware The version number of the PMU firmware and its creation date.

Calibrated Indicates when the PMU was last calibrated using the Calibration Kit.
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Operational Information

The Service Kit can monitor the base station’s current settings and the way the 
reciter, PA, and PMU are operating. You must be logged in to that base station. 
Click Monitor, and then choose one of the items under Monitoring. To display 
information about the modules themselves, see “Module Details” on page 67. 

Monitoring the Current Channel
The Channel form (Monitor > Monitoring > Channel) displays information 
about the channel that the base station is currently operating on. 

The Current channel area specifies which channel is current and displays its 
most important details. 

The Channel profile and Signalling profile areas display information about the 
profiles assigned to the current channel.

The Current source area tells you whether the channel was selected by software 
(the Service Kit) or by hardware (external channel selection lines). If an external 
reference source is connected, it tells you what frequency the base station 
expects. 

Current Channel
The Current channel area (Monitor > Monitoring > Channel) displays details 
about the channel that the base station is currently using. The Channel 
number and Channel name boxes identify the channel. The Rx frequency 
box indicates the frequency that the base station is receiving on and the Tx 
frequency box indicates the frequency that it transmits on. Channels are 
created in Configure > Base Station > Channel Table.

Profile Information
The Signalling profile and Channel profile areas (Monitor > Monitoring > 
Channel) indicate which profiles have been assigned to the channel and display 
information about them. This information is the same as appears in the channel 
table, except for the transmit output power, which can be any one of four 
settings:
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Output power Displays the output power level that the PA is currently configured to use and 
(in brackets) the way that level was set.

Current Source
The Current source area (Monitor > Monitoring > Channel) indicates what 
selected the current channel and which source provided the reference 
frequency. 

Note: The current source’s choice of channel can be overridden by 
Task Manager action.

Channel source The Channel source box indicates whether hardware or software selected the 
current channel.

Clock reference The Clock reference box indicates what is providing the base station with a 
reference frequency (from which it derives the channel frequencies). 

Display Meaning

Channel Table The PA power level is defined by the channel table. 

Mains The base station is using AC mains power and the PA is using 
the corresponding output power level. (Non-default channel 
profiles define the PA output power level separately for mains 
and for battery.)

Battery The base station is using battery power and the PA is using the 
corresponding output power level. (Non-default channel 
profiles define the PA output power level separately for mains 
and for battery.)

Override Task Manager action has overridden the normal output power 
level. The PA is using the special Task Manager override level 
defined in the current channel profile.  

Option Description

Hardware The channel number was selected externally using equipment 
that is connected to channel selection lines on the base 
station’s external interface. Hardware channel selection is 
enabled in Configure > Base Station > System Interface.

Software The channel number was selected by software. The channel 
number is the default channel (set by the Service Kit in 
Configure > Base Station > General).

Option Description

Internal The base station’s own clock signal is the reference source.

External External equipment is providing the reference source via a BNC 
connector at the rear of the reciter. The Service Kit must tell the 
base station whether to expect 12.8 or 10 MHz (Configure > 
Base Station > Miscellaneous).



TB8100 Service Kit User’s Manual   Operational Information 73

Monitoring the Reciter
The Reciter form (Monitor > Monitoring > Reciter) lets you monitor the 
RSSI and SINAD of the received signal and the audio levels on the input and 
output lines. Each level is displayed graphically as a gauge. The equivalent 
numeric value appears under the gauge heading.  If the value is red, it has 
exceeded the maximum or fallen below the minimum that the gauge can 
display.

The first box in the form displays the internal name of the reciter.

Alarm status The Alarm status box indicates whether the reciter has an alarm. If the LED is 
red, select Monitor > Alarms > Current Status to see which alarm is active.

Received signal The Received signal area displays the RSSI and SINAD levels. (If you want to 
know the equivalent RSSI in microvolts, see “Converting Between Microvolts 
and dBm” on page 88). The SINAD is only an approximation, but it is 
reasonably accurate if a receiver filter with a de-emphasised audio response is 
selected.

Input lines The Input lines area displays the audio levels for the balanced and unbalanced 
line inputs. 

Output lines The Output lines area displays the audio levels for the balanced and unbalanced 
line outputs. 

Rx Gate output The Rx Gate output LED displays the current state of the Rx Gate line. If it is 
green (active), the base station is receiving a valid signal.  

Tx Key input The Tx Key input LED displays the current state of the Tx Key line. If it is 
green (active), the line has been asserted, instructing the base station to transmit.
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Monitoring the Power Amplifier
The Power Amplifier form (Monitor > Monitoring > Power Amplifier) lets 
you monitor the levels of various parameters. Each level is displayed graphically 
as a gauge or thermometer. The equivalent numeric value appears in or under 
the heading.  If a value goes off the scale, it turns red. 

The first box in the form displays the internal name of the PA.

Alarm status The Alarm status box indicates whether the PA has an alarm. If the LED is red, 
select Monitor > Alarms > Current Status to see which alarm is active.

Transmitter 
output

The Transmitter output area displays the forward and reverse power. Click 
Watts or dBm to view these parameters as watts or dBm. Underneath is the 
VSWR. If the VSWR is greater than 10:1, an alarm is triggered and the PA 
folds its output back to 10% of its capability. Only when the VSWR falls below 
5:1 will the power output begin to recover.

Duty cycle 
(5 minutes)

Indicates the average duty cycle over the past 5 minutes. This parameter is 
updated once every minute. 50% means that the PA was transmitting for 2.5 of 
the last 5 minutes. 

Duty cycle 
(24 hours)

Indicates the average duty cycle over the past 24 hours. 25% means that the PA 
was transmitting for 6 of the last 24 hours.

Heatsink 
temperature

Displays the highest of the three temperatures measured at the PA driver, 
Final 1, and Final 2 transistors. 

Air intake 
temperature

This thermometer displays the temperature measured at the air intake to the PA 
heatsink. 
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Monitoring the Power Management Unit
The Power Management form (Monitor > Monitoring > Power Management) 
lets you monitor the operation of the PMU. You can:

Check the voltage of the battery and the current that the PMU outputs to 
the PA.

See whether the base station is running on battery or mains power.

Check the status of the PMU’s inputs and outputs.

This form has a gauge displaying the battery voltage and another displaying the 
output current. Rectangles represent the different PMU submodules and LEDs 
indicate the status of power inputs and outputs. A rectangle is disabled if the 
equivalent submodule is not installed.

The first box in the form displays the name of the module: power management 
unit.

Alarm status The Alarm status box indicates whether there is a current alarm. If the LED is 
red and the box displays ‘Alarms active’, one or more PMU alarms have been 
triggered. Select Monitor > Alarms > Current Status to see which alarms are 
active.

AC in The AC in LED  indicates the state of the AC power input into the AC-DC 
converter.

LED Text Description

Green On AC power input is usable

Red Off AC power input is too low or too high 
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Battery voltage The battery voltage gauge indicates the voltage of the DC power supply to the 
PMU (whether or not it is currently being used). The LED alongside indicates 
the state of the power supply. 

AC-DC converter The LED in the AC-DC Converter submodule indicates the state of AC 
power.

The submodule label indicates the voltage the DC-DC converter is designed 
for (12, 24, or 48 V). 

DC-DC converter The box in the DC-DC converter submodule indicates the current power 
saving mode. 

Standby converter The LED in the Standby converter submodule indicates the state of the DC 
supply to the standby converter. This submodule operates only when the PMU 
enters deep sleep mode, in which it provides power only to the reciter.

Output switch There are three arrows going into the output switch. The one that is not 
disabled indicates which converter is currently providing power

LED Text Description

Green On Battery input is usable.  The PMU can provide up to 500 W 
(or up to 40 W of power in low power mode). 

Red Off Battery voltage is too low or too high.

Gray Off No battery power supply is fitted (the rectangle is also 
disabled).

LED Text Description

Green On AC power input is usable

Red Off AC power input is too low or too high 

Gray Off Mains Failure test is running

Mode Description

Normal mode The PMU is operating normally.

Sleep mode The PMU is in hysteresis mode. 

Deep Sleep 
mode

The DC-DC converter is off and no power is being 
provided to the PA. 

LED Text Description

Green On The standby DC supply has been turned on. The PMU is 
providing only 10 W of power to the exciter.

Red Off Battery voltage is too low or too high.

Gray Off No standby battery power supply is fitted. 
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PA The PA LED displays green if the PMU is supplying power to the PA and gray 
if it is not. When the PMU is using mains power, it always supplies power to 
the PA. When it is using battery power, it supplies power unless it is in sleep 
mode and using the standby converter. 

Reciter/control 
panel

The Reciter/control panel LED indicates the status of the power supply to the 
receiver and the control panel. Green means that it is supplying power. Gray 
means that it is not, because the PMU is in battery protect mode. 

Auxiliary output The Auxiliary output submodule has an LED that indicates the status of the 
auxiliary power or battery charging output.

The submodule label indicates the voltage that the auxiliary power submodule 
is designed to produce (12, 24, or 48 V). 

Output Current The Output Current gauge shows how much current the PMU is supplying to 
the rest of the subrack. 

LED Text Description

Green On The auxiliary power output has been turned on.

Red Off There is a fault. This could be because there has been a 
current overdraw and the fuse is blown. On cooling, the 
fuse will automatically reset.

Gray Off No auxiliary power supply unit is fitted or the PMU has 
turned the output off.
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Part E Configuring the Base Station

The Service Kit lets you configure the TB8100 base station.

Click Configure, and select an item from the navigation pane. 

For information about configuring channels and their profiles, 
see “Configuring Channels” on page 97.

Topics

Choosing a Configuration

Configuring General Options

Configuring the System Interface

Configuring Fan Control

Configuring Miscellaneous Items

Printing a Base Station Configuration
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Choosing a Configuration

If you click Configure and the Service Kit doesn’t already have a configuration 
loaded, it asks you to choose one to work with. 

Click New to open a new configuration based on the default template.

Click Open to select an existing configuration file.

Click Read to read a base station’s configuration. You may need to connect 
and log in to a base station first. 
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Configuring General Options

The General form (Configure > Base Station > General) names the base station 
and specifies the default channel. From this form, you can customize the default 
channel and signalling profiles. A panel on the right gives you high-level 
instructions on how to configure channels in a simple system. 

Identification Specifies the name of the base station. Enter a suitable name. This name is used 
in the Log On form and on the status bar to help you verify that you are 
connected to the correct base station. You may need to disconnect and turn the 
base station off, and then turn the base station on again and re-connect, before 
a new name appears in the log on window and on the status bar.

Default profiles Lets you configure default profiles. Click Channel Profile or Signal Profile 
to open the editing dialog box for the corresponding default profile.   

Default channel Specifies the default channel. Select a channel from the drop-down list to make 
it the default channel (see “Default Channel” on page 5). The drop-down list 
contains all the channels that have been defined in the channel table (Configure 
> Base Station > Channel Table). Each entry in the list contains a channel 
number followed by the corresponding channel name. 

Network identity Specifies the IP address and other network parameters of the base station. These 
details are only needed if the base station is fitted with an Ethernet interface. 
They are used in remote communications with the Service Kit and with an 
optional syslog collector.

By default, there is no network identity and the network interface is disabled.  
Before the base station is installed on site, you need to connect via RS-232 and 
give it its proper network identity. You must also define a network connection 
in the Service Kit so that it can remotely connect to the base station. It is a good 
idea to keep a written record of each base station’s network identity, but if you 
lose the information, you can recover it by connecting to the base station via 
the front panel at startup, and then reading the configuration.
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When you program a configuration into the base station, the Service Kit checks 
whether the network identity of the configuration is the same as the network 
identity of the base station. If it is not, you are given the choice of overwriting 
the network identity, or of keeping the existing network identity, while 
updating the rest of the configuration. A new network identity only takes effect 
when the Service Kit session ends.

The network identity consists of the following three items.  

IP address specifies the IP address of the base station in dotted quad format. 
Entering a proper IP address also enables the Ethernet interface. 

Subnet mask specifies the subnet mask. Enter the mask required by the IP 
addressing plan for the network. This tells the base station the IP address range 
of equipment on the local subnet. If you are connecting the Service Kit directly 
to the base station or via a port on a local hub or switch, you can leave this box 
empty. (An empty Subnet mask box is equivalent to a mask of 0.0.0.0, which 
means that no IP packets will be sent outside the local subnet.) 

Default gateway can be used to specify the IP address of the first router on 
the communication path from the base station to the Service Kit or syslog 
collector. The network design may require that you configure the base station 
with this information. If you are connecting the Service Kit directly to the base 
station or via a port on a local hub or switch, you can leave this box empty. (An 
empty Default gateway box is equivalent to a default gateway address of  
0.0.0.0.) 
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Configuring the System Interface

The System Interface form (Configure > Base Station > System Interface) lets 
you configure the base station’s system interface. 

Simple repeater applications do not require any interface. 

The form displays the pin assignments and other information for the selected 
system interface. It lets you configure the RSSI output line and the external 
channel selection lines. 

Viewing System Interface Details
You can view the pin assignments for the system interface.

1. Log on to the base station and select Monitor > Module Details > Reciter 
to find out which system interface is fitted.

2. Select Configure > Base Station > System Interface.

3. In the Type list, select the system interface that has been fitted. 

The table underneath the Type box now shows you the pin assignments for 
that system interface. The pin assignments will update to reflect any changes 
you make to external channel selection. See “Configuring External Channel 
Selection” on page 85. 

The TaitNet Ethernet system interface has two assignments for some pins, for 
example pin 3: ‘Rx audio or M out.’ A hardware link on the system interface 
board determines which assignment is valid. The first assignment shown is the 
factory default. The other assignment can be selected by changing the link. See 
TN-1142 for details. 
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Configuring External Channel Selection
Usually, the channel that the base station normally operates on is selected using 
the Service Kit (see “Default channel” on page 82). If you want the channel to 
be selected by equipment external to the base station, enable external channel 
selection and configure the base station’s system interface to reflect the way that 
equipment works. Then the channel number to use is computed from the state 
of the selected digital inputs.

To configure external channel selection

1. Select Configure > Base Station > System Interface. 

2. Select the Channel selection check box. This enables external channel 
selection.

3. In the Pins to use box, select an option. For each bit in the binary channel 
number, you need a pin. 

4. If the system interface uses any dual-purpose pins as digital outputs, click 
Map Inputs and edit the mapping of digital inputs to bits, so that channel 
selection doesn’t use any digital ouputs. For details, see “Mapping Digital 
Inputs” on page 85.

The table to the left updates to indicate which pins are for channel selection 
and the Number of selectable channels box updates to indicate the high-
est channel number that the hardware will be able to select.

5. Specify whether the external equipment selects the channel number using 
binary or BCD format. 

Important: The base station interprets a line as ‘1’ when it is active 
(when the external equipment is pulling it to ground, the voltage is 
low, and current is flowing). 

6. If the external equipment pulls a line to ground to indicate a ‘0’, select the 
Invert box.

7. Use the Service Kit to test your setup. See “Testing Hardware Channel 
Selection” on page 172.

Note: Setting the channel to 000 (by switching all DIP switches 
off—or on, if the selection is inverted) disables external channel 
selection. The base station will operate on the channel selected by 
the Service Kit or by Task Manager action.

Mapping Digital Inputs
Normally, channel selection uses the available digital inputs in order, even 
though some digital inputs are dual-purpose and can be used as digital outputs. 
For example, 3-bit channel selection uses the digital inputs 1, 2, and 3, where 
1 is the least significant bit. You can however individually map each digital 
input to a particular bit that is part of the channel number. This becomes 
necessary if normal channel selection would use a digital input that is already in 
use as a digital output. 

Tip: Map the digital inputs before enabling channel selection via the 
system interface. The display then shows the default mapping of pins 
to digital inputs.
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To map digital inputs to bits used for channel selection

1. Select Configure > Base Station > System Interface.

2. In the Type box, select the system interface type that the base station is 
fitted with. 

3. Click Map Inputs.  The Digital Inputs Map dialog box appears.

4. For each bit that is required, enter the number of the digital input to be used. 

5. Click OK. The pinout table has updated to reflect the mapping you 
specified. 

6. Enable and configure channel selection (see “Configuring External Channel 
Selection” on page 85).

Configuring RSSI Output
If your system has equipment external to the base station that needs an RSSI 
voltage, you can configure that voltage to suit the equipment. 

If the equipment is configured to operate with older Tait base stations, you can 
specify that the RSSI output behaves like the output from a Tait T800 VHF or 
UHF base station. 

For other equipment, specify the maximum and a minimum output voltage that 
your equipment expects, and the maximum and minimum signal strengths that 
the base station needs to deal with. The base station will then map the signal 
strength range to the output voltage range. When it receives a valid signal, it 
outputs an RSSI voltage based on the strength of that signal. 

Tip: Alternatively, leave the RSSI output as it is and adjust the 
external equipment to work with that output. Use the RSSI output 
test when making the adjustment (Diagnose > Reciter > Misc I/O).
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To configure the RSSI output

1. Select Configure > Base Station > System Interface.

2. If your equipment is configured to work with Tait T800 equipment, in the 
Characteristics box, select Emulate T800 VHF or Emulate T800 UHF. 
This sets the parameters for the RSSI output. Otherwise, select User 
Defined and continue.

3. In the Voltage boxes, set the maximum and minimum voltages that the 
RSSI output will provide when the received signal varies from maximum 
to minimum.

4. In the Signal level boxes, specify the received signal strengths in dBm to 
correspond to the minimum and maximum voltages. (If you work in 
microvolts, see “Converting Between Microvolts and dBm” on page 88.)

When the signal strength reaches the lower value, the RSSI output line will 
have the minimum voltage. As the received signal strength increases, the 
voltage will increase linearly. When the received signal strength reaches the 
upper value, the RSSI output line will have the maximum voltage. Further 
increases in signal strength will not significantly increase the RSSI voltage. 
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Converting Between Microvolts and dBm
The following table lets you convert displayed levels in dBm into microvolts. 

Level in 
Microvolts

Level in dBm
Level in 
Microvolts

Level in dBm

0.10 -126.99 10.00 -86.99

0.20 -120.97 12.50 -85.05

0.25 -119.03 15.00 -83.47

0.30 -117.45 17.50 -82.13

0.40 -114.95 20.00 -80.97

0.50 -113.01 30.00 -77.45

0.60 -111.43 40.00 -74.95

0.80 -108.93 50.00 -73.01

1.00 -106.99 60.00 -71.43

1.50 -103.47 70.00 -70.09

2.00 -100.97 80.00 -68.93

2.50 -99.03 90.00 -67.90

3.00 -97.45 100.00 -66.99

4.00 -94.95 150.00 -63.47

5.00 -93.01 200.00 -60.97

7.50 -89.49 250.00 -59.03 
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Configuring Fan Control

The Fan Control form (Configure > Base Station > Fan Control) gathers 
together fan-related settings.

PA Fan Control
The PA Fan Control area determines when the PA fan is turned on. The 
settings can be adjusted to meet user requirements based on on the transmit duty 
cycle and whether the site facility is air-conditioned. Strike a balance between 
lengthening fan life and reducing the PA operating temperature.The settings 
you choose should also help avoid extreme temperature swings. Bear in mind 
that the PA is designed to run at full duty cycle at up to +60°C ambient 
operating temperature into any transmit VSWR load.

Note: While the PA fan on/off thresholds are user-configurable, the 
PMU fan has fixed on/off thresholds controlled by the PMU 
firmware.

Threshold 
temperature

If the temperature at the driver, final 1, or final 2 stages exceeds the threshold 
temperature, the fan is turned on (but only when the PA is transmitting, if the 
check box below is selected). When the temperature at all three parts of the PA 
falls 5°C below the threshold, the fan is turned off. 

Tip: To monitor all PA temperature values, select Diagnose > Power 
Amplifier > Control Tests. 

Only run fan when 
transmitting

When this check box is selected, the fan will only operate if the PA is 
transmitting and any one of the monitored PA temperatures exceeds the 
threshold.

Emulating T800 Fan Operation
In Tait T800 series base stations, the fan is usually turned on and off based on 
the state of the transmitter’s RF output. To emulate this, follow these steps:

1. Select Configure > Base Station > Fan Control.

2. Set the threshold temperature to a value that is lower than the usual site 
ambient temperature.

3. Select the Only run fan when transmitting check box.

With these settings, the PA fan turns on with RF output and cools the PA as 
soon as it begins working. It turns off when the RF output stops. The PA does 
not turn on if its temperature is below the threshold. This is an improvement 
compared with the T800 and lengthens fan bearing life.
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Select fan type
The Select fan type area (Configure > Base station > Fan Control) lets you tell 
the base station what kind of fans (both PA and PMU) it is fitted with. 

Note: Fans used in the TB8100 must have the correct wiring. Power 
and ground (2-wire fans) or power, ground and rotation detect (3-
wire fans). Both fans in a subrack should be of the same type.

Specify whether the fan type is 2-wire or 3-wire. If you select 3-wire, the 
base station will use the third wire as a rotation detector. If it has turned the 
fan on but does not detect rotation, it activates the ‘Fan failed’ alarm.
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Configuring Miscellaneous Items

The Miscellaneous form (Configure > Base Station > Miscellaneous) gathers 
together a number of settings.

Tx relay operation
The Service Kit lets you enable the control of an antenna relay and configure 
its operation. The base station’s reciter must be fitted with a system interface 
board that has a Tx Relay Driver line for connecting to the antenna relay (see 
Configure > Base Station > System Interface for pinout information). 

Antenna relays (also known as coaxial relays) are used in simplex applications. 
If the transmit and receive frequencies are equal, the base station automatically 
increases the transmitter frequency by 25 kHz when the base station is not 
transmitting, to prevent desensitisation of the receiver.

Before the transmitter keys up, the base station activates the relay, disconnecting 
the receiver and connecting the transmitter to the antenna. It waits for the ‘relay 
closing settling time’, and then powers the transmitter up. After it powers the 
transmitter down, it waits for the ‘delay before relay opens’, and then opens the 
relay.

To enable and configure the operation of an antenna relay

1. Select Configure > Base Station > Miscellaneous

2. Select the Tx relay operation check box.
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3. Adjust the values of the Relay closing settling time (A) and the Delay 
before relay opens (B) boxes to reflect the expected delays in switching 
the relay. 

Minimum battery voltage
The Power configuration area (Configure > Base Station > Miscellaneous) 
defines the lowest possible voltage for the DC power input to the PMU. 

Three pairs of voltages are displayed, corresponding to the PMU’s different 
DC-DC converter options (a nominal 12 V, 24 V, or 48 V input). If there is 
no AC power and the battery voltage falls below the value in the relevant 
Power shutdown voltage box, the base stations in the subrack shut down. If 
the voltage rises above the value in the Power startup voltage box and the 
PMU is fitted with a standby module, the base stations re-start.

Important: The values you define in this area affect any other base 
stations in the subrack.

To edit a voltage value, click the up or down arrow alongside. 

Base stations with no PMU cannot have their shutdown and startup voltages 
adjusted; these voltages are fixed in hardware. 

Auxiliary power control
If the PMU is fitted with an auxiliary power supply unit, you may need to 
configure it to suit the way it will be used. Generally, its output can be used to 
charge batteries or to power other site equipment. This equipment can include 
TaitNet trunked modules. These can be powered via the reciter’s system 
interface board (additional connection required). 

Caution: While the auxiliary power output can be used for more than one 
purpose at once, this is not generally recommended. It can result in a short-
circuit and equipment damage. The output is floating. If it is connected to a 
negatively earthed battery and to positively earthed auxiliary equipment, a 

short-circuit will result.

In the default configuration file, the auxiliary power supply is configured to turn 
on only when the base station is mains powered (see the Mains option below). 
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In the Power configuration area (Configure > Base Station > Miscellaneous), 
the Aux power control box specifies what controls the auxiliary output. Select 
one of the following options.

CTCSS characteristics
The CTCSS characteristics area (Configure > Base Station > Miscellaneous) 
lets you globally configure CTCSS subaudible signalling to emulate the T800 
or to follow the TIA/EIA603 standard.

Reverting to Run mode
You can configure the base station to automatically revert to Run mode. This 
is recommended if Service Kits will remotely connect to the base station over 
unreliable communication lines. 

Option Description

Task Manager The auxiliary output is only turned on by Task Manager action. 
You need to define suitable tasks for your system and 
application so that the auxiliary power output is turned on 
when it is needed. To help you with this, two Task Manager 
tasks have been created and disabled. 

To have the auxiliary power on all the time, simply enable the 
task 'IF Base Station in Run mode THEN Enable Auxiliary 
Supply.' 

If you only want the auxiliary power on in special 
circumstances, enable the task  'IF Base Station in Run mode 
THEN Disable Auxiliary Supply' and create additional tasks that 
define when the auxiliary power is turned on and off.

Mains This is the setting in the default configuration file. Output is 
provided only when the PMU uses AC mains power. This 
option is suitable for trickle charging the batteries used for the 
PMU’s DC power input. If the base station has a DC only PMU, 
this setting never turns the auxiliary power on.

Option Detection time
Detect 
bandwidth

Reject 
bandwidth

T800 < 150 ms 2 Hz 3 Hz

EIA603 120 – 250 ms
(for  250  – 67 Hz)

1.8% 3%
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In the Power configuration area (Configure > Base Station > Miscellaneous), 
select one of the following options for the Revert to Run mode box.

Select external clock reference frequency (if fitted)
The Select external clock reference frequency (if fitted) area (Configure > Base 
Station > Miscellaneous) lets you specify the frequency of an external reference 
frequency source. If an external source is connected to the reciter, select the 
appropriate option to tell the base station what the source’s frequency is. 

Enabling Automatic Entry Into CCI Mode
TB8100 base stations can be controlled by any computer program that uses the 
Tait Computer Controlled Interface (CCI) protocol. This can be done 
remotely via RS-232 or TCP/IP connections. The computer program can send 
a logon sequence to put the base station into CCI mode, or you can configure 
the base station to automatically enter CCI mode on entering Run mode. For 
more information, see TN-947-AN, TB8100 Base Station Computer Controlled 
Interface Protocol. 

Note: Tait does not recommend the use of automatic entry into CCI 
mode if the remote connection uses TCP/IP over Ethernet. If the 
base station automatically enters CCI mode it cannot send syslog 

messages.

To enable automatic entry into CCI mode

1. Select Configure > Base Station > Miscellaneous.

2. Select the Enter CCI in Run mode check box.

3. If the computer program will be connecting via RS-232, select a suitable 
baud rate. 

When you program this configuration into the base station, and then put it 
in Run mode, the base station enters CCI mode and communicates using 
the baud rate you specified.  

You can still connect the Service Kit to a base station when it is in CCI 
command mode. The Service Kit must connect at the baud rate configured 
for CCI mode. Connecting the Service Kit takes the base station out of CCI 
mode. 

Option Description

Never The base station does not revert to Run mode. Service Kit users 
must manually put the base station back into Run mode before 
disconnecting. You are warned if you try to disconnect when 
the base station is still in Standby mode.

2 minutes The base station automatically reverts to Run mode two 
minutes after the Service Kit disconnects.

10 minutes The base station automatically reverts to Run mode ten 
minutes after the Service Kit disconnects.
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Printing a Base Station Configuration

The Service Kit lets you print configuration data that you have opened from a 
configuration file or read from a base station.

Note: Printing to an old-style text printer is not supported; the 
layout requires the use of large and small fonts.

To print a configuration

1. Select File > Print. The Print Selection dialog box appears. 

2. Using the arrow buttons, select the configuration items you want printed. 
An item is selected for printing when it is in the right-hand box.

The >> and << buttons move all configuration items.

The > and < buttons move the highlighted item. Click an item to 
highlight it.

3. Click Printer Settings and check the printer setup.

4. Click Print to send the configuration information to the printer.



96 Part E: Configuring the Base Station    © Tait Electronics Limited April 2006



TB8100 Service Kit User’s Manual   Configuring Channels 97

Part F Configuring Channels

The Service Kit lets you configure the TB8100 base station’s 
channels and their underlying profiles.

Click Configure, and then select an appropriate item from the 
navigation pane. 

Topics

Getting Started with Channels

Customizing the Default Channel Profile

Customizing the Default Signalling Profile

Using Advanced Profile Features

Working with Channel Profiles

Working with Signalling Profiles

Working With the Channel Table

Selecting a Channel

Printing Channel Data
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Getting Started with Channels

To set up channels, you first edit the default channel and signalling profiles. This 
defines the configuration items that are the same for all channels. Then in the  
channel table you create the channels you need, for example, by editing the one 
channel in the table and block copying it to give a set of channels all with the 
same channel spacing. You then edit the channels as needed, for example, to 
vary the subaudible signalling for different channels. Finally, you select one 
channel to be the default.

The following instructions describe the main steps you need to follow. If the 
base station has the Advanced Profiles and Task Manager license, more options 
are available. See “Using Advanced Profile Features” on page 103.

To set up channels

1. Open a suitable configuration file or read the configuration of the base 
station you are logged on to. For more information, see “Working With 
Base Station Configurations” on page 49.

2. Select Configure > Base Station > General. In the Default profiles area, 
click Channel Profile. 

3. Edit the settings in the Edit Channel Profile form to reflect the requirements 
of the channels in the system. For more information, see “Customizing the 
Default Channel Profile” on page 100. Click OK to confirm your changes 
and return you to the General form.

4. In the Default profiles area, click Signal Profile. 

5. Edit the settings in the Edit Signalling Profile form to reflect the 
requirements of the channels in the system. For more information, see 
“Customizing the Default Signalling Profile” on page 102. Click OK to 
confirm your changes and return you to the General form.

6. Select Configure > Base Station > Channel Table to open the Channel 
Table form. 

7. Pick a channel from the table (there may only be one), and give it the first 
transmit and receive frequencies in the band plan. Make any other 
configuration changes needed. For details, see “Editing a Channel (Default 
Profiles)” on page 136.

8. Click Block copy and specify the number of channels that you need. 

If the interval between channels is not regular, or if block copy is not appro-
priate for any other reason, use Insert Copy instead. Copy an existing 
channel as needed and edit the copies to get the results you want.

9. When the channels are set up to your satisfaction, return to the General 
form (Configure > Base Station > General) and select a channel as the 
default. All the channels you created will appear in the drop-down list.

10.Click OK to commit your changes and close the form. 

11.Save the changes to a configuration file.

12.Program the changes into the base station. 



100 Part F: Configuring Channels    © Tait Electronics Limited April 2006

Customizing the Default Channel Profile

The Edit Channel Profile dialog box lets you customize the default channel 
profile to suit your system. Some items display ‘See channel table.’ You 
configure them in the  channel table so that you can give different channels 
different values.

To customize the default channel profile

1. Select Configure > Base Station > General.

2. In the Default profiles area, click Channel Profile. The Edit Channel 
Profile form appears.

Note: If the base station is part of a TaitNet MPT 1327 trunked 
system, see TN-745 for instructions on how to configure channels 
and profiles.

3. In the General tab, define the following:

a. The subaudible deviation if the base station will transmit with CTCSS 
or DCS.

b. The talk-through repeater gain if the base station will be used as a 
repeater.

c. The criteria for receiver gating (see “Configuring Receiver Gating” on 
page 106). 

d. If desired, a special transmitter power output level, for selection by Task 
Manager action. 

4. In the Signal Path tab, do the following:
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a. Use the check boxes to enable the audio paths you require. Enabled 
paths are displayed as dark lines. 

b. Select levels for any line inputs and outputs.

Note: The base station can only provide line in and line out audio if 
the system interface card fitted in the reciter has these audio 
interfaces.

5. In the Power Saving tab, configure Normal power saving mode. If the base 
station has a Power Saving Modes license, you can also configure Sleep and 
Deep Sleep modes. (See “Configuring Power Saving” on page 106).

6. If your system needs to broadcast its ID using Morse code, select the CWID 
System tab and configure the profile appropriately.

7. In the Task Manager tab, use Task Manager to define any inputs and actions 
to customize the way channels with the default profile will respond in 
different situations. 

8. Click OK to confirm your changes and close the dialog box.
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Customizing the Default Signalling Profile

The Edit Signalling Profile dialog box lets you modify the default signalling 
profile to suit your system. Some items display ‘See channel table.’ You 
configure them in the  channel table so that you can give different channels 
different values.

To customize the default signalling profile

1. Select Configure > Base Station > General.

2. In the Default profiles area, click Signal Profile. The Edit Signalling Profile 
form appears.

Nothing in the Subaudible Signalling tab can be configured. Subaudible sig-
nalling is defined for each channel in the channel table. The tone table is 
only available for custom profiles. 

3. In the Tx Timers tab, configure the way the audio, signalling, and carrier 
end at the end of a transmission. You can also enable transmit lockout and 
anti-kerchunking.

4. In the Advanced tab, check that the settings for CTCSS gating are suitable. 

5. Click OK to confirm your changes and return to the General form.
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Using Advanced Profile Features

There are two different ways to configure channels. The basic way uses default 
profiles and the advanced way uses custom profiles.  The advanced way requires 
an Advanced Profiles and Task Manager license.  

The basic way defines most settings in the profiles. The rest are defined in the 
channel table. You select values for each channel. 

The advanced way defines nearly all the settings in custom profiles. The channel 
table only defines the transmit and receive frequencies for each channel. The 
channel table still displays the same items, but their settings are determined by 
the profiles assigned to the channels.  The advanced way is more flexible and 
powerful. In the following situations, you must use custom profiles:

The base station needs to respond to more than one subtone. In other 
words, one channel must be able to decode/encode several different 
subtones.

Different parts of the audio path need to use different filters.

Channel or signalling profile settings need to be different for different 
channels. In other words, the settings that you specify for the default profiles 
cannot be used for all channels.

The receive and the transmit frequencies need to have a different channel 
spacing.

You want to use Task Manager to change a profile setting. This is done by 
getting Task Manager to switch the base station to a channel with a different 
custom profile.

Many users combine both ways to configure channels. They use default profiles 
for most channels but create a set of their own profiles for channels with 
advanced configuration requirements.
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Working with Channel Profiles

The Channel Profiles form (Configure > Base Station > Channel Profiles) lets 
you work with channel profiles. You can view the profile list, add a new profile, 
or edit an existing one.

The form displays a row of information for each profile. ‘See channel table’ 
means that the channel table, not the default profile, defines the setting.

The Channel profile name column indicates the name of the profile. 
‘Default’ is a built-in profile; it can be edited but not deleted. 

The Filter column indicates the audio filter that the profile specifies. ‘Multiple’ 
means that different audio paths use different filters. The Default profile does 
not specify an audio filter; this is done in the channel table.

The Transmitter power column indicates the defined transmitter power 
output. If a custom profile defines different values for mains and battery power, 
the value for mains power is displayed.

The Channel spacing column indicates the nominal or minimum channel 
spacing of channels that are assigned the profile. If a custom profile defines 
different values for the transmit and receive frequencies, the value for the 
receive frequency is displayed.

For more detail about these columns, and about other profile details, see 
“Editing a Channel Profile” on page 107.

Buttons along the bottom of the form let you add a new profile or copy, edit, 
or delete the selected profile.

Adding a Channel Profile
The Add Channel Profile dialog box lets you define the settings for a new 
channel profile and add it to the list of available profiles. You can only do this 
if the base station has the Advanced Channel and Signalling Profiles feature set.

The following instructions do not deal with all configuration items. For more 
detailed information about these dialog boxes, see “Editing a Channel Profile” 
on page 107 (the Add Channel Profile and Edit Channel Profile dialog boxes 
are almost the same).

Important: If the base station doesn’t have an Advanced Profiles 
license, don’t add profiles. The channel table cannot use them.
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Tip: Set up a test profile and assign it to a channel. Use this channel 
when testing your system before commissioning.

To add a channel profile

1. Select Configure > Base Station > Channel Profiles. The Channel Profile 
form appears.

2. Click Add. The Add Channel Profile window appears.

3. In the General tab, define the following:

a. A suitable name for the profile. 

b. The channel spacing for the receiver and the transmitter (they do not 
need to have the same setting).  

c. The subaudible deviation if the base station will transmit with CTCSS 
or DCS.

d. The talk through repeater gain if the base station will be used as a 
repeater.

e. The transmitter’s RF power output, for mains and for battery operation. 
You may, for example, want to specify the full output for mains opera-
tion, but a lower value when the transmitter is operating from battery 
power. 

f. Optionally, a special transmitter power output level, for selection by 
Task Manager action. 

g. The criteria for receiver gating (see “Configuring Receiver Gating” on 
page 106). 

4. In the Signal Path tab, do the following:

a. Use the check boxes to enable the audio paths you require. Enabled 
paths are displayed as dark lines. 

b. Using the Filter drop-down lists, select for each audio path the filter you 
want. Thumbnail sketches display graphs of the selected filter’s audio 
characteristics. (For some applications, you bypass the filter. For TaitNet 
MPT trunking, see TN-745 and for data applications using external 
modems, see TN-1114-AN.)

c. Select levels for any line inputs and outputs.

Note: The base station can only provide line in and line out circuits 
if the system interface card fitted in the reciter has pins for them.

5. In the Power Saving tab, configure power saving. If the base station has a 
Power Saving Modes license, you can configure all three modes (see 
“Configuring Power Saving” on page 106).

6. If your system needs to broadcast its ID using Morse code, select the CWID 
System tab and configure the profile appropriately.

7. In the Task Manager tab, use Task Manager to define any inputs and actions 
to customize the way channels with this profile will respond in different 
situations.

8. If your system requires a tone on idle, select the Tone on Idle tab and enable 
and configure this feature (see “Tone On Idle” on page 122).
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9. Click OK to confirm your changes and close the dialog box. The profile 
you defined appears in the Channel Profiles form.

Configuring Receiver Gating
The Rx Gating area of the General tab lets you configure the way the receiver 
gates the audio signal. 

Figure 2: Receiver Gating

To configure receiver gating

1. Open the Add or Edit Channel Profile dialog box for the profile whose 
receiver gating you want to configure.

2. Select whether the receiver gate will open based on RSSI, SINAD, or both.

3. If you selected both RSSI and SINAD, you need to specify whether both 
conditions need to be met, or only one. In the receiver gating logic box, 
select AND or OR. AND means that both RSSI and SINAD must reach 
their level before the receiver gate opens. OR means that the receiver gate 
opens if either the RSSI or the SINAD level is reached.

4. In the RSSI and/or SINAD areas, enter a gating level. When the level you 
set is reached, the receiver gate opens. (If you enabled both gating types and 
selected AND, both RSSI and SINAD levels must reach their level.)

5. Set the hysteresis. This defines the amount that the RSSI or SINAD must 
fall below the gating level before the receiver gate closes. 

Configuring Power Saving
For each channel profile, you can configure three power saving modes: 
Normal, Sleep, and Deep Sleep. The configuration will be applied to channels 
with the profile you are working on.

Note: Sleep and Deep Sleep modes are only available if the base 
station has a Power Saving Modes license and is operating on battery 
power.

Time

Signal strength or SIN
A

D

Gate 
opens

<
--H

ysteresis-->

Gating level

Gate 
closes



TB8100 Service Kit User’s Manual   Working with Channel Profiles 107

To configure power saving

1. Open the Add or Edit Channel Profile dialog box for the profile whose 
power saving you want to configure.

2. Select the Power Saving tab.

3. For each power saving mode, follow these steps:

a. Select the check box to enable the mode (Sleep and Deep Sleep only).

b. In the Rx cycling box, select a time from the drop-down list. This spec-
ifies how long the receiver is turned off before being turned on again. If 
you select ‘No cycling’, there is no receiver power saving in this mode. 

c. In the Tx keyup box, select a time from the drop-down list. This spec-
ifies the amount of time that the transmitter will need to key up. The 
longer the time, the more circuitry can be switched off. (In Sleep and 
Deep Sleep modes, the Tx keyup time is fixed.)

d. In the Start after box, specify a length of time. When the base station 
has been idle for this length of time, it switches from Normal to Sleep 
mode, or from Sleep to Deep Sleep mode. ‘Idle’ means not operating as 
a talk through repeater or line-connected base station. A base station still 
counts as idle, even if it makes scheduled CWID transmissions or trans-
missions using the front panel microphone.

4. If desired, use the Task Manager action Disable Power Saving to disable 
power saving when it is not needed. For example:

IF Battery voltage low THEN Enable power saving
IF NOT  Battery voltage low THEN Disable power saving

Editing a Channel Profile
The Edit Channel Profile dialog box lets you view the details of the selected 
channel profile and modify them. 

Next Profile and Previous Profile let you move from one profile to another 
without leaving the dialog box. 

Important: If you have made changes to the current profile, click 
OK to confirm them before moving to another profile. 

Some items in the Default channel profile display ‘See channel 
table.’ You specify them individually for each channel in the channel table 
(Configure > Base Station > Channel Table).
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 General
The General tab in the Add or Edit Channel Profile dialog box names the 
channel profile and defines its general characteristics.

Profile name Specifies the name of the profile. You can edit the name of custom profiles.

RF Configuration
In the Add or Edit Channel Profile dialog, General tab, the RF configuration 
area lets you specify the nominal channel spacing for the receiver and the 
transmitter. No hardware modification is necessary when the RF configuration 
is changed.

Note: Your country may use Narrow band, Mid band and Wide 
band to refer to different channel spacings. Make sure that the 
option you select has the correct value. 

Receiver channel Specifies the receiver’s nominal channel spacing. The available options are 
expressed both as a description (for example, Mid Band) and as the kHz value 
of the nominal channel spacing.

Option Equivalent Rx IF Bandwidth

12.5 kHz Narrow Band 7.5 kHz

20 kHz Mid Band 12 kHz

25 kHz Wide Band 15 kHz
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Note: The Receiver channel box does not determine the actual 
spacing between channels. It determines the receiver IF bandwidth. 
For example, 20 kHz Mid Band sets the receiver IF bandwidth to 

12 kHz. Normally, you would select this option if the channels in your band 
plan have a 20 kHz channel spacing. However, your band plan may be 
irregular, or you may want to specify (in the channel table) a greater spacing 
between channels, for example, 50 kHz. 

Max Tx deviation Specifies the highest deviation that the transmit channel is permitted to have. 
The available options correspond to the following channel spacings:

Subaudible 
deviation

Specifies the deviation that CTCSS or DCS signalling will cause to the carrier 
frequency. Options are specified both absolutely in Herz and relatively as a 
percentage of the selected Max Tx deviation. Gain will be applied to the 
CTCSS signalling to cause the deviation specified. If you subsequently alter the 
Max Tx deviation, the Herz value of the subaudible deviation will alter, but not 
its percentage.

Max Tx deviation 
has subaudible 
signalling

Specifies whether subaudible signalling adds to the actual maximum transmit 
deviation or is included in it. It is important to select the correct option to 
ensure that you comply with the relevant standards. 

Talk through 
repeater gain

Specifies the gain in dB that will be applied to received audio that is fed into 
the transmitter. See “Repeater Options” on page 116. 

Option Channel Spacing

2500 Hz Narrow Band 12.5 kHz

4000 Hz Mid Band 20 kHz

5000 Hz Wide Band 25 kHz

Option Description

Superimposed The subaudible (10–300 Hz band) deviation does not alter the audio (0.3–3.4 kHz 
band) deviation transmit levels. The audio path signal thus uses all the allocated 
channel deviation and subaudible signals are summed on top of the audio signal. 
It is therefore possible to transmit levels that exceed the channel limits.

For example, if a wide band channel is configured with a subaudible deviation 
level of 10% and a line input level of -10 dBm, its transmit deviation (with the 
subaudible signal filtered out) will be 3.0 kHz, when the line audio input is 
-10 dBm. 

Included The subaudible deviation reduces the level of the audio deviation out of the 
limiter by the amount of subaudible deviation selected. This ensures that the 
radio will never transmit levels that exceed the maximum transmit deviation 
when using subaudible signalling.

For example, if a wide band channel is configured with a subaudible deviation 
level of 10% and a line input level of -10 dBm, its transmit deviation (with the 
subaudible signal filtered out) will be 2.5 kHz, when the line audio input is 
-10 dBm. The maximim in-limiting deviation will be 4.5 kHz, within the 5 kHz 
channel limit. 



110 Part F: Configuring Channels    © Tait Electronics Limited April 2006

Automatic gain 
control (AGC)

Specifies whether automatic gain control is applied by UHF receivers (H, K, 
and L bands) to received audio. AGC is applied at the RF stage. It enhances the  
ability to handle high signal levels and to protect against receiver 
intermodulation. However, when signal levels are high, the minimum 
sensitivity may be degraded. The AGC setting has no effect on VHF receivers.

AGC is normally enabled, but Tait recommends disabling it when: 

The anticipated receive signal strength is < -107 dBm (1 microvolt) and 
strong interfering signals (> -30 dBm (7000 microvolts)) are anticipated at 
the receiver input.

TIA/EIA or AS-4295 RF performance testing is being carried out.

Transmitter Power Output
In the Add or Edit Channel Profile dialog, General tab, the Transmitter 
power output area specifies the output power of the transmitter. 

The output power is specified separately for mains-powered and for 
battery-powered transmissions. You can also specify a third output power, for 
selection by Task Manager action. The boxes alongside display the equivalent 
power in dBm. 

If you specify 100 W and the PA is rated at 50 W, it will run at 50 W. There 
is therefore no need to alter this value if you temporarily substitute an amplifier 
with lower power, for example, if there is a fault and you don’t have a fully 
powered module on hand.

Receiver Gating
In the Add or Edit Channel Profile dialog, General tab, the Receiver Gating 
area configures receiver gating (also known as receiver squelch). 

You can have gating based on:

RSSI 

SINAD 

RSSI and SINAD

RSSI or SINAD

RSSI gating operates more quickly and is suitable for multiple repeater links or 
for base stations with external data modems. SINAD gating takes longer but is 
more immune to noise interference and is suitable for the repeater itself or for 
a line-connected base station. For information about gating in a base station 
with Power Save, see the Installation and Operation Manual. 
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RSSI Gating 
(carrier)

Enables gating based on the base station’s measurement of the received signal 
strength. This is also known as Carrier gating. This method is not 
recommended for low signal levels. If the level is set low (for example -118 
dBm) and the hysteresis is set to High, the gate may stay open permanently. 

SINAD Gating 
(noise)

Enables gating based on the ratio of signal to noise and distortion. This is also 
known as noise gating. 

Gating logic When both RSSI and SINAD gating options are enabled, an unlabeled 
drop-down list box lets you specify the gating logic. 

Tip: Select OR and set the RSSI level high (for example -100 dBm). 
This gives you quick gating when the signal level is high. When the 
signal level is low, gating occurs based on SINAD. This is slower but 
more immune to noise interference. 

Level The two Level boxes define the level (of RSSI or SINAD) required to enable 
receiver gating and pass the received audio. Even if RSSI gating is disabled, the 
RSSI level is used in power saving to quickly detect whether signal is present. 
See the Installation and Operation manual for more details.

Hysteresis The two Hysteresis boxes specify how far the RSSI or SINAD must fall below 
the level set in the corresponding Level box to disable receiver gating and mute 
the received audio. 

Time

Signal strength or SIN
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Gating level
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Option Description

AND The receiver gate opens when both RSSI and SINAD 
values reach the required level.

OR The receiver gate opens when just one of the RSSI or 
SINAD values reaches the required level. 
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The Hysteresis box for RSSI gating provides the options Low, Medium, and 
High. Typically, these options correspond to hysteresis values of 1–2, 2–5, and 
5–10 dB respectively. The actual hysteresis varies with the RSSI gating level 
(see below). 

Set the hysteresis level you want, test TB8100 operation, and adjust the setting 
as appropriate.

Note: SINAD dB hysteresis is a recovered audio level measurement. 
It does not correlate to RF dBm levels.

Table 1: Typical hysteresis values for the different hysteresis options

Gating Level Low Medium High

-119 dBm 0.8 3.5 5

-118 dBm 1.1 3.4 5.9

-117 dBm 1.3 3.8 5.4

-116 dBm 1.9 3.9 6

-115 dBm 2.2 4.7 6.4

-114 dBm 2.4 4.7 6.4

-110 dBm 2.9 5.6 7.4

-105 dBm 3.4 6.1 8.1

-100 dBm 3.8 6.8 8.7

-95 dBm 4.1 6.8 8.6

-90 dBm 4.7 7 9.2



TB8100 Service Kit User’s Manual   Working with Channel Profiles 113

Signal Path
In the Add or Edit Channel Profile dialog, the Signal Path tab lets you configure 
the path that incoming and outgoing signals take. In effect, you can design your 
own virtual backplane for the base station. 

The left-hand side of the tab defines RF filter characteristics. Each panel has a 
drop-down list you can choose from, and a thumbnail graphic showing you the 
response characteristics of the filter you chose.

The middle of the tab displays possible audio paths as light gray lines. Check 
boxes and a drop-down list let you select path options. When you select an 
item, the path it enables appears as a thick green (transmit path) or red (receive 
path) line. 

Both the receiver and the transmitter have two paths. Path A connects to a 
balanced line and Path B to an unbalanced line. You can select different filters 
for each path.

Note: You can use Task Manager to disconnect or re-connect parts 
of the signal path in particular circumstances. See “Channel Profile 
Actions” on page 203. Also, Task Manager actions can connect the 

balanced line input to the balanced line output, or the unbalanced line input to 
the unbalanced line output. See “Loopback actions” on page 200.   

Important: The transmitter can be keyed from several differerent 
sources. If the instruction to key up is received from more than one 
keying source, the source with the highest priority level takes 

precedence. Only the audio that belongs to the keying source will be used to 
modulate the transmission. The keying sources and their priority levels are:
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Tip: To transmit audio that is summed from line input and from the 
receiver, connect one line output to the corresponding line input 
and connect external audio to the other line input. In other words, 

loop the received audio back externally because the internal  signal path from 
receiver to transmitter will not be used when the Tx Key line is active. 

Receive Path
In the Add or Edit Channel Profile dialog box, the top half of the Signal Path 
tab lets you configure receive paths. A receive path connects the receiver to the 
speaker output and to a line output.

Note: The path to the speaker is always enabled.  However, the 
speaker buttons on the control panel let you turn the speaker off and 
mute or unmute its audio.

Priority 
Level

Keying Source Audio Used

1 Carrier button on control panel None

2 PTT on microphone connected to 
base station

Microphone

3 External Tx Key line Balanced and/or unbalanced 
line input

4 Valid Receive signal (no separate Tx 
Key line required)

Output from receiver
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Filter The Filter drop-down lists let you select an audio filter for each enabled receive 
path. 

Note: The Path B filter does not appear if the Bypass check box is 
selected.

Rx path A Enables the audio path from the receiver to balanced audio output, using the 
filter selected for Path A. 

Rx path B Enables the audio path from the receiver to unbalanced audio output, using the 
filter selected for Path B.

Bypass Bypasses the receiver filters and limiters. This check box is generally cleared, but 
must be selected for TaitNet MPT1327 trunked networks, to minimise the 
time delay through the base station. This is important when the base station is 
handling FFSK data. See TN-745 for details. 

Extended bypass When the Bypass check boxes are enabled on both the transmit and the receive 
paths, Extended bypass check boxes appear on those paths. For details, see 
“Extended bypass” on page 119. 

Line level The Line level boxes on the receive path set the audio level at the line output 
pins. When the reciter receives a signal that is modulated to 60% of a maximum 
transmit deviation that is equivalent to the receiver setting, it outputs audio on 
the line at the level you set. For channels using the default profile, the receiver 
setting is determined by the channel spacing (see “Channel Spacing” on 
page 135). For channels using custom profiles, it is defined by the Receiver 
channel box  (see “Receiver channel” on page 108).  

Option Description

Flat full band Passes audio evenly across the audio spectrum. 

Flat speech 
band

Passes only speech frequencies.

De-emph 
speech band

Passes audio in the speech range, attenuating higher 
frequencies. This option can be used if the base station will  
receive pre-emphasised transmissions. 

De-emph full 
band

Passes all audio, attenuating higher frequencies.This option 
can be used if the base station will receive pre-emphasised 
transmissions.

Subaudible 
band

Passes only the subaudible band, containing any CTCSS tones 
or DCS codes. This option can be used to separate out the 
signalling and put it on the line output that is connected to a 
tone panel.

Receiver setting 
Equivalent Max Tx 
deviation (Hz)

60% of Max Tx  
deviation (Hz)

12.5 kHz Narrow Band 2500 1500

20 kHz Mid Band 4000 2400

25 kHz Wide Band 5000 3000
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The line level units are dBm for the balanced line output and Vpp (voltage 
peak-to-peak) for the unbalanced line output.

Gated Each line output has a Gated check box. Generally, the check box is selected. 
This outputs audio only when the required conditions (RSSI level, SINAD 
level, subaudible signalling) are met. When the check box is cleared, receiver 
gating is not applied to the audio on the line output. This makes continuous 
listening to the channel possible, for example, when troubleshooting.

Tip: You can configure the base station to output line audio 
differently in different circumstances. Define two profiles with the 
different options. Create two channels that are the same except for 

the assigned channel profiles. Then define Task Manager tasks that switch the 
base station between the two channels, for example, when it receives a 
particular subtone.

Repeater Options
In the Add or Edit Channel Profile dialog box, Signal Path tab, the Talk 
through repeater box specifies the audio path from receiver to transmitter.

Important: If the base station uses the same frequency for 
transmitting and receiving, it cannot function as a repeater. You 
must select ‘Disabled.’ 

Note: You can vary the gain that the base station applies to talk 
through audio. See “RF Configuration” on page 108.

Microphone Panel
In the Add or Edit Channel Profile dialog box, Signal Path tab, the two Mic 
drop-down lists specify the line output and transmit audio paths for any 
microphone connected to the control panel.

Option Description

Disabled There is no audio path. The base station does not function as a 
repeater.

RxA-TxA The base station filters received audio using the receive Path A 
filter and transmits it using the transmit Path A filter.

RxA-TxB The base station filters received audio using the receive Path A 
filter and transmits it using the transmit Path B filter.

RxB-TxA The base station filters received audio using the receive Path B 
filter and transmits it using the transmit Path A filter.

RxB-TxB The base station filters received audio using the receive Path B 
filter and transmits it using the transmit Path B filter.
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Microphone The upper drop-down list specifies the microphone’s line out audio path. 

The lower drop-down list specifies the microphone’s transmit audio path.

Tip: Select Tx A or Tx B so that a technician can use a microphone 
to transmit using the base station.

Transmit Path
In the Add or Edit Channel Profile dialog box, Signal Path tab, the lower area 
lets you configure transmit paths. A transmit path connects received audio or a 
line input to the transmitter.

Filter The Filter drop-down lists let you select an audio filter for each enabled 
transmit path. The options are the same as for the receive paths, except that 
Pre-emphasis filters replace the de-emphasis ones. 

Option Description

None The microphone has no line audio path.

Balanced Connects the microphone to the balanced line output.

Unbalanced Connects the microphone to the unbalanced line output.

All Connects the microphone to both the balanced and 
unbalanced line outputs.

Option Description

None The microphone has no audio path to the transmitter

Tx A Connects the microphone to the transmitter using the Path A 
filter

Tx B Connects the microphone to the transmitter using the Path B 
filter
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Note: The Path B filter does not appear if the Bypass check box is 
selected.

Bypass Bypasses the transmitter filters. This check box is generally cleared, but must be 
selected for TaitNet MPT1327 trunked networks. Bypassing the filter 
minimises the time delay through the base station. This is important when the 
base station is handling FFSK data. See TN-745 for details. 

Important: Bypassing the transmitter filters also bypasses the 
limiters.This can cause over-deviation and void the equipment 
compliance. The Bypass check box should only be selected when 

approved level-control devices (for example, modems or trunking controllers) 
are connected and appropriate action is taken to ensure that compliance 
regulations are met.

High pass filter The High pass filter check box appears when the Bypass check box is selected. 
The setting of the High pass filter check box is important for modems and other 
wide band interface signals. For trunking and for quasi-synchronous 
applications it should be selected, for paging and for complex modulation 
modems it should be cleared.

Selecting the High pass filter check box inserts a high pass filter with a very low 
3 dB cut frequency into the appropriate signal path; this effectively AC couples 
the signal path. 

If the High pass filter check box is cleared, any DC content present on the input 
will also offset the Tx carrier frequency. Even with no input, a small fixed 
frequency carrier offset may be noticed.  Clearing the check box will mean that 
the frequency stability of your system is dependant on the input DC signal 
stability, not the internal or external frequency reference accuracy. 

Option Description

Flat full band Passes audio evenly across the audio spectrum. 

Flat speech 
band

Passes only speech frequencies.

Pre-emph 
speech band

Passes speech, amplifying higher frequencies. This option can be 
used for transmitting to systems with de-emphasis.

Pre-emph full 
band

Passes all audio, amplifying higher frequencies. This option can 
be used for transmitting to systems with de-emphasis.

Subaudible 
band

Passes only the subaudible band, containing any CTCSS tones or 
DCS codes. This option can be used to separate out the signalling 
and put it on the line output that is connected to a tone panel.
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Extended bypass When the Bypass check boxes are enabled on both the transmit and the receive 
paths, Extended bypass check boxes appear. Extended bypass adds an equaliser 
that amplifies higher frequencies to extend the available audio frequencies on 
the unbalanced line, providing up to 6 kHz (receive path) or 5.5 kHz (transmit 
path). Enabling one Extended bypass check box automatically enables the 
other; you cannot configure extended bypass separately for the transmit and 
receive paths. Enabling extended bypass makes  the balanced line and internal 
talk-through repeater connections unavailable; their screen display is therefore 
disabled.

The high pass filter is also available for extended bypass.

Extended bypass is necessary for applications such as 9600 baud data in the 
GMSK format using external modems. See TN-1114-AN for more details.

Line level The Line level boxes on the transmit path define the level of the line input that 
the base station expects. The line level you select affects the gain across the 
transmit path. 

When the base station receives a line input at the level you select, it transmits 
at 60% of the maximum transmit deviation. For channels using the default 
profile, the maximum transmit deviation is determined by the channel spacing 
(see “Channel Spacing” on page 135). For channels using custom profiles, it is 
defined by the parameter Max Tx deviation (see “Max Tx deviation” on 
page 109).

Line levels are expressed as dBm for the balanced line input and Vpp (volts 
peak-to-peak) for the unbalanced line input. 

Power Saving
In the Add or Edit Channel Profile dialog box, the Power Saving 
tab lets you configure power saving. A graph shows the meaning of 

Rx Sniff, Rx cycling, and Tx keyup. The three areas below the graph define 
the parameters for Normal, Sleep, and Deep Sleep modes. Sleep and Deep 
Sleep modes require a Power Saving Modes license and only occur when the 
base station is running on battery power. 

Power saving involves switching off parts of the base station circuitry. For 
details see the Installation and Operation manual. To determine the parameter 
settings needed for a given level of power consumption, refer to the 
Specifications manual.

Channel spacing 
Equivalent Tx max 
deviation (Hz)

60% of Tx max 
deviation (Hz)

12.5 kHz Narrow Band 2500 1500

20 kHz Mid Band 4000 2400

25 kHz Wide Band 5000 3000
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Normal Defines how the base station operates normally. Normal mode can involve a 
degree of power saving.

Sleep The Sleep check box enables Sleep mode. The related group box defines how 
the base station operates in Sleep mode. A base station enters Sleep mode when 
the receiver has been idle for the length of time specified in the Sleep mode’s 
Start after box.

Deep Sleep The Deep Sleep check box enables Deep Sleep mode. The related group box 
defines how the base station operates in Deep Sleep mode. A base station enters 
Deep Sleep mode when the receiver has been idle for the length of time 
specified in the Deep Sleep mode’s Start after box. 

Rx cycling Rx cycling is the length of time in milliseconds that the receiver is switched off 
for.

Power saving is effected by switching off the receiver, switching it back on for 
an ‘Rx sniff’ to check if there is a valid signal, switching it off again, and so on. 
Rx cycling is the length of time that the receiver is switched off for.

Even short Rx cycling times improve the power consumption significantly and 
are not noticeable to users. If you select ‘No Cycling’, the receiver runs 
continuously.

Tx keyup The length of time that the transmitter needs for keying up. In Sleep and Deep 
Sleep modes, this is the sum of the time selected for Normal Mode, plus 
whatever remains of current Rx sleep cycle.

Start after The length of time that the base station waits before switching into Sleep or 
Deep Sleep mode. The timer starts when audio ends. 

For example, if the setting is 10 minutes for Sleep mode and 1 hour for Deep 
Sleep mode, the base station enters Sleep mode 10 minutes after audio ended 
and Deep Sleep mode 50 minutes after that. 
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If the base station has to operate as a repeater or line-connected base station, it 
returns to Normal mode and restarts the timer when transmissions end. If the 
base station switches from battery to mains power, it also returns to Normal 
mode. Scheduled CWID transmissions and transmissions using the control 
panel microphone or Carrier button do not affect the mode or restart the timer.

 CWID System
In the Add or Edit Channel Profile dialog box, the CWID System tab lets you 
configure the way the base station broadcasts its identity using Morse code. In 
the USA, the FCC requires that base stations broadcast their identity. 

Tip: Transmit using CWID before your radio system is 
commissioned; if there are any other users of the frequencies you 
have been assigned, this gives them advance warning. 

The Automatic CWID system area lets you enable and configure the regular 
sending of identity broadcasts. The Morse area defines what the base station 
broadcasts. 

Automatic CWID 
system

Enables the automatic sending of a base station identifier. Currently the only 
option is to use Morse code. 

Transmission Interval
In the Add or Edit Channel Profile dialog box, CWID System tab, the 
Transmission interval area lets you specify when the station ID is transmitted.

Transmit every Specifies the interval in minutes between one identity broadcast and the next.

Wait until Tx tail 
before CWID 
transmission

Determines what happens if the base station is transmitting when a CWID burst 
is due. 

If the check box is selected, the base station delays the CWID burst until the 
transmit tail. Any tail timers start to count down immediately after the CWID 
burst. 

If the check box is cleared, the station ID is transmitted as soon as the 
transmission interval after the previous transmission has elapsed. This may 
interrupt speech or signalling. Any other modulating signal is temporarily 
suppressed to prevent interference with the Morse code. 

Tip: Use the Task Manager action Transmit CWID now to set up 
identity broadcasts in ways that the Transmission interval area does 
not permit.
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Morse
In the Add or Edit Channel Profile dialog box, CWID System tab, the Morse 
area lets you specify a unique ID for the base station. The speed of transmission 
and the tone used can also be configured, but you should not need to alter the 
default settings. 

Words per minute Specifies the speed of Morse code transmission. The 5-letter word PARIS is 
used to establish the number of words per minute. This word corresponds to 
50 dots. 

Tone frequency The frequency of the tone used to transmit the Morse code.

Message Enter into this box up to 30 characters to be transmitted as the station ID. You 
can enter any character or digit that the international morse code alphabet 
supports (A-Z, 0-9, and punctuation marks). These characters will be 
transmitted using the International Morse Code convention. You can also enter 
spaces. They result in a silence equivalent in duration to seven dots. 

Task Manager
In the Add or Edit Channel Profile dialog box, the Task Manager tab opens a 
Task Manager form and displays the tasks that apply to the selected channel 
profile. Use it to edit or add Task Manager inputs and actions that apply to the 
channel profile.

Tone On Idle
The base station can be configured to produce a tone on idle. When the 
receiver is muted or Task Manager disables the receiver, a tone is sent on the 
balanced and/or unbalanced line output. 

Tone on idle is enabled and configured in the Add or Edit Channel Profile 
dialog box. 

Tone on idle is overridden if the microphone has a signal path to the line output 
and a user presses PTT. 

The first row of controls enables and configures the balanced line and the 
second row of controls enables and configures the unbalanced line.

Balanced line 
output

Enables tone on idle on the balanced line output.

Unbalanced line 
output

Enables tone on idle on the unbalanced line output.
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Configured line 
level

Displays the level of the audio output configured in the channel profile for the 
line. This sets the gain that will be applied to the received audio and to the 
generated idle tone.

Relative tone level Specifies the level of the idle tone in dB relative to the configured line level.

Output tone level Displays the nominal level of the idle tone at the line interface. This is calculated 
from the idle tone’s relative tone level (that you specified above) and the 
configured line level. 

Frequency Specifies the frequency of idle tones.
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Working with Signalling Profiles

The Signalling Profiles form displays a list of the current signalling profiles.

Buttons along the bottom of the form let you add a new profile or copy, edit, 
or delete the selected profile.

Adding a Signalling Profile
The Add Signalling Profile dialog box lets you define the settings for a signalling 
profile and add it to the list of available profiles. It is almost the same as the Edit 
Signalling Profile dialog box. For detailed information, see “Editing a Signalling 
Profile” on page 127. 

Important: If the base station doesn’t have an Advanced Profiles 
license, it makes no sense to create profiles. The Service Kit lets you 
create them, but you will not be able to apply them to the channels 
in the channel table. 

Tip: Set up a test profile and assign it to a channel. Use this channel 
when testing your system before commissioning.
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To add a signalling profile

1. Select Configure > Base Station > Signalling Profiles. The Signalling 
Profiles form appears.

2. Click Add. The Add Signalling Profile window appears.

3. In the Profile name box, enter a suitable name for the profile.

4. In the Subaudible Signalling tab, set up the default encoding of 
transmitted signals.

a. In the Line-controlled base/mic box, specify the subaudible 
signalling type and the tone frequency that the base station will use when 
it transmits audio from its line in. 

b. In the Talk through repeater box, optionally specify the subtone that 
the base station will encode by default when it transmits received audio. 
If you tell the base station to decode any subtone and gate the receiver, 
this setting is disabled. 

5. In the table, specify up to 16 subtones that you want the base station to 
recognize.

a. In the Decode Signal column, select a tone or code. CTCSS tones 
appear prefaced by a ‘C’ and DCS codes are prefaced by a ‘D.’ The rest 
of the row now displays default settings.

Note: When using CTCSS tones, select frequencies that are spread 
out across the available range. Do not select tones that are close to 
one another in frequency, as the tone reject bandwidth may not 

permit separating them. For example, if 67 Hz is received, both the 67 Hz and 
the 69.4 Hz decoders may operate. The exact select and reject bandwidths vary, 
see “CTCSS characteristics” on page 93. 
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b. If you want the subtone to initiate a Task Manager action, but not to 
produce any audio, change the Action column to display ‘Task Manager 
only’.

c. In the Encode Signal column, you can tell the base station to transmit 
a different subtone from the one it received.

6. In the Tx Timers tab, configure the way the audio, signalling, and carrier 
end at the end of a transmission.

7. In the Advanced tab, configure advanced parameters for CTCSS signalling. 

8. In the Task Manager tab, define any inputs and actions to customize the way 
channels with this profile will respond in different situations.

9. Click OK to confirm your changes and close the dialog box. The profile 
you defined appears in the Signalling Profiles form.

Setting Up a Reminder Tone
If a group of radios using a community repeater are in arrears with their 
payments, you can configure the base station to send out a reminder tone. If 
necessary, you can disable audio so that they can transmit but not hear each 
other. 

1. Select Configure > Base Station > Signalling Profiles.

2. Open the editing form of the signalling profile assigned to the base station’s 
current channel.

3. In the row that specifies the decode signal that the group of radios use, click 
the Reminder Tone cell, and select Enabled from the list that appears.

When you program the base station with these changes, it adds a reminder 
tone to the transmissions from the group that it re-transmits. 

Note: To configure the reminder tone, select the Advanced tab of 
the Edit Signalling Profile dialog box.
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Editing a Signalling Profile
The Edit Signalling Profile dialog box lets you view the details of the selected 
signalling profile and modify them. Subaudible signalling is defined for the 
Default signalling profile in the channel table.

Profile name Specifies the name of the profile. This name is used in the Channel Table and 
Signalling Profile forms.

Previous Profile Displays the previous profile. This means you don’t need to return to the list of 
profiles. 

Next Profile Displays the next profile in the list.  

Important: If you have made changes to the current profile, click 
OK to confirm them before moving to another profile. 

Tabs

Subaudible Signalling
In the Add or Edit Signalling Profile dialog box, the Subaudible Signalling tab 
specifies the subtones that the receiver recognizes and that the transmitter 
applies. The base station supports CTCSS frequencies and DCS codes.

Most of the tab is taken up by a table. Each row in the table specifies a subtone 
that the base station will recognize and the action that it will take. Default 
subtones for the transmitter are specified in the Default encode signalling area. 
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Subtone table
In the Add or Edit Signalling Profile dialog box, a table defines up to 16 
subtones that the receiver will accept and specifies the base station’s response. 
The left-hand side specifies the receive response and the right-hand side the 
transmit response. 

The table lets you configure the base station as a community repeater, with each 
subtone having its own group of users. It also lets you set up the means of 
remotely initiating Task Manager actions. A radio can send carrier with a 
particular subtone and the decoding of this subtone initiates a Task Manager 
action. The left side specifies a subtone. The base station will recognize 
transmissions containing that subtone. The row defines the base station’s 
response. 

Decode Signal Specifies a subtone and instructs the base station to decode it. To begin adding 
a subtone to the list that the base station will recognize, click in the cell. A 
pop-up menu appears. Click an option. 

Note: When specifying CTCSS tones, select frequencies that are 
spread out across the available range. Do not select tones that are 
close to one another in frequency, as the tone reject bandwidth may 

not permit separating them. For example, if 67 Hz is received, both the 67 Hz 
and the 69.4 Hz decoders may operate. The exact select and reject bandwidths 
vary, see “CTCSS characteristics” on page 93. When you select a subtone, it 
becomes unavailable. This is to prevent you selecting the same subtone twice.

Note: When specifying DCS codes, you need to be aware that there 
is an inverse code that is exactly the same. For example, if you 
specify 047, the receiver will unmute to 047 and to 023i. Both these  

codes then become unavailable, to prevent you selecting the same code or its 
equivalent inverse again. 
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Action Specifies the action when the base station detects the specified subtone. 

Encode Signal Specifies the subtone that the base station encodes when it repeats signals with 
the subtone specified in the Decode signal column.

Reminder Tone When the Reminder Tone column is set to ‘Enabled’, the base station includes 
a reminder tone in its transmissions. You configure the reminder tone in the 
Advanced tab. 

Audio Path By default, the Audio Path column is set to ‘Enabled.’ When it is set to 
‘Disabled,’ the audio path is disabled, and the base station transmits carrier (and 
a reminder tone if it is configured to do so), but no audio. 

Default encode signalling
In the Add or Edit Signalling Profile dialog box, Subaudible Signalling tab, the 
Default encode signalling area lets you specify the subtone to be used when 
transmitting audio from line in and when repeating received signals without 
subaudible signalling.

Line controlled 
base/mic

Specifies the subtone to be used when the base station transmits audio from the 
balanced line input, unbalanced line input, or microphone connected to the 
control panel.

Talk through 
repeater

Specifies the subtone to be used when the base station repeats any valid received 
signal. This box is disabled and has no effect if the subtone table below specifies 
any subtone and gives it the action ‘Gate receiver’. 

Option Action

Gate receiver Opens the receiver gate and passes the received audio on. Also sets the system flag 
‘Tone nn detected’ where ‘nn’ is the number of the subtone. This flag is a Task 
Manager input; any tasks with this input will be executed when the base station 
detects the subtone. 

Task Manager only Sets the system flag ‘Tone nn detected’ where ‘nn’ is the number of the subtone. This 
flag is a Task Manager input; any tasks with this input will be executed when the base 
station detects the subtone. 
In systems that use subaudible signalling, the receiver does not pass the received 
audio on (the receiver gate only opens when the receiver decodes a tone configured 
to gate the receiver).
In systems that do not use subaudible signalling, the receiver still passes the received 
audio on (the receiver gate opens irrespective of the subaudible signalling) .

Option Action

Same as received Encodes the transmission with the same subtone that was 
in the received signal.

None Gives the transmission no subaudible signalling.

[any CTCSS tone or 
DCS code]

Encodes the transmission with the subtone you specify
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Tx Timers
In the Add or Edit Signalling Profile dialog box, the Tx Timers tab lets you 
configure tail timers that the transmitter users.

You can also set up a transmit lockout and enable anti-kerchunking. 

Three different tail timers give you power and flexibility in tail timing. The 
total tail time is the sum of all three timers. The graphic at the top of the tab 
shows the difference between them. Tail timers are used to:

eliminate squelch tail (the ‘tish’ sound caused when the CTCSS detector 
doesn’t immediately re-mute the user’s radio when carrier ceases) 

prevent users on different subtones from taking control of the repeater 
during a temporary lull in the conversation

Transmit lockout
To prevent radio users from monopolising the base station, you can set a time 
limit and have the transmitter lock users out for a defined period after this time 
limit is exceeded. Transmit lockout terminates the current transmission and 
gives other users the opportunity to use the channel.

In the Add or Edit Signalling Profile dialog box, Tx Timers tab, the Transmit 
lockout check box enables the temporary disabling of the transmitter after a 
transmission that exceeded the time limit.

The Transmit timer box specifies the time limit for transmissions. If a 
transmission exceeds the time limit, the transmitter is locked out and the 
conversation cannot continue. The transmitter is unable to transmit for the 
length of time specified in the Lockout duration box. 

Anti-kerchunking
Anti-kerchunking discourages radio users from repeatedly pressing PTT briefly 
to ascertain whether they have service or to reserve the base station for 
themselves. 
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In the Add or Edit Signalling Profile dialog box, Tx Timers tab, the 
Anti-Kerchunking check box enables this feature. If a transmission is short, 
either the transmitter is not keyed up or there will be no tail timers, depending 
on the option selected.

The Transmissions less than box specifies which transmissions are short; 
those with a duration less than the value in the box. Anti-kerchunking is only  
applied to short transmissions.

If the Will not key transmitter option is selected, short transmissions do not 
key up the transmitter at all. In effect, this option lengthens the key-up time for 
all radio users.

If the Will not enable tail timers option is selected, short transmissions are 
transmitted but not given a tail timer. The base station becomes available to 
other users quickly. The radio user hears nothing on releasing PTT and 
therefore does not know whether the base station has responded. 

Hang time
The hang time is the length of time at the end of each transmission when the 
base station continues to transmit subaudible signalling after Tx keying has 
ceased.

In the Add or Edit Signalling Profile dialog box, Tx Timers tab, the Hang time 
check box enables this timer and the Duration box specifies the length of the 
hang time. 

Reverse tone burst
The base station can send a reverse tone burst at the end of each transmission. 
This applies only to transmissions with a CTCSS tone. The reverse tone burst 
consists of the same tone, but is out of phase with it. In suitable radios, this 
quickly mutes the receiver. 

Note:  Transmissions with a DCS subtone have an equivalent: the 
DCS end tone. This consists of a 134 Hz tone that lasts 180 ms and 
is not configurable.

In the Add or Edit Signalling Profile dialog box, Tx Timers tab, the Reverse 
tone burst check box enables reverse tone bursts. 

The Duration box specifies the length of the tone burst. You can specify this 
in milliseconds or in cycles. If the burst has too many cycles, it comes back into 
phase with the original subtone and the radio may detect it again, re-opening 
the receiver gate. Specifying the duration in cycles for different CTCSS 
frequencies can help prevent this. 

The Phase angle box specifies the amount that the burst is out of phase with 
the original CTCSS subtone. If you select +120 or -120 instead of 180, more 
cycles are required before the burst comes back in phase with the original 
subtone. 
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Soft-off time
The base station can also send only carrier (carrier without modulation of any 
kind) at the very end of each transmission. 

In the Edit Signalling Profile dialog box, Tx Timers tab, the Soft-off time 
check box enables the feature and the Duration box specifies the length of time 
that only carrier is transmitted. 

Advanced
In the Add or Edit Signalling Profile dialog box, the Advanced tab lets you  
configure reminder tones if the base station is being used as a community 
repeater. Reminder tones are tones that can be added to transmissions for a 
particular talk group.

One pip every Specifies the interval between pips.

Pip duration Specifies the length of time that the pip tone sounds for.

Tone level Specifies the amplitude of the pip tone relative to the nominal audio level.

Tone frequency Specifies the frequency of the tone. 

Task Manager
In the Add or Edit Signalling Profile dialog box, the Task Manager tab opens a 
Task Manager form and displays the tasks that apply to the signalling profile 
named above the tab. 

Use it to configure Task Manager inputs and actions that apply to the channel 
profile.
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Working With the Channel Table

The Channel Table form (Configure > Base Station > Channel Table) lets you 
work with channels. You can view the configured channels, edit them, and add 
more channels using a variety of different methods. 

Channel Table Details
The Channel Table form (Configure > Base Station > Channel Table) displays 
the channels defined in the channel table of the configuration file that you 
opened or the base station database that you read.

The form contains a table that displays a row for each channel. The row 
indicates which profiles have been assigned to the channel and displays the main 
configuration items. 

If default profiles are assigned, all columns are editable. If a custom profile is 
assigned, the columns to its right are defined by the profile.

Not all columns are visible; scroll the display to see the rest. 

An arrow at the left of one row indicates that it is selected; if, for example, you 
click Insert Copy, that row will be copied. Use the mouse or the arrow keys 
to change your selection. When you make any changes to a row, the arrow 
changes to a pencil.

Important: The arrow does not define the current or default 
channel. To find out the channel the base station is currently 
operating on, select Monitor > Monitoring > Base Station. To 

specify the default channel, select Configure > Base Station > General. 

A set of buttons along the bottom lets you work with the channels in the table.

Columns
In the channel table (Configure > Base Station > Channel Table), the first two 
columns indicate the number and name of each channel. The other columns 
define the main characteristics of each channel. Not all columns are visible; 
scroll the display to view them. You can also adjust their width. Some columns 
you can edit directly; in others a drop-down list appears when you click in the 
cell. ‘Multiple’ means that the profile definition defines more than one value for 
the column’s parameter.
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Num The number of the channel. This is the number that external channel selection 
and Task Manager actions use when changing the channel that the base station 
operates on. If you move a row up or down, its channel number changes. If you 
edit the channel number, its position in the table changes.

Channel Name The name of the channel. When you create a channel, it is given a default name 
of the form ‘Channel nnn’ where nnn is the channel number. You can edit this 
name to reflect the channel’s purpose or users. 

Receive Frequency The radio frequency that the channel receives on.

Transmit 
Frequency

The radio frequency that the channel transmits on. 

Signalling Profile The signalling profile assigned to the channel. This profile defines a group of 
operating parameters. If the profile is ‘Default’, the next two columns are 
editable.

Receive Signalling Indicates the subtone that the channel recognizes as a valid signal on its receive 
frequency. If the signalling profile is ‘Default’, you can edit this column, 
otherwise it is defined by the profile. ‘Multiple’ means that the profile assigned 
to the channel defines more than one subtone.

Transmit 
Signalling

Indicates the subtone that the channel includes in its transmissions. If the 
signalling profile is ‘Default’, you can edit this column, otherwise it is defined 
by the profile. ‘Multiple’ means that the profile assigned to the channel defines 
different subtones for different receive signalling.

Channel Profile The channel profile assigned to the channel. This defines a further group of 
parameters. If the profile is ‘Default’, the next two columns are editable.

Filter Specifies the audio response characteristics of the channel. ‘Multiple’ means that 
these are different for different audio paths or that the receive characteristics are 
different from the transmit characteristics (custom channel profiles only). ‘Pre/
De-Emph Speech Band’ and ‘Pre/De-Emph Full Band’ mean that 
pre-emphasis is applied to any enabled transmit path and that the equivalent 
de-emphasis is applied to any enabled receive path.

Power The RF power output that the channel is configured to provide when it is 
provided with mains power. (The channel profile may specify a different power 
output for battery power). 
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Channel Spacing The nominal channel spacing of the channel (the actual channel spacing is 
determined by the interval between this channel and the adjacent channels in 
the channel table). Channel spacings correspond to the following IF bandwidths 
and transmit deviations. 

If the channel is assigned a custom profile, the receiver can have one channel 
spacing while the transmitter has another. In this case, the channel table displays 
the receiver channel spacing. 

Buttons
A row of buttons along the bottom of the channel table (Configure > Base 
Station > Channel Table) lets you work with channels. You can add or remove 
channels, create a whole new block of channels, or rearrange them into a better 
order. 

Insert New Inserts an additional channel at the end of the channel table. The channel is 
identical to the last channel in the table except for the channel number.

Insert Copy Inserts a copy of the selected channel at the end of the table. 

Block Copy Lets you add a number of channels to the channel table, each with the 
properties of the selected channel, except that the channels all have a channel 
spacing that you specify. See “Block Copying Channels” on page 137 for more 
information.

Move Up Shifts the current row above the previous row, effectively renumbering it with 
the previous channel number. You can use Move Up and Move Down to give 
the list of channels a more logical or tidy order, or to group channels in 
particular ways.

Important: Move Up and Move Down assign a different number to 
the channel. If you use them, you may need to alter the default 
channel selection, any external channel selection, and any Task 

Manager actions that change channel.

Move Down Shifts the current row below the previous row, effectively renumbering it with 
the next channel number.

Delete Removes the current row from the channel table.

Import Lets you add a set of channels from a file exported from another base station. 
See “Importing Channels” on page 138.

Export Lets you save a set of this base station’s channels to a file so that you can import 
them into other base stations. See “Exporting Channels” on page 138.

Channel Spacing 
(kHz)

Name
Rx IF Bandwidth 

(kHz)
Tx Max Deviation 

(Hz)

12.5 Narrow Band 7.5 2500

20 Mid Band 12 4000

25 Wide Band 15 5000
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Editing a Channel (Default Profiles)
When a channel has the default profiles assigned to it, you can edit most of the 
cells in its table row.

To edit a channel

1. In the channel table (Configure > Base Station > Channel Table), click in 
the row that defines the channel. An arrow appears at the left of the row 
indicating that it is selected.

2. If desired, click in the Channel Name cell and edit the channel’s name.

3. If necessary, alter the receive frequency and the transmit frequency.

Note: The Service Kit does not check whether the base station can 
operate on these frequencies.

For simplex applications, you can make the receive and transmit frequencies 
the same. The base station automatically increases the transmit frequency by 
25 kHz when it is not transmitting, to prevent desensitisation of the 
receiver.

Note: You cannot assign a frequency in the range 406.0-406.100 
MHz. These frequencies are reserved internationally for distress 
beacons. 

4. If the system requires subaudible signalling, configure it as follows:

a. In the Receive Signalling column, select the subtone that the base 
station will receive. 

b. In the Transmit Signalling column, select the subtone that the base 
station will transmit.

5. In the Filter column, select the appropriate audio filter. See “Filter” on 
page 115 for more information about the available options. 

6. In the Output Power column, specify the transmitter’s RF output power.

7. In the Channel Spacing column, specify a nominal channel spacing for the 
transmit and receive channels. For more information, see “Channel 
Spacing” on page 135. 

8. Click OK to confirm your changes and close the form. 

Note: If you are editing a large number of channels, periodically 
select File > Save to save the changes to a file on disk. 

Editing a Channel (Custom Profiles)
If you assign custom profiles to a channel, most of the columns become 
read-only. The channel is largely defined by the settings in the assigned profiles. 

To edit a channel

1. In the channel table (Configure > Base Station > Channel Table), click in 
the row that defines the channel. The arrow appears at the left of the row 
indicating that it is selected.

2. If desired, click in the Channel Name cell and edit the channel’s name.

3. If necessary, alter the receive frequency and the transmit frequency.
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Important: Do not assign a prohibited frequency to the transmitter. 
For example, 406.0-406.100 MHz is reserved internationally for 
distress beacons.

For simplex applications, you can make the receive and transmit frequencies 
the same. The base station automatically shifts the transmit frequency by 
25 kHz when it is not transmitting, to prevent desensitisation of the 
receiver.

Note: The Service Kit does not check whether the base station can 
operate on these frequencies.

4. Click in the Signalling Profile cell. An arrow appears at the right of the 
cell. Click it and select a profile from the drop-down list. This list contains 
all the profiles defined in Configure > Base Station > Signalling Profiles.

5. If you selected the Default profile, you can edit the Receive Signalling and 
the Transmit Signalling cells. If you selected a custom profile, these cells 
are read-only; they display what has been defined in the profile. To change 
them, you must select a different profile or alter the current profile’s settings.

6. In a similar way, select a channel profile.

7. Click OK to confirm your changes and close the form. 

Note: If you are editing a large number of channels, periodically 
click OK, and then Save. 

Adding and Copying Channels
The Channel Table form (Configure > Base Station > Channel Table) has a 
row of buttons along the bottom that give you a variety of methods for adding 
to the number of channels.

Insert New The Insert New button inserts a row below the current row. The row is 
contains default values and is assigned the Default profiles.

Insert Copy The Insert Copy button copies the current row and inserts it below that row. 
The channel number is incremented.

Block Copying Channels
In the channel table, Block Copy lets you create a block of channels. Each 
channel in the block has its own frequency pair, but all other configurations are 
the same. You can subsequently edit any channel as desired.

1. Select Configure > Base Station > Channel Table.

2. Click in the row of the channel that you want to block copy.

3. Click Block Copy. The Block Copy dialog box appears.
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4. In the Channel block start box, enter the channel number of the first 
channel you want to create.

5. In the Channel block end box, enter the channel number of the last 
channel in the block. 

6. In the Receive frequency increment box, enter a number of kHz. This 
determines how much the receive frequency of a channel differs from the 
previous channel. For example, if you enter 15 kHz and the previous 
channel’s receive frequency is 10 MHz, the next channel’s receive 
frequency will be 10.015 MHz.

Important: Do not assign a prohibited frequency to the transmitter. 
For example, 406.0-406.100 MHz is reserved internationally for 
distress beacons.

Note: The Service Kit does not check whether the base station can 
operate on these frequencies.

7. In the Transmit frequency increment box, specify the number of kHz 
that the transmit frequency will increment for each channel you add. 

8. Click OK to create the block of channels and close the dialog box. The 
channels appear in the Channel Table form.

Importing Channels
You can import a file containing channels that have been exported from 
another base station. Importing overwrites any channels with the same number 
as the imported channel. Imported channels always have the default signalling 
and channel profiles.

To import channels

1. In the Channel Table form (Configure > Base Station > Channel Table), 
click Import.

2. Navigate to the folder containing the TB8100 channel file (*.t8h), select it, 
and click Open. 

Exporting Channels
You can export channel configurations. This provides an exported channel file 
that you can import into other base station channel tables. It also generates a 
text file for your records. 

To export channels

1. In the Channel Table form (Configure > Base Station > Channel Table), 
select the channels you want to export by holding down the Control key 
and clicking the row selector at the left of the table.

2. Click Export.

3. Specify the path and file name for the file you want to create.

4. Click Save.

The Service Kit saves the file, giving it the extension .t8h. It also saves an 
equivalent text file with the same name and with the extension .txt. The text 
file gives you a readable view of the exported channel. Editing this file has 
no effect on the exported channels.
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Selecting a Channel

After you have set up a number of channels, you need to specify the one that 
the base station will actually operate on. 

1. Select Configure > Base Station > General.

2. In the Default channel box, choose a channel from the drop-down list. 

This is the channel that the base station will operate on, unless it uses exter-
nal channel selection or a  Task Manager action changes channel or makes 
a different channel the default. 
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Printing Channel Data

You can print channel and other configuration data that you have opened from 
a configuration file or read from a base station.

Note: Printing to an old-style text printer is not supported, because 
the layout  requires the use of large and small fonts.

To print channel data

1. Select File > Print. The Print Selection dialog box appears. 

2. Using the arrow buttons, select the configuration items you want to print. 
An item is selected for printing when it is in the right-hand box.

The >> and << buttons move all configuration items.

The > and < buttons move the highlighted item. Click an item to 
highlight it.

3. Click Printer Settings and check the printer setup.

4. Click Print to send the configuration information to the printer.
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Part G Alarms

The Service Kit can monitor the current status of a base station’s 
alarms. It can also display the alarm log (a list of recent alarms). 
Many alarms have thresholds that you can alter to suit the 
application. Unwanted alarms can be disabled.

The base station can notify you in various ways when alarms 
occur. Use the Service Kit to enable and configure these 
notification methods.   

Topics

Monitoring Alarms

Viewing Recent Alarms

Disabling Unwanted Alarms

Altering Alarm Thresholds

Notifying Alarms

Configuring Alarm Center Communications

Configuring Email Messaging
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Monitoring Alarms

The Current Status form (Monitor > Alarms > Current Status) shows the 
current status of alarms in the base station. The Service Kit must be connected 
and logged on to the base station.

LED-like icons indicate the status: 

Red (flashing) means that the alarm is active.

Green means that the monitored condition is OK and that there is no alarm.

Gray means that the alarm has been disabled or that the monitored condition 
is not available; for example, Final 2 alarms are gray if there is no Final 2 
stage.

Alarms are triggered when a monitored condition crosses a defined threshold. 
Some thresholds are fixed and built into the module firmware. Others are 
configurable in Configure > Alarms > Thresholds. Some parameters such as 
high voltage and high reverse power have two thresholds. When the 
configurable threshold is crossed, the base station generates an alarm. When the 
built-in threshold is crossed, the base station responds by protecting itself against 
damage. 

Tip: Use Task Manager to configure an automatic response to 
alarms. In general, each alarm has an equivalent Task Manager 
input. When the alarm occurs, Task Manager executes any tasks 

with that alarm as an input.
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Reciter
The Reciter area shows the Alarm status of the reciter. 

Power up failure The reciter has failed an initialisation procedure. 

1. The reciter may have failed to load the code into the DSP. Wait five 
minutes; the alarm may clear.

2. The reciter may have failed to configure the Ethernet interface on the 
system interface board. Because Ethernet is not available, you can only see 
this alarm if you are connected via RS-232, most likely after seeing the 
control panel alarm LED go on.

Other initialisation failures cannot be seen on this form; they cause the base 
station to go into Download mode, in which the base station does not report 
alarms to the Service Kit.

Channel invalid The base station has received an instruction to select an invalid channel number 
and has stopped transmitting and receiving. 

The channel could be invalid for one of the following reasons:

1. The channel number specifies a UHF frequency, but the base station is 
VHF, or vice versa. 

2. The base station cannot lock onto the specified frequency. To verify if this 
is the cause, do a diagnostic test to see if the base station can lock onto the 
frequency. See “Determining Synthesiser Lock Ranges” on page 168. 

3. There is a problem with the external selection of the channel.

a. Select Monitor > Monitoring > Base Station to determine whether the 
channel number is determined by hardware.

b. Select Diagnose > Reciter > Digital I/O to see what the base station 
thinks the hardware channel is set to. 

c. Select Configure > Base Station > System Interface to check that the 
base station is configured to correctly interpret the channel selection. Are 
the settings for Binary or BCD format and for Invert correct?

d. Select Configure > Base Station > Channel Table to see whether a con-
figuration for the externally selected channel exists.

4. A  Task Manager action asked the base station to go to a channel number 
that does not exist in the channel table. 

a. Check to see if a recent Task Manager action has changed the channel 
number (Monitor > Task Manager > Recent Actions). 
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b. Look in the channel profile folders in the Task Manager task list to see if 
there are any ‘go to channel’ actions. Note the number of the channel 
that Task Manager instructed the base station to go to.

c. Select Configure > Base Station > Channel Table to see whether a con-
figuration for that channel exists.

Synthesiser out of 
lock

The reciter has three different synthesiser alarms.

Synthesiser out of 
lock: Exciter

The exciter synthesiser is unable to lock on to the frequency it is configured to 
operate at. In response, the base station disabled the transmitter.

1. Check that this frequency is within the exciter’s RF frequency range. 

2. Do a diagnostic test to determine the reciter’s  switching range, and then 
check that the frequency is within the exciter’s switching range. 

3. If the frequency is outside the switching range, use the Calibration Kit to 
alter the switching range. Otherwise send the reciter for repair.

Synthesiser out of 
lock: Digital

One or more of the DSP and sampling clocks is out of lock. In response, the 
base station disabled the receiver and the transmitter.

1. The base station is configured for an external reference of a particular 
frequency, but the actual frequency of the external reference is different. 

2. The master synthesiser is unable to lock onto the frequency. The base station 
will run, but the accuracy of its receive and send frequencies cannot be 
guaranteed. Send the reciter for repair.

Synthesiser out of 
lock: Receiver

The receiver synthesiser is unable to lock onto the frequency it is configured to 
operate at. In response, the base station disabled the receiver.

1. Check that this frequency is within the receiver’s RF frequency range. 

2. Do a diagnostic test to determine the lock range, and then check that the 
frequency is within that range. 

3. If the frequency is outside the lock range, use the Calibration Kit to alter the 
switching range. Otherwise send the reciter for repair.

Power Amplifier
The Power Amplifier area shows the alarm status of the PA associated with the 
reciter you are logged on to. When a fault is no longer active, any actions (for 
example, inhibiting transmission) are reversed.
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No PA detected The reciter cannot obtain a response from a PA over the using the  control bus. 
The PA may still be operating but the system has lost the ability to monitor PA 
alarms, carry out diagnostics, change configuration, or detect PA fan failure.   

1. No PA is installed.

2. Your system uses a third party PA which does not use the control bus and 
cannot respond to the reciter.

3. The control cable or exciter cable is not connected.

4. The PA is faulty and unable to communicate with the exciter. 

Fan failed The PA told the reciter that its fan is on, but the reciter cannot detect fan 
motion. The base station takes no action when this alarm occurs, but it will act 
if the PA temperature becomes too high.

The fan has failed. Replace it.

Shutdown The PA has detected a fault condition and has disabled the transmitter to 
prevent damage. Check the other alarms to see what fault condition or 
conditions have caused this. 

VSWR high The VSWR is above the configured threshold. A normal VSWR is ≤ 2:1. 
A high VSWR automatically means reduced output power. If the VSWR 
increases to 10:1 or more, the PA folds back its power output to a minimal level. 
If the VSWR returns to 5:1 or less, the PA recovers.

Check for a load mismatch on the PA’s RF output. 

Power foldback The PA has detected a fault condition and has reduced its power output to a 
minimal level to prevent damage. 

Check the other alarms to see what fault condition or conditions have caused 
this. If the fault condition clears, the PA automatically returns to its previous 
power output level and the alarm changes to green.

Forward power 
low

The PA forward power output is below the configured minimum limit. Check 
the PA key line (there is no specific alarm for the failure of this line). If the 
VSWR is also raised, check for a load mismatch. Otherwise, there may be a 
fault in the output driver(s). 

Reverse power 
high

The PA’s reverse power is above the configured maximum. Check for a load 
mismatch. With a resolution of only 1 W, this alarm is not sensitive if the power 
output is lower than 20 W. Check the VSWR fault alarm instead.

Calibration invalid This alarm can only be triggered on startup, when the PA carries out self-tests. 
It indicates that settings stored in firmware have values outside acceptable limits. 
In response, the base station disables the transmitter. Re-calibrate the PA using 
the Calibration Kit or send it to a service center for repair. 

H/w configuration 
invalid

The PA has an invalid hardware configuration. Either the driver is not present 
or the configuration says that there is a Final 2 output stage but no Final 1, 
which is impossible.
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Current The Current group of alarms detects excessive or inappropriate current draw. 
If an alarm shows red, the PA needs servicing.

Supply voltage The PA can detect whether its power supply voltage is too high or too low.

Supply voltage 
high

The PA supply voltage is 29 V or more.

1. The third party power supply is incorrectly configured. 

2. A voltage regulator has failed. 

Note: The base station is not type-approved for operation when the 
supply voltage is outside the specified range. 

Supply voltage 
low

The PA supply voltage is 26 V or less, probably because the battery is running 
low. The fault condition disappears when the voltage exceeds 26.1 V.

Temperature high This group of alarms shows whether the temperature in the driver, Final 1, or 
Final 2 output stage has exceeded the configured threshold. If a temperature 
exceeds a built-in limit, the PA folds back its power output until the 
temperature is within the normal range.

To see the actual temperatures, select Diagnose > Power Amplifier > Control 
Tests. 

System
The System area displays alarms that are triggered by system conditions. These 
alarms do not indicate base station faults. You can set a threshold for these 
alarms if this is appropriate for your system. For example, if the base station 
should always receive a signal on the balanced input, you can set a threshold so 
that the alarm is triggered if the signal fails. Otherwise leave the threshold at 
zero, so that the alarm is never triggered.

Alarm Description

Driver high The driver is drawing excessive current. A fixed limit has been 
exceeded.

Final 1 The Final 1 output stage is drawing excessive current. A fixed 
limit has been exceeded.

Final 2 The Final 2 is drawing excessive current. A fixed limit has been 
exceeded.

Imbalance One of the final stages is drawing significantly more current 
than the other.
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Balanced input 
low

The audio level on the base station’s balanced input lines has fallen below the 
configured minimum. This alarm can be used to indicate when audio is lost.

Unbalanced input 
low

The audio level on the base station’s unbalanced input lines has fallen below the 
configured minimum. This alarm can be used to indicate when audio is lost.

External 
Reference

The base station can detect whether an external reference is present and 
whether it is useable.

External reference 
absent

The base station cannot detect an external reference frequency source. It is now 
using its own source.

1. There is no external reference source. Most applications do not need one.

2. The source has become unplugged.

3. The source is not working.

An external reference is critical for Quasi-Sync applications.

External reference 
invalid

An external reference frequency is connected to the base station, but the base 
station cannot lock on to its channel frequency using that reference. It is now 
using its own source.

1. The base station is configured (Configure > Base Station > General) to 
expect a 10 MHz frequency, but the source is 12.8 MHz (or vice versa). 

2. The reference source is faulty.

RSSI The base station measures the strength of the incoming RF signal and can 
determine whether it is stronger or weaker than a pre-defined level.

RSSI high The signal that the base station is receiving is stronger than the configured 
maximum.

RSSI low The signal that the base station is receiving is weaker than the configured 
minimum.

Air intake 
temperature

The base station is normally fitted with a sensor that measures the air 
temperature at the PA fan intake and determines whether it is above or below 
the configured limits.

Air intake 
temperature high

The temperature has exceeded the configured maximum. The PA can sustain 
full-powered continuous operation at an air intake temperature of up to 60° C. 
Fan operation and PA power foldback are unaffected by this alarm; it is the 
heatsink temperature, not the air intake temperature, that turns a base station 
fan on or folds back PA power.

Air intake 
temperature low

The temperature is below the configured minimum. The base station is not 
designed for operation below the default minimum.
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Power Management Unit
The Power Management Unit area shows the alarm status of the PMU that 
supplies the base station with power.

No PMU detected The reciter is unable to detect the PMU on the control bus. There may be a 
fault or the PMU may still be operating satisfactorily. However, the system has 
lost the ability to monitor PMU alarms, carry out diagnostics, change 
configuration, or detect PMU fan failure. Power saving is disabled.  

Fan failed The PMU told the reciter that its fan is on, but the reciter cannot detect fan 
motion. The base station takes no action when this alarm occurs, but it will act 
if the PMU temperature becomes too high.

The fan has failed. Replace it.

Shutdown 
imminent

This alarm only appears if the PMU has a DC-DC converter and a Standby 
converter. A battery is currently being used to power the base station and its 
voltage has fallen to the absolute minimum. The PMU will stop operating 30 
seconds after activating this alarm. 

The main value of this alarm is as an input for Task Manager actions. You can, 
for example, have the base station send the alarm log just before shutting down. 

Mains supply 
failed

The AC mains power supply to the PMU is absent or its voltage is outside 
acceptable limits. The PMU is using DC power from its battery source. 

Power up fault The PMU has detected an internal error and will reset itself. If the reset is 
successful, the alarm will clear.

Temperature high One of the PMU temperature sensors has detected a temperature that is above 
the fixed limit. 

Battery The PMU measures the voltage of its battery input.

Battery voltage 
high

The PMU’s battery voltage is higher than the configured maximum. The base 
station takes no action until the voltage reaches the fixed maximum, when it 
shuts down. 

Battery voltage 
low

The battery voltage is below the configured minimum. This minimum may 
have been set to alert you to the risk of damage to the battery from 
overdischarge. If the voltage falls below a fixed minimum, the PMU 
automatically shuts down to protect the battery and base station equipment. 

Battery protection 
mode

Battery protection mode is on. This happens when a base station is operating 
on AC mains power, but the battery voltage is still below the configured 
minimum. Battery protection mode requires a PMU with a standby converter. 
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If AC mains power fails when the PMU is in battery protection mode, the base 
station shuts down instead of using battery power. This protects the battery.

1. The system has been operating on battery power; the battery has become 
flat and AC mains is restored. No action required.

2. The battery is not being charged. Check the PMU’s auxiliary output line, if 
it is being used for charging.

3. The battery is flat. Replace it.

4. The minimum battery voltage is set too high. 

Output The PMU measures the voltage and the amperage of its DC output to the PA 
and to the reciter. 

Output voltage 
high

The PMU’s DC output (nominally 28 V) is higher than the fixed maximum of 
32 V. 

Output voltage 
low

The PMU’s DC output (nominally 28 V) is lower than the fixed minimum of 
24 V.

Output current 
high

The PMU is providing more than 15 A of current and is automatically limiting 
its output, lowering the output voltage. There is a short circuit or the PMU is 
faulty.
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Viewing Recent Alarms

The Reported Alarms form (Monitor > Alarms > Reported Alarms) displays 
recent alarms from the base station you are logged on to. The base station stores 
the last 50 alarm messages. When you log on, these messages become available 
and are displayed in this form. 

Note: The Alarm Center can also display recent alarms that have 
been sent to it by various base stations. 

The form displays information about the alarms, one row for each alarm. The 
display is updated with any new alarms each time the Service Kit polls the base 
station. The polling interval is set when you configure the connection. 

Each row contains the following information.

Date & Time The date and time that the alarm was reported to the base station (the date is 
provided by the base station’s clock).

Module The name of the base station module reporting the alarm.

Serial Number The serial number of the module reporting the alarm.

Reported Alarm The text of the alarm.

Save to File Click Save to File to save the displayed information. This enables you to store 
a record of alarms, for example, to help with troubleshooting an intermittent 
problem. The Alarm log can only store the most recent 50 alarms and these are 
lost if the base station is reset. 

Alarms are stored in CSV format. The default extension is *.csv.
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Disabling Unwanted Alarms

You can disable any of the base station’s alarms. Some alarms may not be 
appropriate for your system. For example, the Balanced input low alarm is only 
helpful if the absence of a line input indicates a system failure.

If you disable an alarm, it does not function in the Service Kit, appear in the 
alarm log, or turn on the control panel LED. It is not sent to the Alarm Center 
or to a syslog collector. However, Task Manager tasks with that alarm as an 
input are still processed.

To disable unwanted alarms

1. Select Configure > Alarms > Alarm Control. 

2. Clear the check boxes of the alarms to be disabled.

3. Click OK.
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Altering Alarm Thresholds

The Thresholds form (Configure > Alarms > Thresholds) lets you alter the 
thresholds for base station alarms.

Some alarm thresholds are fixed; they are built in to the base station and cannot 
be changed. Others have default values. You may want to adjust them to better 
reflect your system’s operating conditions or monitoring procedures. This can 
be important if an alarm is used as an input in Task Manager tasks.

The form displays a list of upper and lower limits. Alongside each threshold is 
the applicable unit. To the right, the read-only Current measurement column 
displays the current value of the parameter to help you select a suitable 
threshold. When a parameter value goes outside its limit, the base station 
triggers the corresponding alarm.

To adjust a threshold, edit its value or click one of the adjacent arrows, and then 
click OK to confirm your changes and close the form.

The alarms that these thresholds apply to are described in “Monitoring Alarms” 
on page 143. The equivalent Task Manager inputs are described in “Alarm 
Inputs” on page 196. 

Minimum PA 
power output

Defines the lower limit for the PA forward power output. When the output 
falls below this limit, the base station triggers the alarm Forward power low and 
the Task Manager input Forward power low becomes true.

Maximum PA 
reverse power 
output

Defines the upper limit for the PA’s reverse power. When the reverse power 
exceeds this limit, the base station triggers the alarm Reverse power high and 
the Task Manager input Reverse power high becomes true. 

When using a 5 W PA, or any PA set to 20 W or less, disable this alarm and use 
the VSWR alarm instead. The resolution of the reverse power measurement is 
only 1 W, so the reverse power alarm would only trigger if there is a serious 
antenna fault. VSWR is calculated with better precision and reliably detects 
load failure.
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Maximum PA 
VSWR

Defines the upper limit for the VSWR. When the VSWR exceeds this limit, 
the base station triggers the alarm VSWR high and the Task Manager input 
VSWR fault becomes true. The hysteresis is fixed at 0.2. For example, if the 
threshold is 1.5:1, when the VSWR falls to 1.3:1, the alarm is cleared and the 
Task Manager input becomes false. 

Maximum PA final 
temperature

Defines the upper limit for the operating temperature at the Final 1 and Final 2 
stages of the PA. When the temperature exceeds this limit, the base station 
triggers one of the Temperature high alarms and the Task Manager input PA 
temperature high becomes true.

Maximum PA 
driver 
temperature

Defines the upper limit for the operating temperature at the driver stage of the 
PA. When the temperature exceeds this limit, the base station triggers one of 
the Temperature high alarms and the Task Manager input PA temperature high 
becomes true.

PA air intake 
temperature

The Maximum box defines the upper limit for the air intake temperature that 
is measured at the PA. When the temperature exceeds this limit, the base station 
triggers the Air intake temperature high alarm and the Task Manager input PA 
air intake temperature high becomes true.

The Minimum box defines the lower limit for the air intake temperature that 
is measured at the PA. When the temperature falls below this limit, the base 
station triggers the Air intake temperature low alarm and the Task Manager 
input PA air intake temperature low becomes true.

PMU battery 
voltage

The Max box defines the upper limit for the battery voltage that is supplied to 
the DC-DC converter. Different limits apply, depending on which nominal 
voltage the DC-DC converter is designed for. When the voltage exceeds the 
relevant limit, the base station triggers the Battery voltage high alarm and the 
Task Manager input Battery voltage high becomes true.

The Min box defines the lower limit for the battery voltage that is supplied to 
the DC-DC converter. Different limits apply, depending on which nominal 
voltage the DC-DC converter is designed for. When the voltage falls below the 
relevant limit, the base station triggers the Battery voltage low alarm and the 
Task Manager input Battery voltage low becomes true.

Both the upper and lower limits have a hysteresis of 0.1 V. 

Balanced line 
input level

The Minimum box defines the lower limit for the level of the audio signal on 
the balanced line in. When the audio level falls below this limit, the base station 
triggers the Balanced input low alarm and the Task Manager input Balanced 
input low becomes true.

Unbalanced line 
input level

The Minimum box defines the lower limit for the level of the audio signal on 
the unbalanced line in. When the audio level falls below this limit, the base 
station triggers the Unbalanced input low alarm and the Task Manager input 
Unbalanced input low becomes true.

RSSI level The Maximum box defines the upper limit for the received signal strength as 
measured in the receiver. When the RSSI exceeds this limit, the base station triggers 
the RSSI high alarm and the Task Manager input RSSI high becomes true.

The Minimum box defines the lower limit for the received signal strength as 
measured in the receiver. When the RSSI falls below this limit, the base station 
triggers the RSSI low alarm and the Task Manager input RSSI low becomes 
true.
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Notifying Alarms

The Notification Methods form lets you configure the way the base station lets 
you know over the air and over the line that there is an alarm. 

Important: Configuring these notification methods does not enable 
notification. This is done by Task Manager tasks that must be 
configured for your system.

Base stations with an Alarm Reporting license can send alarms to an Alarm 
Center and status messages (which contain the current state of all alarms and the 
alarm log) via email. 

Notifying Over the Air
The Service Kit lets you configure the way the base station notifies alarms using 
the base station’s own transmissions. To start and stop the over-the-air alarm, 
set up Task Manager statements. See “Over the air alarm actions” on page 207.

Tip: Use CWID as an additional over-the-air alarm notification 
method. Task Manager can disable CWID on startup, and then 
enable it when particular alarm conditions occur. See “CWID 

Actions” on page 204.

To configure the over-the-air alarm

1. Select Configure > Alarms > Notification Methods. 

2. In the Over the air area, Type box, select an alarm type. Currently, only 
Pip Tones are available. A pip tone is a 600 Hz tone with a duration of 200 
ms.

3. In the Pip method box, select an option that specifies how the pip tones 
are transmitted.

Option Description

Tail transmission A single pip tone is transmitted at the end of every 
transmission.

Periodically with Tx A pip tone is transmitted at the beginning of each 
transmission and regularly during the transmission at 
the interval specified by the Pip interval box.

Periodically with no Tx A pip tone is transmitted regularly when the base 
station is not otherwise transmitting. Pip tones are 
transmitted at intervals specified by the Pip interval 
box. 



156 Part G: Alarms    © Tait Electronics Limited April 2006

4. In the Pip interval box, specify the interval between pip tone 
transmissions.

5. In the Pip level box, specify the level of the pip tones in dB. This is the 
level relative to speech. More precisely, it is relative to the maximum 
transmit deviation of the current channel.

6. Click OK to confirm your changes and close the form.

Notifying Over the Line
The Service Kit lets you configure the way the base station notifies alarms over 
its balanced or unbalanced line interface. To start and stop the over-the-line 
alarm, see “Over the line alarm actions” on page 207.

To configure the over-the-line alarm

1. Select Configure > Alarms > Notification Methods. 

2. In the Over the line area, Type box, select an alarm type. Currently, only 
Pip Tones are available. A pip tone is a 600 Hz tone with a duration of 200 
ms.

3. In the Pip method box, select an option that specifies how the pip tones 
are sent.

4. In the Pip interval box, specify the interval between pip tone 
transmissions.

5. In the Pip level box, specify the level of the pip tones in dB. This level is 
relative to the line level specified in the channel profile for the current 
channel.

Option Description

Tail transmission A single pip tone is sent down the line at the end of 
every transmission

Periodically with Tx A pip tone is sent down the line at the beginning of 
each transmission and regularly during the 
transmission at the interval specified by the Pip 
interval box.

Periodically with no Tx A pip tone is sent down the line regularly when the 
base station is not transmitting RF. Pip tones are 
transmitted at intervals specified by the Pip interval 
box. 
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Configuring Alarm Center Communications 

If the base station has a dial-up modem and is able to connect via a telephone 
line to a PC running the Tait Alarm Center program, you need to enable and 
configure that connection. If the base station is connected via an Asynchronous 
Port Switch (APS), see TN-906 for more information.

To configure base station communications with an Alarm Center

1. Select Configure > Communications > Alarm Center. The Alarm Center 
form appears.

2. Select the Alarm Center connection check box. This enables the base 
station to dial out to an Alarm Center.

3. Under Port Settings, select a baud rate. If an APS is used, it must use the 
same baud rate.

4. If the connection is via an APS, enable the Port switch check box and 
configure the commands and responses used in base station communications 
with the APS (see “Configuring Port Switch Commands and Responses” 
on page 158).

5. Under Modem, in the Number to dial box, enter the telephone number 
of the Alarm Center computer’s modem. 

6. In the Modem command string box, specify any command string that is 
to be sent to the base station’s modem to configure it and prepare it for 
dialling. For more information, see TN-742.

7. Specify whether the base station modem is to use tone dialling or pulse 
dialling. Most modern telephone systems use tone dialling.

8. Under Connection timing, in the Number of retries box, specify the 
number of times that the base station will attempt to connect to the Alarm 
Center before giving up.  
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Note: Make sure that this number is sufficiently high. If the Alarm 
Center is connected to another base station, if it is sending an email 
over its modem, or if an APS is in use, the dial-up will fail and the 

base station must retry. The more base stations using the same Alarm Center, 
the more retries are needed. You can have up to 20 retries. If the base station 
is connected to an APS, specify 20 retries and minimize mass dial-out attempts 
by enabling dialling out on only two base stations for conditions that can be 
guaranteed to affect all base stations (for example, AC mains failure). 

9.  In the Time between retries box, specify the length of time that the base 
station will wait before trying again to connect to the Alarm Center.

10. In the Minimum interval box, specify the minimum time that must elapse 
after the base station sends an alarm log or email message before it can send 
another. Select a number and specify whether it is minutes or hours. Make 
sure that the interval is large enough to prevent the base station keeping the 
Alarm Center busy when other base stations are trying to contact it.

11.Click OK to confirm your changes and close the form. 

12.Create suitable Task Manager tasks that instruct the base station to send the 
alarm log or status message, using the action Send alarm log now. 

Configuring Port Switch Commands and Responses
If the base station is connected via an APS, set up the port switch commands 
and responses as follows.

1. In the Connect command box, enter a command in the format  
^M/Cx^M, where:

^M instructs the APS to enter command mode.

/C requests a connection

x is the APS port that the site modem is connected to. This is usually the 
highest port number available. 

^M terminates the sequence.

2. In the Connect response box, leave the default value ‘1’. This is the 
message that the APS uses to acknowledge the base station’s connect 
command.

3. In the Disconnect command box, enter a command in the format
^Mxxx^M/X^M, where:

xxx is a sequence of three identical characters, for example, LLL. The APS 
must be configured to recognise the same character for its disconnect 
sequence and to require three sequential characters. 

/X^M is the command mode exit instruction.

4. In the Disconnect response box, leave the default value ‘3’. This is the 
message that the APS uses to acknowledge a disconnect command.
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Configuring Email Messaging

If the base station has an Alarm Reporting license and is set up with a dial-up 
connection using a telephone line, it can email alarms, for example, to the 
maintenance technician’s PC.

The Email form lets you enable and configure the sending of email messages. 
The base station passes the configuration information on to its Alarm Center 
along with the status message. The Alarm Center then builds the email using 
that information and sends it to the SMTP server address provided.  

To configure email messaging

1. Select Configure > Communications > Email.

2. Select the Email notification box to enable the base station to send emails 
via an Alarm Center.

3. In the Recipient box, enter the email address of the person to receive the 
email. If you want emails to be sent to multiple addresses, separate the 
addresses with a comma. 

4. In the Reply address box, enter an email address for replies. The base 
station itself cannot receive replies to the emails it sends; they will go instead 
to this address. 

5. In the Subject line box, enter the text for the subject of the emails. 

6. In the Leading information box, enter text that will be added to the 
message body before the actual content of the email. 

7. In the SMTP server box, enter the IP address of the server that the Alarm 
Center will send emails to.

8. Set up suitable Task Manager actions that send email in response to 
appropriate events.

Tip: Select Diagnose > Reciter > Misc I/O and send a test email to 
verify that the configuration works. 
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Configuring Syslog Communications

If the base station has an enabled Ethernet interface, it can send its alarm 
messages and a heartbeat message to a syslog collector. For more information, 
see TN-1142-AN. All alarm messages that are stored in the base station’s alarm 
log are sent. The syslog collector can be configured to raise the alarm when it 
ceases to receive any messages from the base station.

To configure syslog communications

1. Select Configure > Communications > Syslog.

2. Select the Send syslog messages to network check box to enable syslog 
communications.

3. In the Address box, enter the IP address of the syslog collector. Messages 
will be sent to this address. 

4. If necessary, enter into the Port box the TCP port that the syslog collector 
uses to receive syslog messages. (The Kiwi Syslog Daemon uses the default 
port number 1468).

5. If you want the syslog collector to alert you if a base station fails, select the 
Send Heartbeat check box and select a suitable interval between heartbeats 
(options range from one minute to 12 hours).

Note: TB8100 syslog messages are not fully reliable, even though 
they use TCP. They can be lost if Internet traffic is particularly 
heavy. In addition, the base station cannot send its heartbeat or any 

other syslog messages if a Service Kit is connected or if it is in CCI mode. When 
setting up the syslog collector, give it an adequately long timer before it raises 
the alarm after failing to receive a heartbeat.
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Part H Diagnosing

Using the Service Kit, you can carry out diagnostic tests on the 
base station and its modules. While you can view a diagnostic 
form in Run mode, the base station must be in Standby mode for 
the test itself.

Generally a diagnostic form displays relevant information, so that 
you can monitor base station status before, during, and after the 
test. Often you can combine different tests.

Some diagnostic tests check aspects of the base station. Others 
provide you with a simple function (for example, a voltage on the 
RSSI output pin) that facilitates setting up or troubleshooting the 
base station’s interface to external equipment. 

Topics

Carrying Out Diagnostic Tests

System Tests

Reciter Tests

Power Amplifier Tests

Power Management Unit Tests
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Carrying Out Diagnostic Tests

Most diagnostic tests are carried out in a similar way. The following describes 
how to do it. 

When you start a test, it uses the base station’s existing settings such as frequency 
and level, unless you enter different values.  When you stop a test or it comes 
to an end, the base station always returns to the configuration it was in before 
the test began. For example, after making a test transmission at a manually 
selected frequency, the base station reverts to the frequency it was previously 
configured for. 

To carry out a diagnostic test

1. Connect and log on to the base station. You can be remotely connected, 
but you do need to be on site to test the control panel and the speaker.

2. Click Diagnose.

3. Click Mode and select Standby mode.

4. In the navigation pane, select an item. The corresponding form appears.

5. In the form, check the base station’s current status and click Start Test. 

This either carries out the test or it enables other buttons on the form so that 
you can carry out a test. The item in the navigation pane turns red and the 
Start Test button changes to Stop Test. 

During the test, the base station will respond to any faults that occur (if, for 
example, the PA overheats, it will fold the power back) but there will be no 
alarm notification, because Task Manager is not active in Standby mode.

6. If desired, you can navigate to other forms to view monitoring screens, 
check the base station’s configuration. Some tests also allow you to 
simultaneously carry out other tests.

7. If necessary, click Stop Test to end the test (some tests end automatically). 
Selecting Run mode or disconnecting the Service Kit also ends the test. 



164 Part H: Diagnosing    © Tait Electronics Limited April 2006

System Tests

The Service Kit can initiate self-tests on the base station you are logged on to 
and verify that the control panel controls are working. 

Self-Tests
In the Self Tests form (Diagnose > System > Self Tests), you can ask the base 
station to carry out a set of self-tests. The base station itself determines whether 
it passes a test. The form displays the result of those tests. 

You can use the option buttons to configure the display to show all test results, 
only tests that failed, or only tests that passed.

To run base station self-tests

1. Click Run Tests. The tests can take up to 90 seconds. When the tests are 
completed, the Self Tests form displays the results. 

2. If the base station fails a test, click Reset Base Station (Administrator access 
level required). This may enable the base station to recover.  You need to 
connect the Service Kit again and log on to the base station.

3. Click Run Tests again. If the base station still does not pass the tests, note 
any failure codes displayed in the Code column and send the base station for 
repair.
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Control Panel Tests
The Control Panel form (Diagnose > System > Control Panel) lets you carry 
out tests to verify that the controls on the front of the base station are working. 
You need to be at the base station site to carry out these tests. The base station 
can test all controls, including those used by the other channel.

To test control panel buttons

1. In the Button test area, click Start Test. This disables all control panel funct-
ions. The base station will now pass control panel inputs to the Service Kit. 

2. Press a button on the control panel. 

3. Check that the corresponding LED in the Service Kit form turns green.

4. Repeat steps 2 and 3 for each other button you want to test.

5. Click Stop Test to conclude the test. 

To test the microphone’s PTT button

1. In the Button test area, click Start Test. This disables all control panel 
functions. The base station will now pass any control panel inputs to the 
Service Kit. 

2. Press the PTT button on the microphone.

3. Check that the PTT button LED in the Service Kit form turns green.

4. Click Stop Test to conclude the test. 

To test the speaker

1. In the Speaker Test area, click Start Test.

2. Turn up the volume and listen to confirm that a 700 Hz test tone at 0 dBm 
is coming from the speaker.

3. Click Stop Test to conclude the test. 

To test the control panel LEDs

1. In the LED test area, click Start Test.

2. Check that each of the control panel LEDs is going on and off in a 
recognisable sequence.

3. Click Stop Test to conclude the test. 
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Reciter Tests

The Service Kit lets you carry out tests on the receiver, synthesiser lock ranges, 
audio lines, and the various digital inputs and outputs.

Receiver Tests
The Receiver form (Diagnose > Reciter > Receiver) lets you carry out various 
tests on the receiver part of the TB8100 reciter.

Testing Receiver Operation
The Set receiver frequency test provides a quick way to get the receiver 
operating. You manually set the receiver frequency and do not need to alter the 
base station’s configuration. 

1. Connect an RF source to the reciter. 

2. Select Diagnose > Reciter > Receiver. In the Frequency box, enter the 
frequency you want to receive on. Alternatively, use the arrow buttons to 
shift the frequency up or down.

3. In the Channel Spacing box, select a value from the drop-down list.

4. Click Start Test.  

In the Receiver Values area, a green LED indicates whether the receiver 
synthesiser managed to lock onto the frequency. The area also displays the 
current RSSI and SINAD and the receiver’s operating frequency.

5. If there is no response, check the Receiver state LED and box to verify 
that the receiver is on. If it is not on, the Exciter state LED and box 
indicate whether the whole reciter is off.

Note: The SINAD is approximate and is obtained by comparing the 
in-band audio against out-of-band noise. This value should not be 
relied upon to make calibrated measurements. 

6. If desired, unmute the receiver output as follows: 

a. In the Control area, click Start Test. 

b. Click Unmute Output.

7. If desired, modify the receive frequency by clicking the up or down arrows. 
(You can repeat this as often as you want.)
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The End Test button turns into a disabled Starting Test button until the new 
frequency has been tested.  The form now displays the new values.  

8. Click Stop Test when you are finished.

Testing Receiver Sensitivity
You can carry out a basic test of the receiver’s sensitivity without using test 
equipment. The test only works if the receiver has a 50 ohm load and is not 
receiving any RF signal. You can set this up by connecting up a test set and 
switching its RF off.

1. Disconnect the antenna and connect a 50 ohm load.

2. Select Diagnose > Reciter > Receiver. 

3. If necessary, alter the receiver’s frequency and channel spacing in the Set 
receiver test frequency area. 

4. Click Test Rx Sensitivity.  The Result box indicates whether the receiver 
passed or failed the test. If the receiver was receiving any RF, the test result 
will be ‘fail.’

Measuring Received Signal Levels
You can measure the strength of RF signal that the base station receives across 
a band of frequencies. A bar graph displays the results. 

This test lets you see what signals are out there; it does not determine the 
receiver’s sensitivity.
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To measure signal levels

1. Select Diagnose > Reciter > Signal Level.

2. In the Center frequency box, specify the middle frequency of the band 
you want to test. This can be any frequency within the receiver’s switching 
range.

3. In the Channel spacing box, select a value from the drop-down list. This 
specifies the size of the step from one frequency to the next. If this 
corresponds to the channel spacing, you will measure signal levels of the 
different channels in the band.

4. Under Peak hold, select On if you want the display to show the strongest 
signal received on any pass.This means signals from infrequent users are  
more likely to be included. Select Off if you want to see only the results of 
the most recent pass.

5. On the toolbar, click Standby.

6. Click Start Test. The base station sets the receiver to a frequency, measures 
the RSSI, increments the frequency by the value in the Channel spacing 
box, measures its RSSI and so on for 101 steps below and above the center 
frequency you specified. If a frequency lies outside the receiver’s lock range, 
its RSSI is not displayed.

The graph displays the measured RSSI values and annotates the x-axis with 
the correct frequency values. The data is automatically saved to a file 
(signal_level_log.csv) in the LogFiles subdirectory. You can open this file in 
a spreadsheet program. 

Determining Synthesiser Lock Ranges
You can test the reciter’s synthesisers to determine the range of frequencies that 
the receiver and the exciter can operate on. Use these tests to check that the 
reciter is calibrated correctly for the channels that it will operate on.

The Clock source box indicates whether the reference frequency is internal 
or external to the base station.

The bottom group of boxes with LEDs indicate the lock status of various parts 
of the reciter in its current operation.

To test the exciter or receiver lock range 

1. Select Diagnose > Reciter > Synthesisers.

2. Click Start Test in the exciter or receiver row. 

The exciter or receiver checks all the channel frequencies in the band that 
the base station is type-approved to operate in.
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3. In the Lower Frequency and Upper Frequency boxes, view the results 
of the test. These values report the range within which the synthesiser is able 
to lock onto the specified frequency. 

Note: The reported ranges are conservative. In fact, the base station 
will be able to transmit and receive outside the range, but with 
reduced transmit output and receive sensitivity. 

4. Click Stop Test. The exciter and receiver frequencies revert to what they 
were when you started the test.

Audio I/O Tests
The Audio I/O form (Diagnose > Reciter > Audio I/O) lets you measure the 
level of any audio input or put a 0 dBm signal tone on the balanced or 
unbalanced line out.

In the Input area, the Audio Input gauge displays the level of the current audio 
input. In the Output area, the Audio Output gauge displays the audio level of 
the line out selected by the option buttons. The display continues to update 
every 500 ms.

Measuring the Audio Input Level
The reciter can measure the level of the current audio input and display it on 
the Service Kit. 

You can use this diagnostic tool in the following situations:

Troubleshooting: the measurement shows you whether audio is arriving at 
the base station. 

Adjusting the audio output of other equipment such as a console. 

Defining channel profiles: the measurement tells you the actual input level 
so that you can specify a value for the expected input level.

Note: Audio that is input during the test is not transmitted, because 
the base station goes into standby mode for the test.

To measure the audio input level

1. Make sure that audio is being fed into one or more inputs on the reciter’s 
system interface.

2. Select Diagnose > Reciter > Audio I/O.

3. Click the appropriate option to select the type of input you want to 
measure. 
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4. In the Input area, click Start Test. 

The Audio Input gauge displays the audio level. The numeric value of the 
level appears under the gauge heading. The value is displayed in red if it is 
off the scale of the gauge. Levels are measured over a window of 100 ms and 
updated twice a second. 

5. Click Stop Test or return to Run mode to end the test.

Generating an Audio Output
The reciter can output an audio test tone at one of three pre-defined 
frequencies. You can use this to test the reciter's ability to put audio on its 
output lines or to set up and configure the interface from external equipment 
to the base station. The audio is output at a nominal 0 dBm.

1. Select Diagnose > Reciter > Audio I/O.

2. In the Output area, specify which line out will carry the output.

3. Click Start Test.

4. View the Audio Output gauge and check that the measured level is close 
to 0 dBm (balanced line out) or 0.8 Vpp (unbalanced line out).

5. Click Stop Test or return the base station to Run mode to end the test.

Digital I/O Tests
The Digital I/O form (Diagnose > Reciter > Digital I/O)  lets you work with 
digital inputs and outputs. You can view the current state of all digital inputs 
and toggle any digital output to help you test any equipment connected to it.  

The Channel switch area indicates the channel number that is currently set by 
external equipment using the channel select lines on the system interface. If the 
area is disabled, this is because external channel selection is disabled (Configure 
> Base Station > System Interface.)

The Digital outputs area lets you toggle any digital output between active (red 
LED) and inactive (gray LED). You can do the same to the Rx Gate output.  

The Digital inputs area displays the current settings of digital inputs. You can 
also view the current state of the Tx Key input. 
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Testing Digital Outputs
You can toggle any digital output line or the Rx Gate output line between   
active and  inactive. Use this test to make sure that the output is working and 
to check that any equipment attached to that output responds as intended.

To test a digital output

1. Select Diagnose > Reciter > Digital I/O.

2. Click Start Test. This enables the Toggle buttons in the Digital Outputs 
area. This area now displays the output states as they were when you started 
the test.

3. Click the digital output’s (or Rx Gate’s) Toggle button to change its state.

When the output is activated, its LED displays Green. (If the output is not 
present on the system interface board, an error message appears.)

4. Check the response of any attached equipment.

When you have finished testing the outputs, click Stop Test. This returns all 
digital outputs to the state they were in when you started the test.

Testing Digital Inputs
The Digital inputs area displays the current state of all digital inputs to the 
reciter. 



172 Part H: Diagnosing    © Tait Electronics Limited April 2006

A digital input can be  active (red LED) or  inactive (gray LED). Many of these 
inputs can be configured as channel select lines. The Channel box indicates the 
channel number that they currently select and the text to the right indicates the 
number of bits (lines) involved and their logic settings.

To test a digital input

1. Select Diagnose > Reciter > Digital I/O.

2. Using the equipment connected to the digital input, toggle the state of that 
input.

3. In the Digital inputs area, check that the state of that input changed. 

Testing Hardware Channel Selection
If the channel that the base station operates on is to be selected by an external 
channel switch, you can verify that the base station correctly interprets the 
switch’s channel selection. 

1. Select Diagnose > Reciter > Digital I/O.

2. Using the channel switch, select a channel.

3. In the Channel switch area, check that the expected channel number 
appears. (A hardware channel number of 0 means that the channel is defined 
by software.)

4. If there is a discrepancy, check that the correct channel selection option 
(Binary, BCD, or invert) is selected in Configure > Base Station > System 
Interface.

Miscellaneous Tests
The Misc I/O form (Diagnose > Reciter > Misc I/O) lets you test the RSSI 
output and send a test email.

RSSI Tests
In the Misc I/O form, the RSSI output area lets you carry out tests on the RSSI 
output. You can:

provide a defined RSSI voltage output so that you can test equipment that 
is connected to the base station.

specify a received signal strength in dBm and test the base station’s 
conversion of the measured signal strength into an output voltage. You can 
use this test to convert an RSSI voltage to received dBm or vice versa.
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The Current output level box displays the voltage currently on the RSSI 
output pin.

Setting a Fixed RSSI Voltage
1. Select Diagnose > Reciter > Misc I/O.

2. In the Force output level to box, enter the voltage level you want.

3. In the adjacent box, select V. 

4. Click Start Test. This unlinks the RSSI output pin from the reciter’s 
operating logic. The RSSI output pin is initially set to 0 V, and then the test 
puts the selected voltage directly on the RSSI output pin.

5. Click Stop Test to stop the test. This gives control of the RSSI output back 
to the base station.

Testing the RSSI Output
1. Select Diagnose > Reciter > Misc I/O.

2. In the Force output level to box, enter a nominal received signal strength 
in dBm.

3. In the adjacent box, select dBm. 

4. Click Start Test. This unlinks the RSSI output pin from the reciter’s 
operating logic. 

The RSSI output pin is initially set to 0 V, and then the test uses the con-
figuration in Configure > Base Station > System Interface to calculate a 
voltage from the signal strength you specified and put it on the RSSI output 
pin. 

5. Using test equipment, measure the voltage on the RSSI output pin and 
confirm that it is as you would expect. Also check the voltage in the 
Current output level box. 

6. Click Stop Test to stop the test. This gives control of the RSSI output back 
to the base station, which updates the voltage with a value computed from 
the currently measured received signal strength.

Sending a Test Email
1. Select Diagnose > Reciter > Misc I/O.

2. In the Email area, click Start Test. The base station sends a test email using 
the configuration in Configuration > Communications > Email.  
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Detecting Subaudible Signalling
You can monitor the current channel for any subaudible signalling. This is a 
useful diagnostic tool if the base station is not opening the receiver gate to 
transmissions with subaudible signalling as expected. 

To detect subaudible signalling

1. Select Diagnose > Reciter > Subaudible Scan.

2. Click Start Monitoring. 

The form will now display ‘Scanning..’ If any subaudible signalling is 
received, its type and modulation frequency or code is displayed.

Once any sub-audible tone is detected, the scan stops until that tone is 
removed. This prevents repetitions of the same tone from being displayed, 
but does mean that when there is more than one possible decode tone, only 
the first one found will be reported. For instance, DCS025 and DCS244 
(inverted) share the same bit-sequence. If one of these codes is applied dur-
ing a scan, the scan will at random report one or the other, but not both.

Similarly, if a low-frequency CTCSS tone is present with a high deviation, 
so that it can be detected by multiple filters, then only the lowest successful 
tone frequency will be reported. For instance, with the "T800" CTCSS 
characteristics selected, if a tone of 69Hz is applied with 20% deviation, then 
it will be reported as a 67Hz tone, not as a 69.4Hz tone. This effect can be 
reduced by selecting the "EIA603" characteristics, which narrows the 
CTCSS filters at low frequencies (Configure > Base Station > Miscellane-
ous).

3. When you are ready to stop scanning, click Stop Monitoring. 
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 Power Amplifier Tests

The Service Kit lets you test aspects of the PA. You can test the fan, the front 
panel, and the PA’s ability to transmit.

Control Tests
The Control Tests form (Diagnose > Power Amplifier > Control Tests) lets 
you test the PA fan and front panel fault LED. 

Alarm status Indicates whether the PA has any current alarms.

Current fault LED 
state

Indicates the current state of the LED. 

Current fan state Indicates whether the fan is on or off.

Current 
temperature

The Current temperature area displays four thermometers that monitor the four 
PA temperature sensors.

Testing the PA Fault LED
You can test that the red fault LED on the front of the PA is able to light up. 
(The PA has a pair of LEDs: a green status LED and a red fault LED. They are 
only visible when the front panel is removed.) 

1. Select Diagnose > Power Amplifier > Control Tests. 
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2. Under Fault LED, click Start Test. This uncouples the fault LED from 
the PA’s operational logic and attempts to light the LED.

3. Check on the front of the power amplifier that the PA LED is flashing on 
and off.

4. Click End Test to finish the test. 

Testing the Fan
You can ask the base station to turn the PA fan on and off. This tests the fan 
and its control circuitry.

Test the fan after fixing a fan problem or fitting a new fan. When you fit a fan, 
use this test to verify that the fan is correctly connected, so that the PA (and not 
the PMU) activates it. 

Note: The base station can detect the motion of 3-wire fans and will 
raise an alarm if the fan does not operate.

 

To test the fan

1. Select Diagnose > Power Amplifier > Control Tests. 

2. Click Start Test. This uncouples the fan from the base station’s control but 
leaves it in its current state.

3. Click Toggle Fan. If the fan was off, this should turn it on.

4. Check that the fan is operating.  A 5-second timer counts down. When it 
expires, the test ends and control of the fan reverts to the base station. 

Testing the Transmitter
The Transmission Tests form (Diagnose > Power Amplifier > Transmission 
Tests) lets you test the ability of the PA to transmit. Use it, for example, when 
setting up and commissioning a system. You can:

transmit using the current channel configuration

specify any suitable frequency, and configure the output power and channel 
bandwidth. 

transmit carrier only or carrier modulated by your choice of modulation 
frequency and deviation level. 

Tip: Alternatively, test the transmitter by pressing the Carrier button 
on the control panel.

To ensure that you cannot inadvertently leave the base station transmitting, the 
test automatically stops after 60 seconds. 

Note: You can carry out this test together with other tests, for 
example to see the effect of transmission on battery voltage when 
the AC mains supply is off.
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Transmitter 
output

The Transmitter output area displays forward and reverse power gauges, and 
you can choose whether to view the values as watts or dBm. Underneath is the 
VSWR.

Alarm status If the Alarm status LED is red, there is a PA alarm and you cannot carry out the 
test. 

Manual 
transmission

The Manual transmission area lets you configure and carry out the transmission 
test.

To send a test transmission

1. If you don’t want to use the current channel configuration, specify the 
frequency and power of the test transmission as follows:

a. In the Transmitter frequency box, enter a frequency or use the arrows 
to increment or decrement the current frequency.

Important: Do not inadvertently transmit on a prohibited 
frequency. For example, 406.0-406.100 MHz is reserved 
internationally for distress beacons.

b. In the Power box, specify the RF output power that the test will run at. 
The box to the right displays the equivalent power in dBm.

2. If you want to transmit an unmodulated test signal, select the Carrier only 
option.

3. If you want to transmit a modulated test signal, select the Modulation on 
option, and configure the modulation as follows:

a. In the Deviation box, select a maximum transmit deviation.

b. In the Modulation level box, specify what percentage of the maximum 
deviation the test tone will have.

c. In the Modulation frequency box, specify the frequency of the tone 
that will modulate the test signal. 

4. Wait until the PA transmitter LED is gray (this means that the base station 
is not busy).
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5. Click Start Transmission. 

The PA outputs an RF signal on the RF Out N-connector. The Trans-
mitter output area gives you a graphical display of the forward and reverse 
power.

6. Click Stop Transmission at any time to end the test. 

If you don’t end the test, it automatically stops when the Time to autostop 
box has counted down to zero. If the transmission time was not long 
enough, click Start Transmission again.
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Power Management Unit Tests

The Service Kit lets you test aspects of the PMU and monitor additional details 
of its operation. 

Control Tests
The Control Tests form lets you simulate an AC mains failure. You can also 
check that the fan, the fault LED, and the auxiliary output are working. 

Simulating AC Mains Failure
The Control Tests form lets you simulate an AC mains failure so that you can 
test the base station’s battery backup and the PMU’s DC-DC converter. This 
simulation is not available if there is no DC power supply or if its voltage is too 
low. 

Important: This test affects any other base station in the subrack. 

To simulate an AC mains failure

1. Select Diagnose > Power Management > Control Tests.

2. Click Start Test at the bottom of the Control Tests form.

3. Click Mains Failure Test. 

4. Check that power to the PA and the Reciter/control panel stays on. 

5. Click Stop Test.

Testing the Fan
You can ask the base station to turn the PMU fan on and off; this tests the fan 
and its control circuitry.
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Test the fan after fixing a fan problem or fitting a new fan. When you fit a fan, 
use this test to verify that the fan is correctly connected, so that the PMU (and 
not the PA) activates it. 

Note: The base station can detect the motion of 3-wire fans and will 
raise an alarm if the fan does not operate.
 

To test the fan

1. Select Diagnose > Power Management > Control Tests.

1. Click Toggle to the left of the PMU fan LED. If the fan was off, this should 
turn it on. 

2. Check that the fan is operating.

After ten seconds, the test automatically ends and the base station takes back 
control of the fan. 

Testing the PMU fault LED
You can test that the red LED on the front of the PMU is able to light up in 
response to a fault. (The PMU has a pair of LEDs: a green status LED and a red 
fault LED. They are only visible when the front panel is removed.)

1. Select Diagnose > Power Management > Control Tests.

2. In the Control Tests form, click the Start Test button that is to the left of 
the PMU fault LED. This uncouples the LED from the PMU’s operational 
logic.  

3. Remove the base station front panel, and check that the PMU LED is 
flashing on and off. 

4. Click Stop Test to restore the LED’s connection with the PMU. 

Testing the Auxiliary Power Output
If the PMU is fitted with an auxiliary power supply submodule, you can test 
the PMU’s ability to switch its output on and off.

Note: The auxiliary power output must be on. If it is configured to 
be on only when the PMU uses AC mains power, make sure that 
the PMU is not using battery power.

1. Select Diagnose > Power Management > Control Tests.

2. Click Start Test at the bottom of the form.

3. Click the Toggle button above the Aux Output box.

The state of the LED should change.

4. Click Stop Test.
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Viewing Additional Details
The Supply Tests form (Diagnose > Power Management Unit > Supply 
Details) provides some additional information about the PMU. 

The form has a thermometer for each heatsink temperature sensor and an 
output voltage gauge. It also shows you all the monitoring information in 
Monitor > Monitoring > Power Management.
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Part I Task Manager

The Service Kit is your window into Task Manager. You can view 
the list of tasks, create new tasks from the available list of inputs 
and actions, and create custom inputs and actions. 

You can also monitor recent Task Manager actions and disable 
any tasks that may be causing problems. 

Topics

Accessing Task Manager

Working With Task Manager

Inputs

Actions

Customizing Task Manager

Customizing Task Manager

Monitoring Task Manager
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Accessing Task Manager

There are several different ways to access Task Manager forms. The different 
forms arrange the tasks differently, to present you with the most appropriate 
grouping of tasks for the part of the Service Kit you are currently in.  For 
example, if you open Task Manager from the Alarms section of the 
Configuration navigation tree, tasks relating to alarms are shown, and other 
tasks are hidden in folders. You can always access all tasks, no matter where you 
access Task Manager from

Task Grouping Best Access Method

General tasks Configure > Base Station > Task Manager

Tasks belonging to a 
channel profile

In the channel profile’s Edit Channel Profile dialog box, 
select the Task Manager tab

Tasks belonging to a 
signalling profile

In the signalling profile’s Edit Signalling Profile dialog box, 
select the Task Manager tab

Tasks that respond to 
an alarm 

Configure > Alarms > Alarms Task Manager
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Working With Task Manager

Task Manager forms let you work with the task list that the Task Manager 
processes. You can view the task list, add new tasks, modify existing ones, and 
rearrange the order and structure of tasks. Generally, a set of tasks is headed by 
a comment indicating their nature and purpose. 

The Task list item area lets you edit a selected item, which can be a task or a 
comment. When a task is selected, you can click one of the special Help icons 
to display information about the task’s input or action. The area also indicates 
the total number of enabled tasks.

The task list displays tasks in folders. Double-click a folder (or click its +/- icon) 
to open or close it. An open folder displays the tasks and comments that belong 
to it. Tasks generally have a tick; this means that they are enabled; tasks with a 
cross have been disabled. Click an item to select it; it appears inside the Task 
List Item area. 

The folders group related tasks. Tasks in a folder for a particular profile (for 
example, the default channel profile, or Signalling profile 1) are only processed 
if the current channel uses that profile.  

The buttons to the right lets you maintain the tasks in the list. For example, you 
can add an item or modify the selected item.

Maintaining the Task List
In Task Manager forms, the buttons to the right of the task list help you 
maintain the task list. To use some buttons, you must first select a task list item  
by clicking it. 

<<Update Item Saves changes you made to the selected item and updates the display in the Task 
List.

<<Insert Item Inserts the task displayed in the Task list item area just below the selected item 
in the task list. See also “Adding a Task” on page 187.
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Custom Actions Opens the Custom Actions form, where you can define your own combination 
of existing actions. 

Custom Inputs Opens the Custom Inputs form, where you can define your own combination 
of existing inputs. 

Move Up / Move 
Down

Shift the selected item up or down one line. Use these buttons to rearrange the 
order of tasks and comments in the task list.

Increase Indent / 
Decrease Indent

Let you add or remove an indent from a selected task. Indents have no effect 
on Task Manager processing; they help to make tasks easier to read and 
understand. You can only indent tasks that are under a comment. 

Enable / Disable By default, tasks are enabled; when an input condition becomes true, Task 
Manager processes the task. The Enable / Disable button lets you disable a task 
so that it has no effect, or toggle it between enabled and disabled. A standard 
base station can have up to 20 enabled tasks but up to 400 disabled ones. 

Delete The Delete button deletes the current task list item.

Adding a Task
To make full use of the base station’s capabilities, you need to add your own 
tasks to the list that Task Manager processes. This enables Task Manager to 
respond to events in a way that is tailored to your system. However, the set of 
actions must be well thought out to operate in exactly the way you want. For 
assistance, see TN-1154-AN Task Manager Programming Guide.

Important: It is possible to create tasks that undermine the base 
station’s ability to operate properly. Make sure that the choices you 
make are appropriate. Be particularly careful with powerful actions 

such as Reset base station. 

Important: While Tait has carefully tested each input and each 
action, it is not possible to test the enormous number of possible 
combinations of inputs and actions.  Thoroughly test any tasks you 

add before commissioning the base station. If you are uncertain about anything, 
refer to your supplier.

You can add a task anywhere in the task list. However, tasks in a channel profile 
or a signalling profile folder will only be actioned if the current channel has that 
profile assigned to it.

To define a task

1. Open a Task Manager form (see “Accessing Task Manager” on page 185).

2. If desired, click the folder you want the task to appear in.

3. Select Task in the Task list item area.

4. In the drop-down text box, select IF. 

Alternatively, if you want the task to be processed when the input condition 
goes from true to false, select IF NOT. For example, tasks with the input 
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‘IF NOT Receiving valid signal’ will be processed when the base station 
stops receiving a signal with the correct subaudible signalling. 

5. Position the mouse cursor over the next drop-down box and right-click to  
open the list of available inputs. The inputs relevant to the context from 
which you accessed the Task Manager form appear in the main list; other 
inputs are grouped under headings.

6. Select an input from the list. It appears in the box.

7. In the same way, select an  action from the drop-down list of the last drop-
down text box. 

8. In the task list, click a task to indicate where you want to add the task. 
Alternatively, click a folder. 

9. Click <<Insert Item. The task appears in the task list. 

10. If necessary, use the buttons on the right to move the task up or down, or 
to indent it.

Adding a Comment
When you define a set of tasks, you need to provide a comment that names 
them and indicates what they are for and how they work. You may also want 
to add further comments on individual tasks.

To add a comment

1. Open a Task Manager form (see “Accessing Task Manager” on page 185).

2. In the Task list item area, select the Comment option. 

3. Inter the text of the comment into the box below.

4. Click <<Insert Item. The comment appears in the task list.

5. If necessary, use the buttons on the right to move the comment up or down, 
or to indent tasks under it.

6. Click OK to confirm your changes and close the form.

Disabling a Task
You can disable any task in the task list. This is an easy way to stop Task 
Manager doing something you don't want it to do. (When the base station is in 
Standby mode, Task Manager is disabled and no tasks are executed.)

To disable a task

1. In any Task Manager form, click a task.

2. Click Enable/Disable. The tick at the beginning of the task turns into a 
cross.
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Importing Tasks
You can import a file containing tasks and comments that have been exported 
from another base station. Custom inputs or actions used by any of these tasks 
will also be imported. 

Note: If an existing custom input or action has the same name as one 
to be imported, it will be overwritten without warning. 

To import task items

1. In any Task Manager form, click Import.

2. Navigate to the folder containing the TB8100 task item export file (*.t8i), 
select it, and click Open. 

Exporting Tasks
You can export tasks and comments to a file, which can be imported into other 
base stations.

To export task items

1. In any Task Manager form, click an item or a folder containing items, and 
click Select. The items turn bold. Repeat until you have selected 
everything you want to export.

2. Click Export. The Export Task Items dialog box appears.

3. Navigate to a suitable folder for the TB8100 task item export file (*.t8i) in, 
give the file a name and click Save. 
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Task Manager Inputs and Actions

Task Manager has a large set of inputs and actions. 

To select an input or action

Click in the appropriate box in the Task list item area. A menu with several 
submenus appears.

The menu shows you the input relevant to the context from which you 
accessed the Task Manager form. The submenus contain all the other inputs. 
You can select any input.

To obtain Help on a task’s input or action

1. Click the task.

2. In the Task list item area, click the Help icon beside the appropriate box.

Inputs
An input is anything that Task Manager monitors. When the state of that input 
changes from false to true, Task Manager executes tasks with that input. IF 
NOT tasks are executed when the state of the input changes from true to false. 
Most inputs are set to true when the base station transitions to Run mode. 

Many inputs read the state of a system flag. Select Monitor > Monitoring > 
Base Station to view the current state of system flags. 

General Inputs
General inputs relate to the general operation of the base station.  

Another receiver in rack
The Another receiver in rack input is true when there are two or more base 
stations in the subrack and they are responding to polls on the internal bus. This 
input is useful in combination with other inputs as a custom input. 

Example

IF Another receiver in rack AND Battery voltage low
THEN Go to channel 2.

Another receiver in rack and Battery voltage low need to be combined 
as a custom input, and Channel 2 can be set up with an extra low power output.

This example could be used to provide an extra low power output when there 
are two base stations in the subrack. It could be used in a standard configuration 
used by all base stations in a system and would not be processed in single base 
stations.

Auxiliary supply enabled
The Auxiliary supply enabled input becomes true when Task Manager 
turns the Auxiliary supply flag on. If the Auxiliary power control box is set to 
Task Manager (Configure > Base Station > Miscellaneous), the auxiliary power 
output is active.
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Base station in Run mode
The Base station in Run mode input becomes true when the base station 
goes into Run mode. This occurs on startup and when you tell a base station in 
Standby mode to change to Run mode. 

Use this input for tasks you want included in Task Manager’s initialization 
routine, to start timers, and to disable base station functions that you only want 
enabled under particular circumstances. You can also set a system flag to a value 
other than the usual default. 

You can use the inverse of this input, but it will not work with all actions. For 
example, Transmit CWID now cannot work, because CWID is only 
transmitted in Run mode. 

Example

IF Base station in Run mode THEN Disable talk through repeater
IF Base station in Run mode THEN Disable line controlled base 

station

This example could be used to configure a backup base station with everything 
disabled but ready to go into operation when needed.

Example

IF NOT Base station in Run mode THEN Disable auxiliary supply 
IF Base station in Run mode THEN Enable auxiliary supply

This example can be used in TaitNet trunking systems to turn off power to the 
CMM when the base station is taken out of service.

Counter at maximum
The Counter at maximum (Countername) input becomes true when the 
particular named counter reaches the maximum value set for it in Configure > 
Task Manager > Counters. 

The counter value changes through Task Manager actions such as Increment 
counter. Counter values are read at the beginning of a processing cycle. If the 
counter value changes during the processing cycle, it is immediately available; 
any subsequent tasks will use the new input. When the base station enters Run 
mode, all counters are reset to 0.

Example

IF Counter at maximum (LightTrigger) THEN Activate Digital 
Output 2. 

Flag set (flagname)
The Flag set (flagname) input becomes true when Task Manager sets the 
corresponding flag. Flagname represents any name that you assigned to the flag 
in Configure > Task Manager > Flags. The state of flags is read at the beginning 
of a processing cycle. If a flag state changes during the processing cycle, it is 
immediately available; any subsequent tasks will use the new input. When the 
base station enters Run mode, each flag is cleared, unless a Task Manager task 
explicitly sets it. 
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External channel select enabled
The override input External channel select enabled becomes true when 
Task Manager sets the H/W channel select flag. This occurs on entering Run 
mode and if a Task Manager task enables power saving after a previous task has 
disabled it. 

Example

IF NOT External channel select enabled THEN Go to channel 2

This example specifies the channel that the TB8100 will operate on if a Task 
Manager action disables external channel selection. This is another way of  
specifying the channel in software; you can also select a channel as the default. 

Syslog service enabled
The override input Syslog service enabled becomes true when Task Manager 
turns the Syslog service system flag on. This occurs on entering Run mode and 
if a Task Manager task enables the syslog service after a previous task has 
disabled it. When the syslog service system flag is on, the base station sends 
syslog messages according to the configuration in Configure > 
Communications > Syslog. 

Power saving enabled
The override input Power saving enabled becomes true when Task 
Manager turns the Power save system flag on. This occurs on entering Run 
mode and if a Task Manager task enables power saving after a previous task has 
disabled it. 

Timer expired
A timer can only be started by the Task Manager action Start timer. It expires 
when the timer’s maximum time has elapsed. This time was entered in 
Configure > Task Manager > Timers. 

Example

IF Timer expired (Weekly Email) THEN Email status now. 

This input can be used to set up regular actions such as emailing the status 
message. 

Tx relay enabled
The override input Tx relay enabled becomes true when Task Manager turns 
the Tx relay system flag on. This occurs on entering Run mode and if a Task 
Manager task enables power saving after a previous task has disabled it. 

Channel Profile Inputs
Channel profile inputs relate to configuration items that are defined in channel 
profiles. You can put tasks with a channel profile input into the folder for a 
particular channel profile or into the General folder. If the task is in a channel 
profile folder, it is only processed when the current channel uses that profile. It 
the task is in the General folder, it is always processed. 
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CWID enabled
The override input CWID enabled becomes true when Task Manager turns 
the CWID system flag on. This occurs on entering Run mode. It also occurs if 
a Task Manager task turns the flag on after a previous task has disabled it.

Intercom enabled
The override input Intercom enabled becomes true when Task Manager 
turns the Intercom system flag on. When the base station enters Run mode, 
Task Manager sets the Intercom system flag to off. When the Intercom 
enabled input is true, there is an audio path connecting the base station 
microphone and speaker to the audio in and out lines.

Line controlled base enabled
The override input Line controlled base enabled becomes true when 
Task Manager turns the Line connected base system flag on. This occurs on 
entering Run mode. It also occurs if a Task Manager task turns the flag on after 
a previous task has disabled it.

Loopback enabled
The override input Loopback enabled becomes true when Task Manager 
turns the Loopback system flag on. When the base station enters Run mode, 
Task Manager sets the Loopback system flag to off.

PA carrier present
Whenever the PA starts transmitting, the PA carrier present input is true. 
This input becomes true when the PA is keyed up.

PA keyed by Tx Key line
This input becomes true when the PA is keyed up to transmit as a line-
controlled base station. This means that the Tx Key line has keyed up the PA 
and that it is the line in audio that will be transmitted.

PA keyed by valid Rx
This input becomes true when the PA is keyed up to transmit as a talk-through 
repeater. This means that the receiver has keyed up the PA and the received 
signal is being transmitted. 

Receiver enabled
The override input Receiver enabled becomes true when Task Manager 
turns the Receiver system flag on.. When the base station enters Run mode, 
Task Manager sets the Receiver system flag to on.

Receiving valid signal
The Receiving valid signal input becomes true when the conditions for 
opening the receiver gate are fulfilled. The received signal must meet the 
requirements for receiver gating defined in the current channel profile and for 
subaudible signalling defined in the current signalling profile. For example, the 
signal must be strong enough and use the right CTCSS tone. 

When the base station receives a valid signal, it does not necessarily make the 
Rx Gate line active.

IF NOT Receiving valid signal THEN Transmit CWID now.

This sends a Morse code identifier at the end of each transmission.
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Rx Gate line active
The Rx Gate line active input becomes true when the Rx Gate line on the 
system interface goes low. This input is similar to Receiving valid signal, 
however the Rx Gate line becomes active not just when the base station is 
receiving a valid signal, but whenever there is a valid line audio output. This 
audio output can also come from the base station microphone or from line 
input (when loopback is enabled). 

Note: If the current channel profile does not specify an audio path 
to line out, the Rx Gate line does not become active when a valid 
signal is being received.

Talk through repeater enabled
The override input Talk through repeater enabled becomes true when 
Task Manager turns the Talk through repeater system flag on. This occurs on 
entering Run mode. It also occurs if a Task Manager task turns the flag on after 
a previous task has disabled it.

Example

You could use this input as part of a set of tasks that impose a time limit on calls 
when in repeater mode. 

IF Talk through repeater enabled AND PA keyed by valid Rx 
THEN Start timer (CallTimeLimit)

The two inputs need to be combined into a custom input. When it become 
true, a timer is started. When this timer expires, other tasks can disable the 
repeater, start a timer for the transmit lockout, and re-enable the repeater. 

Transmitter enabled
The override input Transmitter enabled becomes true when Task Manager 
turns the Transmitter system flag on. This occurs on entering Run mode. It also 
occurs if a Task Manager task turns the flag on after a previous task has disabled 
it.

Tx Key input enabled
The override input Tx Key input enabled becomes true when Task 
Manager turns the Tx Key system flag on. This occurs on entering Run mode. 
It also occurs if a Task Manager task turns the flag on after a previous task has 
disabled it.

Signalling Profile Inputs
Signalling profile inputs relate to configuration items that are defined in 
signalling profiles. You can put tasks with a signalling profile input into the 
folder for a particular signalling profile or into the General folder. If the task is 
in a signalling profile folder, it is only processed when the current channel uses 
that profile. It the task is in the General folder, it is always processed. 

Subtone decoding enabled
The override input Subtone decoding enabled becomes true when Task 
Manager turns on the Subaudible decode system flag. This occurs on entering 
Run mode. It also occurs if a Task Manager task turns the flag on after a 
previous task has disabled it.
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Subtone encoding enabled
The override input Subtone encoding enabled becomes true when Task 
Manager turns on the Subaudible encode system flag. This occurs on entering 
Run mode. It also occurs if a Task Manager task turns the flag on after a 
previous task has disabled it.

Tone nn detected 
This input becomes true when the receiver detects a subaudible tone that is 
defined in the current signalling profile (Subaudible Signalling tab). nn refers to 
the number of the tone specified in that profile (a profile can have up to 16 
tones defined). 

Example

Enable the technician to request the emailing of a status message

IF Tone 2 detected THEN Email status now

When the base station receives the subaudible tone, the base station emails a 
status message. The signalling profile is set up so that this tone only results in 
Task Manager action. To obtain status information, the technician transmits 
that subaudible tone: Task Manager then instructs the base station to email the 
status message to the configured destination. 

System I/O
System I/O inputs involve digital and audio inputs and outputs over the base 
station’s system interface board.

Balanced input low
The Balanced input low input becomes true when the audio level on the 
unbalanced line in falls below the minimum level specified in Configure > 
Alarms > Thresholds. 

This input is useful in applications where the base station can expect a signal all 
the time. It lets you define tasks that specify actions when the expected audio 
input ceases.

Example

IF Balanced input low THEN Start over the air alarm

If the line fails, the base station sends alarm pips over the air.

Digital input active 
The Digital input active input becomes true when the digital input becomes 
active.

Digital output nn active
The Digital output nn active input becomes true when the base station sets 
the digital output.

RSSI high
The RSSI high input becomes true when the RF signal that the base station is 
receiving exceeds the maximum signal strength specified in Configure > Alarms 
> Thresholds. 
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Example

IF RSSI high THEN Go to channel 2

Change to a channel with a lower output power on receiving a powerful signal.

RSSI low
The RSSI low input becomes true when the RF signal that the base station is 
receiving falls below the minimum signal strength specified in Configure > 
Alarms > Thresholds. This input is useful in applications where the base station 
can expect to be receiving a signal all the time. The input lets you specify what 
the base station is to do when the expected signal ceases.

Unbalanced input low
The Unbalanced input low Task Manager input becomes true when the 
audio input on the unbalanced line falls below the minimum level specified in 
Configure > Alarms > Thresholds. This Task Manager input is useful in 
applications where the base station can expect a signal all the time. The input 
then lets you define tasks that specify actions when the expected input ceases.

Example

Tell the base station to do something when the unbalanced line input signal 
fails.

 IF Unbalanced input low THEN Start over the air alarm

If the line fails, the base station sends alarm pips over the air.

Alarm Inputs
You can select any alarm as a Task Manager input. This makes it possible to 
individually configure the base station's response to any alarm. For information 
about base station alarms, see “Monitoring Alarms” on page 143. All alarms are 
basic inputs. Even if an alarm is disabled, tasks with that alarm as an input will 
be processed.

PA air intake temperature high
This input becomes true when the ‘Air intake temperature high’ alarm is 
triggered. For information about this alarm, see “Air intake temperature high” 
on page 148. 

PA air intake temperature low
This input becomes true when the ‘Air intake temperature low’ alarm is 
triggered. For information about this alarm, see “Air intake temperature low” 
on page 148. 

Base station alarm on
This input becomes true when any base station alarm is triggered. 

Battery protection mode on
This input becomes true when the PMU is operating in battery protection 
mode, triggering the ‘Battery protection mode’ alarm. For information about 
this alarm, see “Battery protection mode” on page 149. 
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Battery voltage high
This input becomes true when the ‘Battery voltage high’ alarm is triggered. For 
information about this alarm, see “Battery voltage high” on page 149. 

Battery voltage low
This input becomes true when the ‘Battery voltage low’ alarm is triggered. For 
information about this alarm, see “Battery voltage low” on page 149. 

Channel invalid
This input becomes true when the ‘Channel invalid’ alarm is triggered. For 
information about this alarm, see “Channel invalid” on page 144. 

Email service enabled
The Email service enabled input becomes true when Task Manager turns the 
Email alarms flag on. This occurs on entering Run mode. It also occurs if a Task 
Manager task turns the flag on after a previous task has disabled it.

External reference absent
This input becomes true when the ‘External reference absent’ alarm is triggered. 
For information about this alarm, see “External reference absent” on page 148. 

External reference invalid
This input becomes true when the ‘External reference invalid’ alarm is 
triggered. For information about this alarm, see “External reference invalid” on 
page 148. 

Fan failed
This input becomes true when the PA or PMU ‘Fan failed’ alarm is triggered. 
For information about these alarms, see “Fan failed” on page 146 for the PA or 
“Fan failed” on page 149 for the PMU. 

Forward power low
This input becomes true when the ‘Forward power low’ alarm is triggered. For 
information about this alarm, see “Forward power low” on page 146. 

Mains supply failed
This input becomes true when the PMU’s ‘Mains supply failed’ alarm is 
triggered. For information about this alarm, see “Mains supply failed” on 
page 149. 

No PA detected
This input becomes true when the ‘No PA detected’ alarm is triggered. This 
occurs when the module fails or control bus communications are disrupted. For 
information about this alarm, see “No PA detected” on page 146.

No PMU detected
This input becomes true when the ‘No PMU detected’ alarm is triggered. This 
occurs when the module fails or control bus communications are disrupted. For 
information about this alarm, see “No PMU detected” on page 149.
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Over the air alarm on
This input becomes true when Task Manager turns the over the air alarm on. 
For more information, see “Over the air alarm actions” on page 207. 

Over the line alarm on
This input becomes true when Task Manager turns the over the line alarm on. 
For more information, see “Over the line alarm actions” on page 207. 

PA alarm on
This input becomes true when any PA alarm is triggered.

PA current fault
This input becomes true when any of the PA’s current alarms are triggered. 
This happens if any part of the PA is drawing excessive current, or if one final 
stage uses significantly more current than the other. For information about these 
alarms, see “Current” on page 147.

PA is shut down
This input becomes true when the PA’s ‘Shutdown’ alarm is triggered. For 
information about this alarm, see “Shutdown” on page 146. 

PA power foldback
This input becomes true when the PA’s ‘Power foldback’ alarm is triggered. For 
information about this alarm, see “Power foldback” on page 146. 

PA startup fault
This input becomes true when the ‘Hardware configuration invalid’ alarm or 
any of the ‘Calibration invalid’ alarms are triggered. For information about 
these alarms, see “H/w configuration invalid” on page 146 and “Calibration 
invalid” on page 146.

PA supply voltage fault
This input becomes true when one of the PA’s power supply voltage alarms is 
triggered. This happens if the voltage is too high or too low. For more 
information, see “Supply voltage” on page 147. 

PA temperature high
This input becomes true when the one or more of the PA’s ‘Temperature high’ 
alarms is triggered. For information about this alarm, see “Temperature high” 
on page 147. 

PMU alarm on
This input becomes true when any PMU alarm is triggered.

PMU output fault
This input becomes true when one of the PMU’s output alarms is triggered, 
because the voltage is high or low or the current is high. For information about 
these alarms, see “Output” on page 150. 

PMU power up fault
This input becomes true when the PMU’s ‘Power up fault’ alarm is triggered. 
For information about this alarm, see “Power up fault” on page 149. 
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PMU shutdown imminent
This input becomes true when the PMU’s ‘Shutdown imminent’ alarm is 
triggered. For information about this alarm, see “Shutdown imminent” on 
page 149. 

PMU temperature high
This input becomes true when the PMU’s ‘Temperature high’ alarm is 
triggered. For information about this alarm, see “Temperature high” on 
page 149. 

Reciter alarm on
This input becomes true when any reciter alarm is triggered. 

Reverse power high
This input becomes true when the ‘Reverse power high’ alarm is triggered. For 
information about this alarm, see “Reverse power high” on page 146. 

Note: Use the VSWR fault input instead of the Reverse power high 
input if the transmit power is set to less than 20 W or if the base 
station has a 5 W PA. The resolution of the reverse power 

measurement is 1 W; only a very serious antenna fault would trigger the reverse 
power high alarm if the power setting is low.

Synthesiser failed
This input becomes true when a synthesiser goes out of lock or the external 
frequency reference is invalid and the corresponding alarm is triggered. For 
information about these alarms, see “Synthesiser out of lock” on page 145 and 
“External reference invalid” on page 148.

VSWR fault
This input becomes true when the ‘VSWR high’ alarm is triggered. For 
information about this alarm, see “VSWR high” on page 146. 

Custom Inputs
The Custom Inputs submenu contains all the custom inputs that have been 
defined for the base station using Configure > Task Manager > Custom Inputs.

Actions
An action is something that Task Manager instructs the base station to do. 

There is often a group of actions relating to a particular base station function. 
For example, Task Manager can enable, disable, or toggle the talk through 
repeater function.  Enable makes the function effective, disable makes it 
ineffective, and toggle changes from the one state to the other.

Tip: To obtain Help on a task’s action, click the task. In the Task 
list item area, click the Help icon beside the action box.

General Actions
General actions relate to the general operation of the base station.
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Auxiliary supply actions
Auxiliary supply actions can enable, disable, or toggle the auxiliary supply, 
provided that it is configured for Task Manager control. The Auxiliary power 
control box (Configure > Base Station > Miscellaneous) must be set to Task 
Manager. Auxiliary supply actions affect the state of the Auxiliary supply system 
flag 

Example

IF Base station in Run mode THEN Enable auxiliary supply

This task is used in TaitNet trunked networks to provide power to the trunking 
controller. 

Fan test now
The ‘do now’ action Fan test now instructs the base station to run the fans 
for 5 seconds, irrespective of the temperature. If the fans are already running, 
this has no effect.

Power saving actions
Power saving override actions can enable, disable, or toggle the power save  
system flag. When the base station enters Run mode, the flag is enabled. 

When the power save flag is enabled, the power saving configuration in the 
current channel profile is effective. When it is disabled, there is no power 
saving.

Loopback actions
Loopback override actions can enable, disable, or toggle the Loopback system 
flag. When the base station enters Run mode, the flag is disabled. 

Note: The default state of the Loopback system flag is ‘disabled’. The 
default for most other system flags is ‘enabled’.

For Loopback actions to have any real effect, corresponding audio 
paths (balanced in and balanced out, or unbalanced in and unbalanced out) must 
be configured in the current channel profile. If all four audio paths are enabled, 
there are two loopbacks; balanced audio in to balanced audio out, unbalanced 
audio in to unbalanced audio out). 

When Loopback is enabled, corresponding input and output audio paths are 
connected to each other. A signal that is sent along the base station’s line in is 
sent back down line out. This is useful for line testing. 

When Loopback is disabled, there are no connections between input and 
output audio paths.

Example

IF Tone 15 detected THEN Enable loopback
IF Tone 16 detected THEN Disable loopback

You could use a single tone to toggle loopback, but this gives no certainty about 
the state of loopback.

Intercom actions
Intercom override actions can enable, disable, or toggle the Intercom system 
flag. When the base station enters Run mode, the flag is enabled.
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For Intercom actions to have any real effect, corresponding audio paths must be 
configured in the current channel profile. This means that the base station 
microphone must be connected to the balanced and/or unbalanced line out 
The speaker is always connected to the balanced line in. 

When this system flag is disabled, the microphone’s connections are disabled. 

When this system flag is enabled, the audio path for the microphone and the 
speaker is as configured in the current channel profile’s Signal Path tab. 

Tx Key actions
The Tx Key system flag makes it possible for Task Manager to override the Tx 
Key line. Tx Key override actions can enable, disable, or toggle the flag. When 
the base station enters Run mode, the flag is enabled. 

When the Tx Key system flag is disabled, the transmitter does not key up when 
the Tx Key line on the system interface goes active. 

When the Tx Key system flag is enabled, the transmitter keys up when the Tx 
Key line on the system interface goes active and transmits the audio provided 
to it on the balanced and/or unbalanced line in. 

The Tx Key system flag has no effect on the base station’s internal keying logic.

Reset base station
The ‘do now’ action Reset base station resets the base station. You can use 
this action in tasks designed to help the base station recover from minor faults.

Note: When a base station is reset, it reverts to its default channel. 

Example
IF Tone 2 detected THEN Reset base station

This task means that a technician can remotely reset the base station by sending 
a radio signal with the appropriate subaudible signalling.

Transmitter actions
Transmitter override actions can enable, disable, or toggle the Transmitter 
system flag. This provides you with an additional layer of control over 
transmitter operation. 

When the base station enters Run mode, the flag is enabled. 

When the Transmitter system flag is disabled, the transmitter cannot transmit. 

When the Transmitter system flag is enabled, the transmitter operates as usual. 

If the PMU is fitted with a standby converter and the Receiver and the 
Transmitter system flags are both disabled, the PMU shuts down as in Deep 
Sleep mode. 

Note: You can shut down specific forms of the transmitter 
operation. See “Talk Through Repeater Actions” on page 203 and 
“Line-Controlled Base Actions” on page 203.

Receiver actions
Receiver override actions can enable, disable, or toggle the Receiver system 
flag. This provides you with an additional layer of control over receiver 
operation. 

When the base station enters Run mode, the flag is enabled. 
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When the Receiver system flag is disabled, the receiver is always muted. If the 
current channel profile enables tone on idle, an idle tone is output on the line.  

When the Receiver system flag is enabled, the receiver operates as configured. 

If the PMU is fitted with a standby converter and the Receiver and the 
Transmitter system flags are both disabled, the PMU shuts down as in Deep 
Sleep mode. 

External channel select actions
External channel select override actions can enable, disable, or toggle the H/W 
channel select system flag. This provides you with an additional layer of control 
over how the current channel is selected. 

When the base station enters Run mode, the flag is enabled. 

When the flag is disabled, the channel is specified in software (Configure > Base 
Station > General). The base station uses the default channel.

When the flag is enabled, the channel is specified by the Channel select lines 
connected to the system interface card. The system interface must be configured 
using the Service Kit to enable channel selection. 

Note: Other Task Manager actions can tell the base station to change 
to a different channel.

Start timer
Task Manager can start or stop any of its 16 timers. When a timer is started, it 
is re-initialised, then it begins to count down, beginning at the time set in 
Configure > Task Manager > Counters and Timers. When it has counted 
down to zero, it expires. You can create tasks that are executed when a timer 
expires.

Stop timer
Task Manager can start or stop any of its 16 timers. When a timer is stopped, it 
ceases to count down, so it does not expire.  If it is re-started, it starts counting 
down again from the length of time set in Configure > Task Manager > 
Counters and Timers. You can create tasks that are executed when a timer 
expires.

Set flag
Task Manager can set or clear any of 16 numbered flags. A flag can only have 
one of two states: set or cleared. The state of a flag can be used as an input in 
other tasks.

Clear flag
Task Manager can set or clear any of 16 numbered flags. A flag can only have 
one of two states: set or cleared. The state of a flag can be used as an input in 
other tasks.

Increment counter
The Increment counter action adds one to the counter specified. When a 
counter reaches its specified maximum, it triggers actions with the input 
Counter at maximum. 
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Reset counter
The Reset counter action sets the value of the counter specified to zero, so that 
it must begin counting anew. 

Decrement counter
The Decrement counter action subtracts one from the current value of the 
counter specified. 

Channel Profile Actions
Channel profile actions relate to configuration items that are defined in channel 
profiles. You can put tasks with a channel profile action into the folder for a 
particular channel profile or into the General folder. If the task is in a channel 
profile folder, it is only processed when the current channel uses that profile. If 
the task is in the General folder, it is always processed. 

Talk Through Repeater Actions
Talk through repeater override actions can enable, disable, or toggle the Talk 
through repeater system flag. This gives you an extra layer of control over the 
audio path that feeds received audio into the transmitter. It lets you program 
the base station to operate as a talk through repeater in some situations, and to 
intelligently switch to another way of operating when the situation changes.

When the base station enters Run mode, the flag is enabled. 

When the flag is disabled, the base station cannot function as a talk through 
repeater. Any internal audio path joining receiver and transmitter is 
disconnected and receiving a valid signal does not key the transmitter. 

When the flag is enabled, the internal audio path is as configured in the channel 
profile.

If the channel profile does not configure the base station as a talk through 
repeater, these Task Manager actions have no effect. 

Line-Controlled Base Actions
Line-controlled base override actions can enable, disable, or toggle the Line 
controlled base system flag. This gives you an extra layer of control over the 
audio path that feeds line in audio into the transmitter. It lets you program the 
base station to operate as a line-controlled base station in some situations, and 
to intelligently switch to another way of operating when the situation changes.

When the base station enters Run mode, the flag is enabled. 

When the flag is disabled, the base station cannot function as a line-controlled 
base station. The Tx Key line and any internal audio path joining a line input 
to the transmitter are disconnected.  

When the flag is enabled, the internal audio path is defined by the channel 
profile and the Tx Key line can be used to key the transmitter.

If the channel profile does not configure the base station as a line-controlled 
base station, these Task Manager actions have no effect. 

Go to channel
The Go to channel action instructs the base station to change channel and 
operate according to the configuration defined by the channel with the number 
specified in the action. It stays on that channel until another Task Manager 
action changes channel or a reset returns it to the default channel.
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In base stations with a complex set of Task Manager tasks, you need to 
understand exactly how this action works. It is not a ‘do now’ action; the actual 
change of operating channel happens at the end of a processing cycle. This 
means, for example, that if the task list has a Go to channel 5 action  followed 
by a Go to channel 6 action, the base station will only ever change to channel 
6.  

Note: Hardware channel selection overrides all Task Manager 
channel actions.

Make current channel the default
The Make current channel the default action instructs the base station to 
select the channel it is currently operating on as the default channel. This action 
is the equivalent of selecting the channel in Configure > Base Station > 
General, and programming the base station with that change. If Task Manager 
changes to a new channel and makes that channel the default, the base station 
stays on that channel even after a reset.

In base stations with a complex set of Task Manager tasks, you need to 
understand exactly how this action works. The action takes what Task Manager 
views as the current channel. For example, a base station is operating on 
Channel 1 and the task list has a Go to channel 5 action followed by a Make 
current channel the default action, and then a Go to channel 6 action. 
The result of processing this list is that channel 5 is the default. It is not Channel 
1 (the current channel during the processing cycle) or channel 6 (the channel 
that the base station goes to at the end of the processing cycle).  

Note: Hardware channel selection overrides all Task Manager 
channel actions.

Go to next channel
The Go to next channel action instructs the base station to operate on the 
next valid channel in the channel table. If the base station was on Channel 001, 
it changes to Channel 002. It stays on that channel until Task Manager changes 
channel or a reset returns it to the default channel.

In base stations with a complex set of Task Manager tasks, you need to 
understand exactly how this action works. It is not a ‘do now’ action; the actual 
change of operating channel happens at the end of a processing cycle. This 
means, for example, that if the task list has two Go to next channel actions, 
the base station will move two channels down the channel table. 

Note: Hardware channel selection overrides all Task Manager 
channel actions.

CWID Actions
Task Manager can enable, disable, or toggle the CWID system flag. This 
provides you with an additional layer of control over the transmission of a 
CWID.

When the base station enters Run mode, the flag is enabled. 

When the flag is disabled, there is no automatic transmission of the CWID.

When the flag is enabled, CWID is transmitted as configured in the channel 
profile’s CWID System tab. 

If the channel profile does not provide for CWID, this flag has no effect.
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Transmit CWID now
The ‘do now’ action Transmit CWID now instructs the base station to 
immediately transmit the CWID message defined in the CWID System tab. 
This action enables you to configure CWID transmissions in a way that is not 
otherwise possible. For example, you could have the CWID transmitted more 
than once a minute or at every transmit tail. 

Transmit CWID now works even if a CWID action has disabled the CWID 
system flag. 

Transmitter power override actions
Task Manager can override the normal transmit power level and instruct the PA 
to use a special power level. This action can be used to reduce the transmit 
power if the DC input level is low or to increase the transmit power when the 
received signal strength is low. If the base station is transmitting when the 
transmit power is changed, there will be a short interruption to the transmission.

 The system flag Transmit power override indicates the current status. If it is 
enabled, Task Manager has overridden the configured transmit power level.

The special power level is set by the Task Manager override box (in the channel 
profile, General tab). 

When the base station enters Run mode, Task Manager clears any transmit 
power override. The normal transmit power level is used. 

When Task Manager enables the transmit power override, the PA uses the Task 
Manager override transmit power level.

When Task Manager disables the transmit power override, the PA reverts to 
using the normal transmit power level, as defined by the current channel profile 
or the channel table.  

Example
IF Battery voltage low THEN Enable transmitter power override
IF NOT Battery voltage low THEN Disable transmitter power override

Signalling Profile Actions
Signalling profile actions relate to configuration items that are defined in 
signalling profiles. You can put tasks with a signalling profile action into the 
folder for a particular signalling profile, or into the General folder. If the task is 
in a signalling profile folder, it is only processed when the current channel uses 
that profile. If the task is in the General folder, it is always processed. 

Subaudible Decoding
Subaudible decoding override actions can enable, disable, or toggle the 
Subaudible decode system flag. This gives you an extra layer of control over the 
base station’s response to subaudible signalling.

When the base station enters Run mode, the flag is enabled. 

When the flag is enabled, any subtones are decoded and checked against the 
current signalling profile. A received signal is only valid if it contains a specified 
subtone.

When the flag is disabled, subaudible signalling is not decoded. The received 
signal is regarded as valid irrespective of its subaudible signalling.



206 Part I: Task Manager    © Tait Electronics Limited April 2006

Subaudible Encoding
Subaudible encoding override actions can enable, disable, or toggle the 
Subaudible encode system flag. This gives you an extra layer of control over the 
subaudible signalling that the base station encodes onto its transmissions.

When the base station enters Run mode, the flag is enabled. 

When the flag is enabled, the base station encodes transmissions according to 
the signalling profile’s configuration (Subaudible signalling tab). 

When the flag is disabled, transmissions are not encoded with subaudible 
signalling.

System I/O
System I/O actions affect the base station’s digital outputs.

Activate Digital Output n
The Activate Digital Output n action makes the Digital Out n line on the 
system interface active.  If this line does not exist on the current user interface, 
the action has no effect. 

In base stations with a complex set of Task Manager tasks, you need to 
understand exactly how this action works. The actual activation of the digital 
output doesn’t happen till the end of a processing cycle. So the task list can 
activate and deactivate a digital output many times, but the output line will only 
ever be activated if the last action for that digital output is to activate it. 

IF Counter at maximum (LightTrigger) THEN Activate Digital 
Output 2. 

Deactivate Digital Output n
The Deactivate Digital Output n action makes the Digital Out n line on 
the system interface inactive.  If this line does not exist on the current user 
interface, the action has no effect. 

In base stations with a complex set of Task Manager tasks, you need to 
understand exactly how this action works. The actual deactivation of the digital 
output doesn’t happen till the end of a processing cycle. So the task list can 
activate and deactivate a digital output many times, but the output line will only 
ever be deactivated if the last action for that digital output is to deactivate it. 

Tx Relay actions
Tx relay  override actions can enable, disable, or toggle the Tx Relay system 
flag. This gives you an additional layer of control over the Tx Relay Driver line 
on the system interface. When the base station enters Run mode, the flag is 
enabled. 

When the Tx Relay system flag is disabled, the Tx Relay Driver line cannot go 
active. 

When the Tx Relay system flag is enabled, the base station can control an 
antenna relay using the Tx Relay Driver line, switching the relay before 
powering its transmitter up.

If the base station is not fitted with a system interface board that provides a Tx 
Relay Driver line, the Tx Key system flag has no effect.
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Alarm
Alarm actions make it possible for you to configure the way that the base station 
responds to alarm conditions.

Over the air alarm actions
Over the air alarm actions can turn the base station’s over the air alarm on or 
off. Indeed, Task Manager action is the only way that this alarm can be started 
or stopped. 

When the base station enters Run mode, Task Manager ensures that the over 
the air alarm is turned off. 

When Task Manager turns on the over the air alarm, the base station starts 
transmitting the alarm over the air according to Configure > Alarms > 
Notification Methods. 

When Task Manager turns off the over the air alarm, the base station stops 
transmitting the alarm. 

Over the line alarm actions
Over the line alarm actions can turn the base station’s over the line alarm on or 
off. Indeed, Task Manager action is the only way that this alarm can be started 
or stopped. 

When the base station enters Run mode, Task Manager ensures that the over 
the line alarm is turned off. 

When Task Manager turns on the over the line alarm, the base station starts 
sending the alarm over the line according to Configure > Alarms > Notification 
Methods. It will be sent over audio out lines that the system interface provides 
and that are enabled in the current channel profile’s audio path. 

When Task Manager turns off the over the air alarm, the base station stops 
sending the alarm. 

Email status now
The ‘do now’ action Email status now turns on a flag requesting that the 
base station email the status message. Emailing a status message is only done in 
systems with remote RS-232 connections.The email will be sent via an Alarm 
Center according to the configuration in Configure > Communications > 
Email. 

Note: A status message can only be sent once the minimum interval 
has elapsed after the last status message or alarm log was sent. This 
avoids (for example) receiving an email every time the base station 
keys up.

Note: Task Manager can disable the email service, which will 
override any future Email status now action. See “Email service 
actions” on page 208. 

Clear alarm log
The ‘do now’ action Clear alarm log empties the alarm log of all entries. This 
can be a useful action after the alarm log has been sent. Although Alarm Center 
will not duplicate alarms in its display, clearing the alarm log reduces the 
communications load involved in sending the alarm log. If the alarm log 
contains any alarms that have not already been sent as syslog messages, they will 
be lost.
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Example

IF Timer expired (Email Timer) THEN Clear alarm log

This task could be part of a set of tasks that emails the alarm log once per day. 
When a day timer expires, the alarm log is emailed. The email timer gives the 
base station time to send the alarm log. When that timer expires, the action 
clears the log, so that alarms are not sent more than once.

Email service actions
Task Manager can enable, disable, or toggle the Email system flag. This gives 
you an extra layer of control over the base station’s emailing functions. Email 
service actions are only used in systems with remote RS-232 connections.

When the base station enters Run mode, the flag is enabled. 

When the flag is enabled, Task Manager can email status messages (see “Email 
status now” on page 207). The base station does this according to the 
configuration in Configure > Communications > Email. 

When the flag is disabled, any Email status now actions are disregarded. 

Send alarm log now
The Send alarm log now action sends the alarm log to an Alarm Center, 
according to the configuration in Configure > Communications > Alarm 
Center. This configuration must have enabled Alarm notification to the Alarm 
Center, or the action has no effect.

First, the base station attempts to connect to the Alarm Center and log on. If it 
is successful, the base station sends its name and the contents of the alarm log, 
and then logs off and disconnects.

Example

IF Base station in Run mode THEN Start timer (24 hour Timer)
IF Timer expired (24 hour Timer) THEN Send alarm log now
IF Timer expired (24 hour Timer) THEN Start timer (24 hour Timer)

Syslog service actions
Syslog service override actions can enable, disable, or toggle the Syslog service 
system flag. This provides you with an additional layer of control over the syslog 
service. Task Manager can disable syslog messaging in particular circumstances 
and re-enable it later. 

When the base station enters Run mode, the flag is enabled.

When Task Manager disables the syslog service, no syslog messages are sent over 
the Ethernet system interface board.

When Task Manager enables the syslog service, syslog messages are sent 
according to the configuration (Configure > Communications > Syslog).

Custom Actions
The Custom Actions submenu contains all the custom actions that have been 
defined for the base station using Configure > Task Manager > Custom 
Actions. 
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Customizing Task Manager

Customizing Task Manager adds to its power and flexibility. There are several 
options available. You can create custom inputs or actions and define timers, 
counters, and flags. You can then use them to create tasks that will be executed 
when the custom input becomes true, the timer expires, the counter reaches its 
maximum, or the flag is activated. 

Working With Custom Inputs
The Custom Inputs form (Configure > Task Manager > Custom Inputs) lets 
you work with custom inputs. It lists the existing custom inputs and lets you see 
what combination of standard inputs each consists of. You can also create new 
custom inputs and edit or rename existing ones. 

A custom input is a user-defined Task Manager input that consists of a 
combination of standard inputs. Custom inputs make it possible to define tasks 
that will be processed when a combination of inputs becomes true. (A Task 
Manager task can only have one input.)

Viewing a Custom Input
1. Click an item in the Custom Input Name column.

2. View the display in the rest of the form. It shows the standard inputs used 
to create the custom input, whether they are negated, and the logic of their 
combination. The standard truth table determines the outcome for the 
different states of any pair. (See “Truth Table” on page 210.)

The Logic column shows graphically how the standard inputs will be com-
bined. First the input is negated, if its Not check box is selected. Then it is 
combined with the adjacent input to which it is joined by a line. The result 
of that combinatorial operation is combined with the input or result that it 
is joined to, and so on, until the final result is obtained. In this way, up to 
eight standard inputs can be combined to produce an input that can only be 
true or false.
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Defining a Custom Input
1. Click New. 

2. Edit the name that appears in the Custom Input Name column.

3. Click in an Input box and select an input from the list. 

4. If you want the negative of the input to contribute to the custom input’s 
logic, select the Not check box alongside.

5. Repeat steps 3 and 4 for all the standard inputs that will go to make up the 
custom input. The Input boxes that you choose will determine the order in 
which the standard inputs are combined. 

6. Under the Logic heading, select the appropriate options in the drop-down 
boxes to give the logical combination of inputs that you want. (For 
information about the effect of the different options, see “Truth Table” on 
page 210.)

7. Click OK.

Truth Table
The truth table below displays the possible individual values for input A and 
input B, and the result when you combine those values using each of the six 
available logic operators.  So, for example, if A is true and B is false and we 
combine A and B using XOR, the result is true. 

Working With Custom Actions
The Custom Actions form (Configure > Task Manager > Custom Actions) lets 
you work with custom actions. It displays the list of existing custom actions. If 
you select a custom action, it displays the set of standard actions that it consists 
of. You can also create new custom actions and edit or rename existing ones. 

A custom action is a user-defined Task Manager action that consists of more 
than one standard action. It saves you writing several different tasks with the 
same input.

A B AND NAND XOR XNOR OR NOR

false false false true false true false true

false true false true true false true false

true false false true true false true false

true true true false false true true false
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Viewing a Custom Action
1. Click an item in the Custom Action Name column.

2. View the Standard Actions column. It lists the standard actions that the  
custom action consists of.

Defining a Custom Action
1. Click New. 

2. Edit the name that appears in the Custom Action Name column.

3. Click in the first row of the Standard Actions column and select an action 
from the list. 

4. Repeat step 3 for all the standard actions that will go to make up the custom 
action. 

5. Click OK.

Defining Counters, Timers, and Flags
Counters, timers, and flags make it possible for Task Manager to do such things 
as respond to three presses of PTT or to email a status message once a week.

Note: Short timers may not be accurate. This is because it may take 
Task Manager longer than 10 ms to process its tasks, causing it to 
miss the next instruction to go through its task list. Tait recommends 

that you avoid short timers (< 50 ms) if the task list has more than 10 enabled 
tasks. 

To define a counter

1. Select Configure > Task Manager > Counters.

2. If desired, enter a suitable name for the counter into the Name box.

3. In the Maximum box, enter the highest number that the counter can 
reach. 

When the counter reaches its maximum, the input Counter at maximum 
becomes true for that counter and any tasks containing it are processed.

To define a timer

1. Select Configure > Task Manager > Timers.

2. If desired, enter a suitable name for the timer into the Name box..

3. In the Maximum box, enter the highest number that the timer can reach.

4. In the Units box, specify what unit of time the number you entered 
represents. 

When the timer reaches its maximum, the input Timer expired becomes 
true for that timer and any tasks containing it are processed.

To define a flag

1. Select Configure > Task Manager > Flags.

2. If desired, enter a suitable name for the flag into the Name box.

3. Click OK.
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Monitoring Task Manager

The items under Monitor > Task Manager provide options for monitoring 
Task Manager. If the base station is behaving unexpectedly, you can view the 
state of system flags to see whether Task Manager has overridden the normal 
configuration. Alternatively, open the Recent Actions form to see a list of 
actions that Task Manager has recently carried out. You also can view the 
current state of timers, counter, and flags.

Viewing System Flag States
The System Flags form (Monitor > Task Manager > System Flags) displays the 
current state of flags that Task Manager sets in the base station firmware. A 
green LED means that the flag is enabled. A gray LED means that it is disabled.  
Most flags are enabled by default, but Loopback, Over the air alarms, and 
Over the line alarms are disabled. When the base station enters or re-enters 
Run mode, Task Manager sets all flags to their default values. Flags only change 
when Task Manager executes a task that enables, disables, or toggles them.

Important: The System Flags area shows you the state of the flags, 
not necessarily the state of the corresponding base station function. 
It is important to understand this distinction. For example, if the 

Loopback flag is enabled, the base station’s audio will in fact be looped back 
only if the current channel profile provides compatible line in and line out 
audio paths. If the Email alarms flag is enabled, the base station will only 
actually email alarms if email alarm notification is enabled and correctly 
configured in Configure > Communications > Email. 

Use the System Flags area to find out whether Task Manager has enabled or 
disabled any functions. If a system flag does not show the default setting, Task 
Manager has changed it. Checking the state of the alarm notification functions 
is particularly important. 

The System Flags area is an important place to check, if the base station is not 
behaving as expected; Task Manager actions may be responsible. 
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Loopback When the Loopback flag is enabled, audio from the line input is connected 
directly to line output. Loopback can only happen if the current channel 
profile’s signal path has a line input and a line output. A balanced input can only 
be looped back to a balanced output and an unbalanced input can only be 
looped back to an unbalanced output. By default, the flag is disabled.

Intercom When the Intercom flag is enabled, a technician at the base station can 
communicate with a console over the line. The Base Station’s microphone is 
connected to line output. When the flag is disabled, the microphone is 
disconnected, but the speaker still remains connected to the receiver Path A.

Tx Key When the Tx Key flag is enabled, the Tx Key line on the system interface can 
be used to key up the transmitter. When the flag is disabled, you can still 
transmit microphone audio using the PTT key, but the Tx Key line has no 
effect, which means that line audio is not transmitted.

Receiver When the Receiver flag is enabled, the receiver is able to receive as usual, 
according to the current channel configuration. When the flag is disabled, the 
receiver is unable to pass any received audio.

Transmitter When the Transmitter flag is enabled, the transmitter is able to transmit as usual, 
according to the current channel configuration. When the flag is disabled, the 
transmitter is unable to transmit signal at all.

Talk through 
repeater

When the Talk through repeater flag is enabled, the base station feeds received 
audio into the transmitter according to the current channel profile. (Edit 
Channel Profile form: Audio Path tab. The Talk-through repeater box 
specifies the audio path.) When the flag is disabled, the transmitter is not given 
audio from the receiver. 

Line connected 
base

When the Line connected base flag is enabled, the base station feeds line in 
audio into the transmitter according to the current channel profile. (Edit 
Channel Profile form: Audio Path tab. The Tx audio path A or Tx audio 
path A check box must be selected.) When the flag is disabled, the transmitter 
is not given line in audio. 

Power save When the Power save flag is enabled, the base station applies power saving 
according to the current channel profile (Edit Channel Profile form: General 
tab). When the flag is disabled, power saving is not applied.

Auxiliary supply When the Auxiliary supply flag is enabled, the auxiliary power output is turned 
on, if the optional auxiliary power supply PCB is fitted to the PMU, and if it is 
configured to be under the control of Task Manager (Configure > Base Station 
> Miscellaneous, Auxiliary power control box). If the Auxiliary supply flag is 
disabled, the auxiliary power is turned off, unless it is configured for battery 
charging (on when the AC mains supply is on). 

Over the air alarm When the Over the air alarm flag is enabled, an alarm is sent over the air 
according to the configuration in Configure > Alarms > Notification Methods: 
Over the air notification area. When the flag is disabled, the over the air alarm 
is turned off.
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Over the line 
alarm

When the Over the line alarm flag is enabled, an alarm is sent over the line 
according to the configuration in Configure > Alarms > Notification Methods: 
Over the line notification area. When the flag is disabled, the over the line alarm 
is turned off.

Email service When the Email alarms flag is enabled, any alarms are sent via email according 
to the configuration in Configure > Communications > Email. When it is 
disabled, alarms are not sent via email.

Syslog service When the syslog service flag is enabled, the base station sends any alarms and an 
optional heartbeat as syslog messages over its Ethernet interface. It operates 
according to the configuration in Configure > Communications > Syslog. 
When the flag is disabled, no syslog messages are sent.

CWID When the CWID flag is enabled, the base station transmits a continuous wave 
ID (Morse code) according to the current channel profile (Edit Channel Profile 
form: CWID System tab). When the flag is disabled, no Morse code is 
transmitted.

Subaudible 
encode

When the Subaudible encode flag is enabled, the base station encodes audio 
according to the current signalling profile (Edit Signalling Profile form: 
Subaudible signalling tab). When the flag is disabled, subaudible signalling is not 
added to audio.

Subaudible 
decode

When the Subaudible decode flag is enabled, the base station decodes any 
subaudible signalling according to the current signalling profile (Edit Signalling 
Profile form: Subaudible signalling tab). When the flag is disabled, subaudible 
signalling is not decoded, which means that there is no receiver gating based on 
subaudible signalling.

H/W channel 
select

When the H/W channel select flag is enabled, the base station uses the channel 
number specified by external equipment. This equipment sets the channel number 
using channel selection lines on the system interface (see Configure > Base Station 
> System Interface. The Channel selection check box must be enabled.) When 
the flag is disabled, the base station uses the default channel (set in Configure > 
Base Station > General) or a channel specified by Task Manager action. 

Tx Relay When the Tx Relay flag is enabled in a simplex system, the base station can use 
the Tx Relay Driver line on its system interface to switch a relay that connects 
the transmitter or the receiver to the antenna. When Tx Relay is disabled, the 
Tx Relay Driver line has no effect.

Transmit power 
override

When the Transmit power override flag is enabled, the PA transmits using the 
Task Manager override power level set in the current channel profile. When 
the flag is disabled, the PA transmits using its normal power level 

Monitoring Recent Actions
The Recent Actions form displays the last 40 tasks that Task Manager carried 
out. This display shows you the situation when you opened the form: the 
display does not automatically update. 

Note: To see the current state of many parameters that Task 
Manager monitors, select Monitor > Task Manager > System Flags. 
These flags have a default state and are only altered when Task 
Manager executes a task.
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To monitor recent Task Manager actions

1. Select Monitor > Task Manager > Recent Actions. 

2. If you want to update the display, click Read Last 40 Statements. 
Statements (actions) executed after you opened the form are added to the 
display.

Viewing Timers
The Timers form (Monitor > Task Manager > Timers) displays the current 
state of any timers that you configured for Task Manager. 

The Name column lists the timers. A bar graph shows how far each timer has pro-
gressed towards its maximum value, which is displayed in the Maximum column. 

Viewing Counters
The Counters form (Monitor > Task Manager > Timers) displays the current 
state of any counters that you configured for Task Manager. 

The Name column lists the counters. A bar graph shows how far each counter 
has progressed towards its maximum value, which is displayed in the Maximum 
column.

Viewing Flag States
The Flags form (Monitor > Task Manager > Timers) displays the current state 
of any custom flags that you configured for Task Manager. 

Each of the possible flags has an LED alongside it. A Green LED means that the 
timer is set. A gray LED means that is is cleared.
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Glossary

This glossary contains an alphabetical list of terms and 
abbreviations related to the TB8100 base station. For 
information about trunking, mobile, or portable terms, consult 
the glossary provided with the relevant documentation.

A

access level There are three different levels of access to a base station: 
Administrator, User, and Read-only. The User access level has a 
configurable access profile; the Administrator decides which 
functions that access level can carry out.

action An action is the second part of a Task Manager task. It specifies 
what the base station must do when the first part (the input) 
becomes true.

active Digital outputs are active when the base station pulls their voltage 
low and current is flowing. Digital inputs are active when 
external equipment is pulling them to ground. All base station 
digital inputs and outputs are open collector.

ADC Analog-to-Digital Converter. A device for converting an analog 
signal to a digital signal that represents the same information.

Alarm log The alarm log is a list of the last 50 alarms that the base station 
generated. This list is stored in the base station. To view it, select 
Monitor > Alarms > Reported Alarms.

Alarm Center Alarm Center is a utility provided with the Service Kit that is able 
to receive, store, and display alarms from any number of base 
stations with dial-up connections. Participating base stations need 
an Alarm Reporting license. Alarm Center also routes emailed 
messages to the email server.

alarm notification Alarm notification is the process by which the base station passes 
on information about an alarm condition. It can notify alarms 
over the air, over the line, via email, or to an Alarm Center. It 
can also activate a digital output. If the Service Kit is logged on 
to the base station, it is automatically notified of any alarms.
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air intake 
temperature

The temperature of the air as measured at the PA’s air intake.

anti-kerchunking Anti-kerchunking is a base station configuration that discourages 
users from kerchunking. 

B

balanced line A balanced line has two wires carrying equal and opposite signals. 
It is typically used in a line-connected base station for connecting 
to the despatcher console. The system interface identifies the 
balanced line in as Rx+ and Rx-, and the balanced line out as 
Tx+ and Tx-.

BCD BCD (binary coded decimal) is a code in which a string of four 
binary digits represents a decimal number.

C

Calibration Kit The TB8100 Calibration Kit is a utility for defining the 
switching ranges of the receiver and the exciter and for flattening 
the receiver response across its switching range. It can also be 
used to calibrate various parts of the reciter and the PA circuitry.

channel A channel is:
1. A frequency pair (or just a single frequency in a simplex 
system).
2. A set of configuration information that defines the frequency 
pair and other settings. Also referred to as a channel 
configuration. Generally, ‘channel’ has this meaning in the 
Service Kit.

channel profile A channel profile is a named set of configuration items relating 
to the base station’s RF configuration, transmitter power output 
and power saving modes. Like the signalling profile, it can be 
applied to any channel. Together, these profiles define most 
configuration items.

channel spacing Channel spacing is the bandwidth that a channel nominally 
occupies. If a base station has a channel spacing of 12.5 kHz, 
there must be a separation of at least 12.5 kHz between its 
operating frequencies and those of any other equipment. 
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channel table The channel table is the base station’s database of channel 
configurations. To view it, select Configure > Base Station > 
Channel Table.

CODEC An IC which combines analog-to-digital conversion (coding) 
and digital-to-analog conversion (decoding).

configuration file A configuration file consists of all the configuration settings 
needed for a base station, stored as a file in the configurations 
folder. Configuration files have the extension *.t8c.

connection A connection is a named group of settings that the Service Kit 
uses when establishing communications with a base station.

control bus The control bus is used for communications between modules in 
a base station system. It is an I2C bus, a bi-directional two-wire 
serial bus which is used to connect integrated circuits (ICs). I2C 
is a multi-master bus, which means that multiple chips can be 
connected to the same bus, and each one can act as a master by 
initiating a data transfer. 

control panel The control panel is an area at the front of the base station with 
buttons, LEDs and other controls that let you interact with the 
base station.

CTCSS CTCSS (continuous tone controlled squelch system), also 
known as PL (private line) is a type of signalling that uses 
subaudible tones to segregate groups of users.

custom action A custom action is a user-defined Task Manager action that 
consists of more than one pre-defined action.

custom input A custom input is a user-defined Task Manager input that 
consists of a combination of pre-defined inputs.

CWID CWID (Continuous Wave IDentification) is a method of 
automatically identifying the base station using a Morse code. 
Continuous wave means transmission of a signal with a single 
frequency that is either on or off, as opposed to a modulated 
carrier. 
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D

DAC Digital-to-Analog Converter. A device for converting a digital 
signal to an analog signal that represents the same information.

DCS DCS (digital coded squelch), also known as DPL (digital private 
line), is a type of subaudible signalling used for segregating groups 
of users. DCS codes are identified by a three-digit octal number, 
which forms part of the continuously repeating codeword. 
When assigning DCS signalling for a channel, you specify the 
three-digit code.

de-emphasis De-emphasis is a process in the receiver that restores pre-
emphasised audio to its original relative proportions. 

duty cycle Duty cycle is used in relation to the PA. It is the proportion of 
time (expressed as a percentage) during which the PA is operated. 
The TB8100 PA can be operated continuously. 

E

EIA Electronic Industries Alliance. Accredited by the American 
National Standards Institute (ANSI) and responsible for 
developing telecommunications and electronics standards in the 
USA.

EMC Electromagnetic Compatibility. The ability of equipment to 
operate in its electromagnetic environment without creating 
interference with other devices.

ETSI European Telecommunications Standards Institute. The non-
profit organisation responsible for producing European 
telecommunications standards.

F

flag A flag is a programming term for a “yes/no” indicator used to 
represent the current status of something. The base station has a 
set of system flags that are read and set by Task Manager. There 
is also a separate set of flags that you can use in your own Task 
Manager tasks. 
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frequency band The range of frequencies that the equipment is capable of 
operating on.

front panel The cover over the front of the base station containing fans for 
the PA and PMU.

G

gating Gating is the process of opening and closing the receiver gate. 
When a valid signal is received, the receiver gate opens. 

H

hiccup mode Many power supplies switch off in the event of a short-circuit 
and try to start again after a short time (usually after a few 
seconds). This “hiccup”-type of switching off and on is repeated 
until the problem is eliminated.

hysteresis Hysteresis is the difference between the upper and lower trigger 
points. For example, the receiver gate opens when the upper 
trigger point is reached, but will not close until the level falls to 
the lower trigger point. An adequate hysteresis prevents the 
receiver gate from repeatedly opening and closing when the level 
is about that of the trigger point. 

Hysteresis mode A mode of PMU operation designed to save power. The PMU 
is mainly turned off, but switches back on intermittently to 
maintain output voltage when the output current is low.

I

inactive Digital outputs are inactive if the base station is doing nothing to 
them. They are floating, open collector outputs. Digital inputs 
are inactive when they are open circuit. 

Intercom mode Intercom mode makes it possible for the operator at the dispatch 
center and the servicing technician at the base station to 
communicate with each other over the line. It connects the base 
station microphone to line out.
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isolator An isolator is a passive two-port device which transmits power in 
one direction, and absorbs power in the other direction. It is used 
in a PA to prevent damage to the RF circuitry from high reverse 
power.

K

kerchunking Kerchunking is transmitting for a second or less without saying 
anything in order to test the base station. This results in a 
‘kerchunk’ sound.

L

line-controlled base 
station

A TB8100 is a line-controlled base station when it receives audio  
(sending it out via its systems interface), transmits audio received 
over its systems interface, and its transmitter is keyed via the Tx 
Key line.

logging on Once you are connected, you can log on to a base station. This 
establishes communications between the Service Kit and a 
particular base station.

N

navigation pane The navigation pane is the left-hand pane of the Service Kit 
application window. It displays a hierarchical list of items. When 
you click an item, the main pane displays the corresponding 
form.

0

operating range Operating range is another term for switching range.

P

PA The PA (power amplifier) is a base station module that boosts the 
exciter output to transmit level.
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PMU The PMU (power management unit) is a module that provides 
power to the subrack.

pre-emphasis Pre-emphasis is a process in the transmitter that boosts higher 
audio frequencies. 

R

reciter The reciter is a module of a TB8100 base station that acts as 
receiver and exciter.

reverse tone burst Reverse tone bursts can be used with CTCSS. When reverse 
tone bursts are enabled, the phase of the generated tones is 
reversed for a number of cycles just before transmission ceases. If 
the receiver is configured for reverse tone burst, it responds by 
closing its gate.

RSSI RSSI (Received Signal Strength Indicator) is a level in dBm or 
volts that indicates the strength of the received signal. 

Run mode Run mode is the normal operating mode of the base station.

signalling profile A signalling profile is a named set of configuration items related 
to signalling that can be applied to any channel. Items include 
subaudible signalling and transmit timers. 

S

sensitivity The sensitivity of a radio receiver is the minimum input signal 
strength required to provide a useable signal.

SINAD SINAD (Signal plus Noise and Distortion) is a measure of signal 
quality. It is the ratio of (signal + noise + distortion) to (noise + 
distortion). A SINAD of 12 dB corresponds to a signal to noise 
ratio of 4:1. The TB8100 can provide an approximate SINAD 
value while in service by comparing the in-band audio against 
out-of-band noise. This value should not be relied upon to make 
calibrated measurements.

Sleep mode Sleep mode is a power saving state in which a part of the base 
station is switched off, and then periodically switched on again. 
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Standby mode Standby mode is a mode of base station operation in which active 
service is suspended so that special operations can be carried out, 
such as programming the base station with a new configuration. 

status message A status message is a set of information about the base station that 
can be emailed. It identifies the base station, indicates the current 
operating channel, lists the status of all alarms, and gives the 
current values of a number of other monitored parameters. It also 
contains the alarm log. 

subaudible 
signalling

Subaudible signalling is signalling that is at the bottom end of the 
range of audible frequencies. The TB8100 base station supports 
CTCSS and DCS subaudible signalling. 

subtone A subtone (subaudible signalling tone) is a CTCSS tone or a DCS 
code. 

switching range The switching range is the range of frequencies (about 10 MHz) 
that the equipment is tuned to operate on. This is a subset of the 
equipment’s frequency band.

system flag System flags are binary indicators that are read and set by Task 
Manager. Generally, they are used to disable or enable 
configured base station functions.

system interface The system interface is the set of inputs to and outputs from the 
base station (excluding power and RF), provided by a board 
inside the reciter. A range of different boards are available for 
different applications. 

T

TB8100 Base Station A Tait TB8100 base station consists of the equipment necessary 
to receive and transmit on one channel. Generally, this means a 
reciter, a PA, and a PMU. Often abbreviated to TB8100 or base 
station. 

Talk Through 
Repeater

A TB8100 is a talk through repeater when its audio path is 
configured to pass the audio it receives on to the transmitter.

Task Manager Task Manager is a part of the TB8100 base station firmware that 
carries out tasks in response to inputs. These tasks are formulated 
using the Service Kit.
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template file A template file contains configuration information that can be 
used to create a new base station configuration. Template files 
have the extension *.t8t.

transmit lockout The transmit lockout feature prevents the base station from 
transmitting for a time once the transmit timer has expired. It is 
designed to prevent users from monopolizing the base station.

U

Unbalanced line An unbalanced line has one wire earthed. It is typically used for 
short connections, for example, between a base station and a 
repeater on the same site. The system interface identifies the 
wires of unbalanced lines with Rx audio, Tx audio, and Audio 
Ground. Audio Ground is common to line in and line out.

V

valid signal A valid signal is a signal that the receiver responds to by opening 
the receiver gate. A signal is valid for example when it is stronger 
than a minimum level and when it has the specified subtone.

VSWR Voltage Standing Wave Ratio (VSWR) is the ratio of the 
maximum peak voltage anywhere on the line to the minimum 
value anywhere on the line. A perfectly matched line has a 
VSWR of 1:1. A high ratio indicates that the antenna subsystem 
is poorly matched.

W

Watchdog A watchdog circuit checks that the system is still responding. If 
the system does not respond (because the firmware has locked 
up), the circuit resets the system. 
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Index

A
AC mains supply, state of 76
access level 47
access profile 54
AC-DC converter 70, 76
actions (Task Manager) 199

alarm 207
channel profile 203
custom 208
general 199
signalling profile 205
System I/O 206

Add Channel Profile dialog box, accessing 104
Administrator access level 47
advanced profile features 103
Advanced Profiles and Task Manager license 15,

103
air intake temperature 74
alarm 13, 141

adjusting thresholds 153
configuring for fan 90
disabling 152
emailing 159
flashing icon 20
list of recent 151
monitoring 143
monitoring from Service Kit 20
notification methods 155
notifying Alarm Center 157
over the air 155
over the line 156
polling interval 37
reported alarms 151
Task Manager actions 207
Task Manager inputs 196
turning over-the-air alarm on and off 207
turning the over-the-line alarm on and off

207
using CWID as 121
using pip tone as 155

Alarm Center 12
sending alarms to 157

alarm log 151
clearing (by Task Manager action) 207
saving to file 151
sending (by Task Manager action) 208

alarm notification 13
setting up 13

Alarm Reporting license 15
Alarm status LED 68
antenna relay 91
anti-kerchunking 130
application window 31
audio filter 115
audio input

measuring level of 169
monitoring 73
monitoring level of 73
summing from line and receiver 114

audio output
configuring line level 115
generating 170
monitoring 73
monitoring level of 73

audio path 113
automatic gain control 110
auxiliary power output

availability of 70
configuring 92
monitoring state of 77
testing 180

B
balanced line

measuring level of 169
bandwidth 135
base station

connecting to 44
connecting via Ethernet 36
connecting via rear serial port 44
controlling remotely from a computer 94
IP address of 82
monitoring IP address of 32
naming 82
network identity 82
operation mode 4
programming 51
resetting 48
resetting (by Task Manager action) 201
self-tests 164
testing 161
upgrading firmware 59

basic tasks 29
battery

configuring minimum voltage 92
state of 76
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battery backup
testing 179

battery charger
configuring auxiliary power as 92
monitoring state of 77

battery protection mode 149
battery voltage

monitoring 76
BCD format 85
Bypass checkbox 115, 118

C
calibration

date of 68
Carrier gating 110
CCI mode, enabling automatic entry into 94
Celsius 33
channel 5

adding 137
block copying 137
configuring 97
configuring for TaitNet 100
copying 137
defining a set of 99
editing (when custom profiles are used) 136
exporting 138
getting started 99
importing 138
profiles assigned to 71
selecting (by Task Manager action) 203
selecting default 82
selecting default (by Task Manager action)

204
selecting externally 85
selecting one to operate on 139
setting up 99
source of channel selection 72

Channel Guard see subaudible signalling
channel profile

adding 104
customizing the default 100
editing 107
list of 104
naming 108
Task Manager actions for 203
working with 104

channel spacing 135
of receiver 108
when block copying 138

channel table 5, 133
arrow in 133
working with 133

clock reference, source of 72
coded squelch see DCS code
comment, in Task Manager 188
compatibility file 59
configuration

creating 50
creating template from 52
file location 33
handling of older versions 58
printing 95
programming base station with 51
reading 50
saving to file 51
tutorial 24
viewing 22
ways of working with 49

connecting 44
remotely 12
via control panel 44
via Ethernet 45
via RS-232 44

connection 34
adding 37
copying 41
dial-up 12, 38
direct 37
displayed in status bar 32
editing 41
exporting 42
importing 42
intermittent 37
network 12
options 34
remote 35
slow 37
types of 34
using USB instead of a serial port 34
via asynchronous port switch 36, 39
via Ethernet 36
via rear serial port 35

connections tree 40
control panel

status of power supply to 77
testing 165
testing LEDs 165

counter
defining 211
Task Manager action 202
viewing 215

CTCSS 7
detect bandwidth 93
detection time 93
reject bandwidth 93
setting deviation of 109
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specifying tones 128
CTCSS characteristics 93
current channel 5

details of 71
Current Status form 143
custom action 11, 210

defining 211
viewing 211

custom input 11, 209
defining 210
viewing 209

custom profile 103
See channel profile and signalling profile

CWID 121
automatic transmission of 121
disabling (by Task Manager action) 204
transmitting (by Task Manager action) 205

D
dBm, converting to microvolts 88
DC-DC converter 70, 76
DCS code 7

matching base station’s code to radios’ code 7
setting deviation of 109
specifying 128

DCS end tone 131
Decode signal column 128
de-emphasis 115
Deep Sleep mode 8, 120
default channel 5

selecting 82
setting 139

default channel profile 100
default gateway 83
default profile 6
Default Radio System license 15
default signalling profile 102
Delay before relay opens box 91
diagnosing 23

how to 163
overview 161

dial-up connection 12, 38
digital input 84

mapping for channel selection 85
using to select channel 85
viewing pin numbers 84
viewing state of 171

digital output 84
activating (Task Manager action) 206
deactivating (Task Manager action) 206
toggling 171

viewing status of 171
Digital Private Line see DCS code 7
direct connection 37

access profile for 54
disconnecting 56
do now action 11
Download mode 4, 144

selecting 48
duty cycle

monitoring 74

E
email 159

disabling (by Task Manager) 208
testing 173

enabling additional features 61
Ethernet interface 36

connecting via 45
enabling 83

exciter, switching range of 67
Extended bypass check box 119
external channel selection 85

disabling 85
disabling (by Task Manager action) 202
mapping digital inputs for 85
testing 172

external reference
alarm 148
specifying frequency of 94

F
Fahrenheit 33
fan

alarms 90
emulating T800 89
monitoring operating hours 90
rotation detector 90
testing 175, 176, 179
testing (Task Manager action) 200

fault diagnosis 23
feature enabler 15
feature set

disabling 62
filter

bypassing 115, 118
on audio path 115

firmware
downgrading 59
folder for upgrade files 33
upgrading 59
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flag
defining 211
viewing 215

form 31
forward power 74

G
gating, of receiver 106
getting started 17

H
hang time 131
hardware channel selection 85

testing 172
heartbeat 160
heatsink temperature

of PA 175
of PMU 181

high pass filter 118
hysteresis, in receiver gating 111

I
idle time 107
IF and IF NOT tasks 10
inputs (Task Manager) 190

alarm 196
custom 209
for channel profile 192
for signalling profile 194
for system I/O 195
general 190

installation 24
intercom mode, disabling (by Task Manager ac-

tion) 201
interface See system interface board
IP address 82

display on status bar 32
isolator 69

K
kerchunking 130
keyup time

configuring 120

L
license file, folder to store in 33

license key 61
line in

setting expected level 119
line level

of input 119
setting for line out 115

line-controlled base station, disabling (by Task
Manager action) 203

local connection See direct connection
lock range

determining 168
lockout

of transmitter 130
log files, location of 33
logging on 46
loopback, enabling (Task Manager action) 200
low current option 8

M
Map Inputs button 85
mapping digital inputs 85
Max Tx deviation box 109
microphone

testing microphone channel switch 165
testing PTT operation 165

microvolts, converting to dBm 88
mid band 108, 135
mode 4

changing 48
viewing current 32

monitoring 21, 65
operational information 71
PA 74
PMU 75
polling interval 37
reciter 73
subaudible signalling 174

Morse code 121
multiple

in Channel Profiles form 104
in channel table 133

N
naming the base station 82
narrow band 108, 135
navigation pane 21, 31

red item in 163
network connection 12, 36, 40
Noise gating 110
Normal power saving mode 8, 120
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O
operating channel 139
operation mode 4
output current 77
over the air alarm

turning on and off 207
over the line alarm

turning on and off 207
Override actions (Task Manager) 10

P
PA

alarm status 145
monitoring air intake temperature 74
monitoring duty cycle 74
monitoring operational information on 74
monitoring temperature of 74, 175
not detected 146
power rating 69
state of power supply to 77
testing fault LED 175
version 69
viewing information on 68

password 47
changing 53

PGM800Win, comparing Service Kit with 3
pip tone

over the air 155
over the line 156

PMU
alarm status 149
auxiliary power output 92
available inputs 70
available outputs 70
configuring shutdown voltage 92
monitoring heatsink temperatures 181
monitoring operational information on 75
monitoring output current 77
monitoring output voltage 181
product code 70
serial number 70
submodules in 70
testing 179
testing fault LED 180
version 70
viewing information on 69

polling interval 37
Port Switch tab 39
power output

monitoring 74
of PA 74

setting 105, 110
to PA 77
to reciter 77

power saving 8
configuring 106, 119
effect on quality of service 8
overriding (by Task Manager action) 200

Power Saving Modes license 15
Power shutdown voltage box 92
Power startup voltage box 92
pre-emphasis 115
printing a configuration 95
Private Line see CTCSS tone
profile 6

advanced features of 103
programming base station 51

Q
quality of service 8

R
Read icon 50
Read only access level 47
receiver

audio path 114
disabling (by Task Manager action) 201
idle time 107
lock range 168
measuring received signal level 167
operating without a configuration 166
switching range 67
testing 166

Receiver channel box 108, 109
receiver gating 110

configuring 106
receiver sensitivity

AGC affects 110
testing 167

receiver squelch 110
reciter

alarm status 144
lock range 168
monitoring operational information on 73
power-up failure 144
serial number of 68
state of power supply to 77
testing 166
version 68
viewing information on 67

Relay closing settling time box 91
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relay line 91
reminder tone 126

enabling 129
remote connection 12

access profile for 54
repeater

setting gain of 109
reported alarms 151
Reported Alarms form 151
resets, number of 68
resetting the base station 48
reverse power 74
reverse tone burst 131
RF power output

setting 105, 110
RSSI

alarm 148
monitoring 73

RSSI gating 110
RSSI output

configuring 86
setting a voltage 173
testing 172

Run mode 4
automatically reverting to 93
F5 goes to 48

Rx cycling 107, 120
Rx Gate output

toggling 171
viewing status of 73, 171

S
See channel table, entry in profile dialog box 100
self-tests 164
sensitivity of receiver 167
serial port 37

USB to serial converter 34
Service Kit

appllication window 31
installing 24
monitoring alarms 20

signal level
measuring across band 167

signal path 113
signalling profile

adding 124
customising the default 102
editing 127
list of 124
Task Manager actions 205
Task Manager inputs 194

working with 124
simplex 91, 136
SINAD

measurement method 166
monitoring 73

SINAD gating 110
Sleep mode 8, 120
Soft-off time 132
software feature enabler 15, 61
speaker, testing 165
speech band filter 115
squelch See receiver gating
squelch tail 130
Standby converter

state of DC supply to 76
Standby mode 4

F5 goes to 48
Start after box 107, 120
status bar 32
subaudible band filter 115
Subaudible deviation 109
subaudible signalling 7

disabling decoding of (Task Manager action)
205

disabling encoding of (Task Manager action)
206

monitoring 174
Subaudible Signalling tab 127
subtone 7

encoding options 129
specifying the ones to recognize 128

switching range 67
exciter 67
when last altered 68

synthesiser
alarm 145
determining lock range 168
out of lock 145

syslog collector 13
sending alarm messages to 160

syslog messages
disabling by Task Manager 208

system alarms 147
system flags 212
system I/O

Task Manager actions 206
system interface 14
system interface board 84

configuring for external channel selection 85
installed version 67
pin assignments on 84
viewing details of 84
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T
T800, comparing TB8100 with 3
t8n file 42
tail timers 130
TaitNet

configuring for 100, 115, 118
TaitNet Ethernet system interface 84
talk through repeater

disabling 203
Talk through repeater box 116
talk through repeater gain 109
task

adding 187
disabling 188
exporting 189
importing 189

Task Manager 9, 183
accessing 185
actions 10
adding comments 188
adding tasks 187
custom actions 208
customizing 209
disabling tasks 188
exporting tasks 189
flags 212
importing tasks 189
input types 10
inputs 190
monitoring recent actions 214
tasks 10
working with 186

TCP/IP interface 36
temperature

Celsius or Fahrenheit 33
monitoring on PA 74, 175
monitoring on PMU 181

template 52
test tone, generating 170
testing 23

audio output 170
auxiliary power output 180
battery backup 179
control panel 165
digital I/O 170
email 173
external channel selection 172
fan 175, 176, 179
I/O 169
lock range 168
PA 175
PA fault LED 175

PMU 179
PMU fault LED 180
receiver sensitivity 167
RSSI output 172
transmitter 176

Thresholds form 153
timer

defining (Task Manager) 211
starting (by Task Manager action) 202
stopping (by Task Manager action) 202
viewing 215

tone on idle 122
toolbar 31
traffic light 4, 48
transmit lockout 130
transmit timers 130
transmitter
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Tait General Software Licence Agreement

This legal document is an Agreement between you (the 
“Licensee”) and Tait Electronics Limited (“Tait”). By using any 
of the Software or Firmware items prior-installed in the related 
Tait product, included on CD or downloaded from the Tait 
website, (hereinafter referred to as “the Software or Firmware”) 
you agree to be bound by the terms of this Agreement. If you do 
not agree to the terms of this Agreement, do not install and use 
any of the Software or Firmware. If you install and use any of the 
Software or Firmware that will be deemed to be acceptance of the 
terms of this licence agreement.
The terms of this Agreement shall apply subject only to any 
express written terms of agreement to the contrary between Tait 
and the Licensee.

Licence
TAIT GRANTS TO YOU AS LICENSEE THE NON-EXCLUSIVE 
RIGHT TO USE THE SOFTWARE OR FIRMWARE ON A SINGLE 
MACHINE PROVIDED YOU MAY ONLY:
1. COPY THE SOFTWARE OR FIRMWARE INTO ANY MACHINE 
READABLE OR PRINTED FORM FOR BACKUP PURPOSES IN 
SUPPORT OF YOUR USE OF THE PROGRAM ON THE SINGLE 
MACHINE (CERTAIN PROGRAMS, HOWEVER, MAY INCLUDE 
MECHANISMS TO LIMIT OR INHIBIT COPYING, THEY ARE 
MARKED “COPY PROTECTED”), PROVIDED THE COPYRIGHT 
NOTICE MUST BE REPRODUCED AND INCLUDED ON ANY SUCH 
COPY OF THE SOFTWARE OR FIRMWARE; 
AND / OR

2. MERGE IT INTO ANOTHER PROGRAM FOR YOUR USE ON 
THE SINGLE MACHINE (ANY PORTION OF ANY SOFTWARE OR 
FIRMWARE MERGED INTO ANOTHER PROGRAM WILL 
CONTINUE TO BE SUBJECT TO THE TERMS AND CONDITIONS 
OF THIS AGREEMENT).

THE LICENSEE MAY NOT DUPLICATE, MODIFY, REVERSE 
COMPILE OR REVERSE ASSEMBLE ANY SOFTWARE OR 
FIRMWARE IN WHOLE OR PART.

Important Notice
THE SOFTWARE OR FIRMWARE MAY CONTAIN OPEN SOURCE 
SOFTWARE COMPONENTS (“OPEN SOURCE COMPONENTS”). 
OPEN SOURCE COMPONENTS ARE EXCLUDED FROM THE 
TERMS OF THIS AGREEMENT EXCEPT AS EXPRESSLY STATED IN 
THIS AGREEMENT AND ARE COVERED BY THE TERMS OF THEIR 
RESPECTIVE LICENCES WHICH MAY EXCLUDE OR LIMIT ANY 
WARRANTY FROM OR LIABILITY OF THE DEVELOPERS AND/OR 
COPYRIGHT HOLDERS OF THE OPEN SOURCE COMPONENT 
FOR THE PERFORMANCE OF THOSE OPEN SOURCE 
COMPONENTS. YOU AGREE TO BE BOUND BY THE TERMS AND 
CONDITIONS OF EACH SUCH LICENCE. FOR MORE 
INFORMATION SEE:
http://support.taitworld.com/go/opensource

Title to Software 
THIS AGREEMENT DOES NOT CONSTITUTE A CONTRACT OF 
SALE IN RELATION TO THE SOFTWARE OR FIRMWARE SUPPLIED 
TO THE LICENSEE. NOT WITHSTANDING THE LICENSEE MAY 
OWN THE MAGNETIC OR OTHER PHYSICAL MEDIA ON WHICH 
THE SOFTWARE OR FIRMWARE WAS ORIGINALLY SUPPLIED, OR 
HAS SUBSEQUENTLY BEEN RECORDED OR FIXED, IT IS A 
FUNDAMENTAL TERM OF THIS AGREEMENT THAT AT ALL 
TIMES TITLE AND OWNERSHIP OF THE SOFTWARE OR 
FIRMWARE, WHETHER ON THE ORIGINAL MEDIA OR 
OTHERWISE, SHALL REMAIN VESTED IN TAIT OR THIRD 
PARTIES WHO HAVE GRANTED LICENCES TO TAIT.

Term and Termination 
THIS LICENCE SHALL BE EFFECTIVE UNTIL TERMINATED IN 
ACCORDANCE WITH THE PROVISIONS OF THIS AGREEMENT. 
THE LICENSEE MAY TERMINATE THIS LICENCE AT ANY TIME BY 
DESTROYING ALL COPIES OF THE SOFTWARE OR FIRMWARE 
AND ASSOCIATED WRITTEN MATERIALS. THIS LICENCE WILL BE 
TERMINATED AUTOMATICALLY AND WITHOUT NOTICE FROM 
TAIT IN THE EVENT THAT THE LICENSEE FAILS TO COMPLY 
WITH ANY TERM OR CONDITION OF THIS AGREEMENT. THE 
LICENSEE AGREES TO DESTROY ALL COPIES OF THE SOFTWARE 
OR FIRMWARE AND ASSOCIATED WRITTEN MATERIALS IN THE 
EVENT OF SUCH TERMINATION.

Limited Warranty 
THE SOFTWARE OR FIRMWARE (INCLUDING OPEN SOURCE 
COMPONENTS) IS SUPPLIED BY TAIT AND ACCEPTED BY THE 
LICENSEE “AS IS” WITHOUT WARRANTY OF ANY KIND EITHER 
EXPRESSED OR IMPLIED, INCLUDING BUT NOT BEING LIMITED 
TO ANY IMPLIED WARRANTIES AS TO MERCHANTABILITY OR 
FITNESS FOR ANY PARTICULAR PURPOSE. THE LICENSEE 
ACKNOWLEDGES THAT THE SOFTWARE OR FIRMWARE 
(INCLUDING OPEN SOURCE COMPONENTS) IS USED BY IT IN 
BUSINESS AND ACCORDINGLY TO THE MAXIMUM EXTENT 
PERMITTED BY LAW NO TERMS OR WARRANTIES WHICH ARE 
IMPLIED BY LEGISLATION SHALL APPLY TO THIS AGREEMENT. 
TAIT DOES NOT WARRANT THAT THE FUNCTIONS CONTAINED 
IN THE SOFTWARE OR FIRMWARE (INCLUDING OPEN SOURCE 
COMPONENTS) WILL MEET THE LICENSEE’S REQUIREMENTS OR 
THAT THE OPERATION OF THE SOFTWARE OR FIRMWARE 
(INCLUDING OPEN SOURCE COMPONENTS) WILL BE 
UNINTERRUPTED OR ERROR FREE.

Exclusion of Liability
IN NO CIRCUMSTANCES SHALL TAIT BE UNDER ANY LIABILITY 
TO THE LICENSEE, OR ANY OTHER PERSON WHATSOEVER, 
WHETHER IN TORT (INCLUDING NEGLIGENCE), CONTRACT 
(EXCEPT AS EXPRESSLY PROVIDED IN THIS AGREEMENT), 
EQUITY, UNDER ANY STATUTE, OR OTHERWISE AT LAW FOR 
ANY LOSSES OR DAMAGES WHETHER GENERAL, SPECIAL, 
EXEMPLARY, PUNITIVE, DIRECT, INDIRECT OR 
CONSEQUENTIAL ARISING OUT OF OR IN CONNECTION WITH 
ANY USE OR INABILITY OF USING THE SOFTWARE OR 
FIRMWARE (INCLUDING OPEN SOURCE COMPONENTS).

THE LICENSEE’S SOLE REMEDY AGAINST TAIT WILL BE LIMITED 
TO BREACH OF CONTRACT AND TAIT’S SOLE AND TOTAL 
LIABILITY FOR ANY SUCH CLAIM SHALL BE LIMITED AT THE 
OPTION OF TAIT TO THE REPAIR OR REPLACEMENT OF THE 
SOFTWARE OR FIRMWARE OR THE REFUND OF THE PURCHASE 
PRICE OF THE SOFTWARE OR FIRMWARE.

General
THE LICENSEE CONFIRMS THAT IT SHALL COMPLY WITH THE 
PROVISIONS OF LAW IN RELATION TO THE SOFTWARE 
OR FIRMWARE.

Law and Jurisdiction 
THIS AGREEMENT SHALL BE SUBJECT TO AND CONSTRUED IN 
ACCORDANCE WITH NEW ZEALAND LAW AND DISPUTES 
BETWEEN THE PARTIES CONCERNING THE PROVISIONS 
HEREOF SHALL BE DETERMINED BY THE NEW ZEALAND 
COURTS OF LAW. PROVIDED HOWEVER TAIT MAY AT ITS 
ELECTION BRING PROCEEDINGS FOR BREACH OF THE TERMS 
HEREOF OR FOR THE ENFORCEMENT OF ANY JUDGEMENT IN 
RELATION TO A BREACH OF THE TERMS HEREOF IN ANY 
JURISDICTION TAIT CONSIDERS FIT FOR THE PURPOSE OF 
ENSURING COMPLIANCE WITH THE TERMS HEREOF OR 
OBTAINING RELIEF FOR BREACH OF THE TERMS HEREOF.

No Dealings 
THE LICENSEE MAY NOT SUBLICENSE, ASSIGN OR TRANSFER 
THE LICENCE OR THE PROGRAM EXCEPT AS EXPRESSLY 
PROVIDED IN THIS AGREEMENT. ANY ATTEMPT OTHERWISE TO 
SUBLICENSE, ASSIGN OR TRANSFER ANY OF THE RIGHTS, 
DUTIES OR OBLIGATIONS HEREUNDER IS VOID.

No Other Terms 
THE LICENSEE ACKNOWLEDGES THAT IT HAS READ THIS 
AGREEMENT, UNDERSTANDS IT AND AGREES TO BE BOUND BY 
ITS TERMS AND CONDITIONS. THE LICENSEE FURTHER AGREES 
THAT SUBJECT ONLY TO ANY EXPRESS WRITTEN TERMS OF 
AGREEMENT TO THE CONTRARY BETWEEN TAIT AND THE 
LICENSEE THIS IS THE COMPLETE AND EXCLUSIVE STATEMENT 
OF THE AGREEMENT BETWEEN IT AND TAIT IN RELATION TO 
THE SOFTWARE OR FIRMWARE WHICH SUPERSEDES ANY 
PROPOSAL OR PRIOR AGREEMENT, ORAL OR WRITTEN AND 
ANY OTHER COMMUNICATIONS BETWEEN THE LICENSEE AND 
TAIT RELATING TO THE SOFTWARE OR FIRMWARE.
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